View Full Version : Don't transcode, just play native format please.

01-07-2011, 05:06 AM
I have Mezzmo streaming to my Sony KDL-EX500 via wired ethernet cable. And I'm quite happy with it. BUT:
I would like Mezzmo to stream to the TV without transcoding to reduce CPU usage (almost 100% for Phenom II X550 dual core, 4GB).
I can play MP4 fileformat (videocodec: H264, audiocodec: AAC) movies with USB directly inserted in the TV (native format).
But when playing same file from PC harddisk via Mezzmo, it is always transcoded. Even when I turn off all transcoding in transcoding settings tab. MPEG-2 files without transcoding does work.
Is it possible to play untranscoded MP4 via Mezzmo.


01-07-2011, 08:53 AM
Yes, if the TV supports it. Please note that playing files from a USB does not mean they'll play via DLNA. Can you please provide FFmpeg information on the file that you'd like to play natively and we'll try it here (we've got an EX600 here) - in Mezzmo right-click on the file and use the "Get FFmpeg Information" command, then post results here.

01-07-2011, 09:49 PM
Hi Dennis,

Here's the FFmpeg information of the file:

FFmpeg version SVN-r26071, Copyright (c) 2000-2010 the FFmpeg developers
built on Dec 22 2010 10:30:32 with gcc 4.4.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-mingw32- --enable-static --disable-shared --enable-zlib --disable-ffprobe --disable-ffplay --prefix=/media/windows-share/ffmpeg --extra-cflags=-U__STRICT_ANSI__ --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect
libavutil 50.35. 0 / 50.35. 0
libavcore 0.16. 0 / 0.16. 0
libavcodec 52.100. 0 / 52.100. 0
libavformat 52.88. 0 / 52.88. 0
libavdevice 52. 2. 2 / 52. 2. 2
libavfilter 1.69. 0 / 1.69. 0
libswscale 0.12. 0 / 0.12. 0
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'E:\MijnVideos\Movies\Keizer Kuzco\Keizer Kuzco.mp4':
major_brand : isom
minor_version : 512
compatible_brands: isomiso2avc1mp41
creation_time :
title : Keizer Kuzco
date : 2011
encoder : Lavf52.33.0
Duration: 01:15:11.31, start: 0.000000, bitrate: 2249 kb/s
Stream #0.0(und): Video: h264, yuv420p, 848x504, 2118 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc
creation_time :
Stream #0.1(und): Audio: aac, 48000 Hz, stereo, s16, 127 kb/s
creation_time :
At least one output file must be specified

---> DB Level Info: 31

None of the MP4 files (same codecs) play without transcoding.


01-10-2011, 09:36 AM
I've tried it here and I don't think the TV supports MP4 over DLNA. It doesn't show the files at all, no matter what their mime type is. If there's another server that plays these files without transcoding on the TV, please let me know and I'll investigate further, but for the time being I believe they should be transcoded.