PDA

View Full Version : VBR mp3 playback hangs



JNME
01-15-2011, 12:54 AM
I noticed when playing mp3 audio from Mezzmo (v 2.1.12.0) on my Sony BDP-S570 Blu-Ray Player (Profile: Sony BDP (NTSC, no DivX)), the playback will hang on some songs saying the file is corrupt or not supported. If I exit the album then reenter and play that song, it plays without problem but then will hang after one or more songs play. It does not appear to be related to the specific song and occurs in multiple albums. Usually not more than 2-4 songs play before it hangs.

I noticed that this occurs only on variable bit rate (VBR) mp3 but have not observed it when playing either transcoded m4a files or when playing fixed bit rate mp3. I also noticed that after this occurred, Win Task Manager would by multiple VLC processes left open. VLC (v. 1.1.5) was configured using the default settings. I changed the VLC advanced settings selecting "Allow only one running instance" and "Enqueue items in playlist when in one instance mode" (in addition to "One instance when started from file" which is selected in the default configuration). I subsequently played ten VBR mp3 with no problems. I will continue to monitor but this seems to resolve the hangs. (log files available on request)

JNME
01-17-2011, 05:13 AM
Seems I failed to test this thoroughly. I noticed that m4a files now fail occasionally. In either case, the hang fails as a song ends and the next is queued. I noticed that when it occurs, the VLC process does not close regardless of the settings in VLC.

Paul
01-17-2011, 10:42 AM
It's possible that you're experiencing a network streaming issue we're working on fixing right now. Please send a message to support to get a patch once it's ready.

Mezzmo does not use VLC or any codecs on your system - all transcoding is self-contained within the bundled FFmpeg.