PDA

View Full Version : Transcoder settings greyed out



Mark
01-19-2011, 05:43 AM
In transcoding settings the "complete partially transcoded audio/video files in background" is unchecked and greyed out.
The "Use low priority CPU when completing partially transcoded audio/video files" is checked and also greyed out.
Max number of transcoders is set to 1.

Should these checkboxes be greyed out?

Paul
01-19-2011, 08:35 AM
No, they shouldn't be grayed out. Is the FFmpeg folder set correctly? Do you see a Build date?

Mark
01-19-2011, 08:55 AM
FFmpeg installed with Mezzmo ver 4.1.1 I believe it was. I had FFmpeg 3.1 installed so I uninstalled it first, then installed Mezzmo2.1.12. Not quite sure what you mean by set correctly, do you mean pathed? In Transcoder Setttings I have C:\Mezzmo in ffmpeg application folder and ffmpeg.exe exists in the folder. FFmpeg runs as a process when I transcode so I presume everything is setup properly. There isn't a build date under file properties. Said it was version 4.1.1 I think when it installed last week.

Paul
01-19-2011, 08:58 AM
Sorry, I missed a crucial point :) Change the max number of transcoders to 2 or larger and it should re-enable then.

The FFmpeg build date is shown right under the FFmpeg application folder.

Mark
01-19-2011, 02:20 PM
This will probably sound stupid but where would I see the FFmpeg application folder? Somewhere on the Mezzmo GUI I presume.

Paul
01-19-2011, 02:27 PM
It's in the Transcoding settings dialog - the one with the number of transcoders - at the top ;)

Mark
01-19-2011, 03:25 PM
Says; Warning: Could not get build date from FFmpeg.exe. Check that FFmpeg is operating correctly. Mezzmo transcoded a .mzt file. The only indicator I have that it may work. Can the MZT file be played to determine if it encoded correctly?

Paul
01-19-2011, 03:30 PM
Strange... Did you replace FFmpeg with your own one? When you mentioned that you had FFmpeg 3.1 and then you put in 4.4.1 - what did you mean? FFmpeg's versions are a bit different, e.g. SVN-r26397.

And yes, you can rename the .mzt to .mpeg (or .mkv - depending one the output format) and it'll play on your PC.

Mark
01-19-2011, 05:10 PM
No, just the opposite. I uninstalled an older version and installed Mezzmo which came with I presume a fairly recent version. Is there a way to ensure it's working correctly? I presume it is working right since it transcodes to my DirecTv fine, just not to my iPhone.

Paul
01-20-2011, 08:29 AM
Can you please post a screenshot of your Transcoding Settings dialog? It sounds like it's working ok, but for some reason the build date is not picked up correctly.

Mark
01-20-2011, 11:04 AM
Here's a screenshot...

Paul
01-20-2011, 11:13 AM
Thanks for the screenshot.

So, Mezzmo is installed in C:\Mezzmo and ffmpeg.exe is there, right? If you run your command prompt and type C:\Mezzmo\ffmpeg.exe - what do you get?

Mark
01-21-2011, 06:58 AM
I get...

FFmpeg version SVN-r26071, Copyright (c) 2000-2010 the FFmpeg developers
built on Dec 22 2010 10:30:32 with gcc 4.4.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-mingw32- --enable-static --di
sable-shared --enable-zlib --disable-ffprobe --disable-ffplay --prefix=/media/windows-share/ffmpeg --extra-cflags=-U__ST
RICT_ANSI__ --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect

libavutil 50.35. 0 / 50.35. 0
libavcore 0.16. 0 / 0.16. 0
libavcodec 52.100. 0 / 52.100. 0
libavformat 52.88. 0 / 52.88. 0
libavdevice 52. 2. 2 / 52. 2. 2
libavfilter 1.69. 0 / 1.69. 0
libswscale 0.12. 0 / 0.12. 0
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

Paul
01-21-2011, 08:23 AM
Thanks. Looks good to me. I am not sure what's wrong, but we'll take a closer look at the code that gets the version - maybe something is buggy there. In any case, transcoding is working, so it's only the version string that's amiss, right?

Mark
01-22-2011, 04:10 AM
Appears that way.

Trancera
01-22-2011, 04:28 AM
I had the same problem with them being greyed out so I set it to "Change the max number of transcoders to 2 or larger and it should re-enable then" Now the ffmpeg has no build date and while playing .mp4 movies there is no picture, just sound. Other file formats are ok but not .mp4


when I goto the ffmpeg download site im unsure what I should be downloading and how to install it into mezzmo, Dennis could you explain this please.

UPDATE: The video kicks in after about 20 seconds and seems fine, but when I goto transcoding settings the FFmpeg build date cannot be found even though the video is playing.

Mark
01-22-2011, 05:22 AM
In my case, FFmpeg installed during the Mezzmo installation. I also have an '07 FFdshow installation in another directory. Looks like FFmpeg with a config GUI. Don't expect this would cause any problems but could chunk it if necessary. If there is benefit to installing FFmpeg separately so that the build date is found I'm down for that.

Paul
01-24-2011, 09:13 AM
I had the same problem with them being greyed out so I set it to "Change the max number of transcoders to 2 or larger and it should re-enable then" Now the ffmpeg has no build date and while playing .mp4 movies there is no picture, just sound. Other file formats are ok but not .mp4


when I goto the ffmpeg download site im unsure what I should be downloading and how to install it into mezzmo, Dennis could you explain this please.
Which site are you trying to download FFmpeg from? Generally, you'll just replace the ffmpeg.exe in Mezzmo's installation folder (or use the Transcoding Settings to point to a different folder with a different FFmpeg), but if you plan to replace our stock FFmpeg, please make sure that it contains all the formats that are needed for your device. We do not support FFmpeg builds other than our own, so if it doesn't transcode, then we can't help you (because we do not control how it's built and what is included).


In my case, FFmpeg installed during the Mezzmo installation. I also have an '07 FFdshow installation in another directory. Looks like FFmpeg with a config GUI. Don't expect this would cause any problems but could chunk it if necessary. If there is benefit to installing FFmpeg separately so that the build date is found I'm down for that.
FFdshow shouldn't be a problem - we're not using it and FFmpeg itself is not using it either.

Trancera
01-30-2011, 02:34 AM
Which site are you trying to download FFmpeg from? Generally, you'll just replace the ffmpeg.exe in Mezzmo's installation folder (or use the Transcoding Settings to point to a different folder with a different FFmpeg), but if you plan to replace our stock FFmpeg, please make sure that it contains all the formats that are needed for your device. We do not support FFmpeg builds other than our own, so if it doesn't transcode, then we can't help you (because we do not control how it's built and what is included).


FFdshow shouldn't be a problem - we're not using it and FFmpeg itself is not using it either.

Im downloading it from within mezzmo in the check for updates to FFmpeg. I havnt installed anything as even though there is no build date etc my media still streams. Ill wait for the next mezzmo update and see if this sorts out the no ffmpeg build date problem.


Cheers.

Adric
01-31-2011, 03:16 PM
You could try to uninstall Mezzmo and reinstall it and see if that works better. You ffmpeg information should be 20th January 2011 for the latest version of Mezzmo.