PDA

View Full Version : Trouble - Sony BDP-S370 & FF/RW with 2.2.0.0



Aaron407
03-06-2011, 02:18 AM
With the new 2.2.0.0 update I'm finding that I'm now able to FF & RW in transcoding files on my Sony BDP-S370, even past a point that it has linearly transcoded to (I wish I could also do this on my PS3...). Although it's somewhat unstable and occasionally freezes, it's a nice feature to have.

HOWEVER, and very sadly to say, the new update has now taken away the ability to FF/RW streamed DivX files. Now, when pressing the FF or RW buttons, I'm told "This operation currently prohibited for this disc", which is what the last revision stated for files that were being transcoded. Is there possibly a profile I could get my hands on that would restore the DivX file FF/RW functionality? This is extremely important functionality in my mind.

Aaron407
03-06-2011, 03:10 AM
FYI, I've slightly modified the previous revision's SonyBDP-NTSC profile to temporarily fix this issue while retaining transcoding FF/RW capability while an official fix is worked out. I've attached the file in case anyone else wants to give it a try (make sure you back up your other one though). Seems to work ok, but I haven't tested it much yet.

EDIT: Try the profile listed in the post below, it should work better.

Aaron407
03-06-2011, 09:50 AM
I've attached another profile based off of the update profile that came with 2.2.0.0., but with a few tweaks. Correct me if I'm wrong, but it appears that the new problem with DivX not having seeking capabilities has to do with a DivX requirement to seek via byte range. The 2.2.0.0 profile initiates extended DLNA protocol capabilities, then enables time based seeking and turns off byte ranged seeking. By setting turnoffbyterangedlna="0" rather than 1 as the profile originally set, I believe you're allowing both time based and byte based seeking for the player's DLNA communication. This seems to work well on mine, but I'd be interested to see if it works for others.

ALSO, I was having issues with MP4's not playing back, even with transcoding. I changed a chunked MPEG_TS parameter back to what it was in the previous profile. This now allows all of my MP4's to play again, and they also benefit from the time based seeking allowance and can now be fast forwarded and rewound.

Anyway, the updated profile's attached, let me know if you have any luck with it. Make sure you remove the "Custom_3" part so Mezzmo will recognize it as the standard "SonyBDP-NTSC" profile.

EDIT: New .prf attached.

paulorox
03-06-2011, 11:56 AM
Yep, the first think I noticed with the new version of Mezzmo was the inability to FF & RWD with my divx files. This is a killer for me, especially with kids who want to FF to their fav parts of a film.

I will give your modified profile a little later on and report back.

Aaron407
03-06-2011, 02:38 PM
Any luck? Still seems to be working fine for me with the changes.

paulorox
03-06-2011, 09:54 PM
Yes, thanks.

All seems to be fine with your amended profile.

Paul
03-07-2011, 03:58 PM
Excellent work, Aaron407.

If there are any users with similar problems with Mezzmo v2.2, then contact us at support [at] conceiva [dot] com and we can supply the official device profile fix.

DEJ710
08-10-2011, 08:18 AM
Hi Aaron407,

Good job on this updated profile. I have been playing around with it a bit and have the following working ok for my Sony BDP-S370 (PAL):

1. MKV Support - Play OK
2. DIVX Support - Play OK
3. MP4 files get transcoded to M2TS but do not play. Error "Unsupported file format."

Do you have any suggestions on how to get the MP4 files to play on the Sony BDP-S370 for PAL?

Regards,

Jason
Melb, Australia