View Full Version : PS3, folders, missing files

04-30-2011, 10:19 PM
Hello Mezzmo users

All was well with DLNA - I was using Tversity and streaming any content I liked to my two PS3s.

Then I bought a Sony SMP-N100. That couldn't see Tversity. It could find WMP 12, but I don't like WMP. So I tried Mezzmo, and that worked with the N100 using one of the BDP profiles.

Unfortunately, the PS3s cannot see all the video files through Mezzmo that they could with Tversity. Yes, I'm in the Video section on the PS3, other video files play, servers have been stopped/started, the profile/IP address is correct, no firewall issues and all the videos show up in the Mezzo Windows UI. Transcoding is enabled.

I cannot see any reason why Mezzo won't play it when Tvserity will. Tversity was disabled, until I needed it to play these files again.

I've seen threads with similar problems that have turned out to be people in the wrong menu (not the case here) or wrong device profile (but I've got my PS3s set correctly).

What am I missing?

Here's the file info:

FFmpeg version git-N-28463-gc5dcb3d, Copyright (c) 2000-2011 the FFmpeg developers
built on Apr 20 2011 10:16:52 with gcc 4.4.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-mingw32- --enable-static --disable-shared --enable-zlib --disable-ffprobe --disable-ffplay --prefix=/media/windows/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --pkg-config=pkg-config
libavutil 50. 40. 1 / 50. 40. 1
libavcodec 52.120. 0 / 52.120. 0
libavformat 52.108. 0 / 52.108. 0
libavdevice 52. 4. 0 / 52. 4. 0
libavfilter 1. 79. 1 / 1. 79. 1
libswscale 0. 13. 0 / 0. 13. 0
Input #0, avi, from 'c:\avi\zzc\myfileS01E01.DVD.XviD.avi':
Duration: 00:22:55.41, start: 0.000000, bitrate: 1077 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 640x368 [PAR 1:1 DAR 40:23], 23.98 tbr, 23.98 tbn, 23.98 tbc
Stream #0.1: Audio: mp3, 48000 Hz, stereo, s16, 128 kb/s
At least one output file must be specified

---> DB Level Info: -99

05-02-2011, 10:54 AM

We've found that the PS3 doesn't like some DivX/XviD files - perhaps it's one of those files? When you try to play the same file using TVersity is it served natively or transcoded (you can check using file properties on the PS3)?

05-02-2011, 11:01 AM
It's transcoded. The PS3 doesn't like lots of files, so I liked the idea of transcoding. Is Mezzmo not transcoding something it should be? I went into properties for the device and tried to force it to Always Deliver content, made no difference.

05-02-2011, 11:05 AM
Yes, sounds like your transcoding is turned off, since the device profile (in the latest version 2.3.1) should transcode those files. Transcoding can be turned on/off in more than one place, so perhaps that's the issue? If you're sure it's turned on, please enable logging (see this thread: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging) then browse to that file and try to play it. After it fails, stop the server and send the logs to support (at) conceiva (dot) com and we'll investigate.

Also, please revert the Advanced tab settings back to default - they should work fine as-is.

05-02-2011, 11:15 AM
OK. All I saw was an option to turn off transcoding which is not checked. I have reset all Advanced to defaults. Where are all the places it can be turned off?

05-02-2011, 11:17 AM
If the Advanced is reset to default (and server is restarted), then the two remaining spots are the Media Device properties dialog and the Transcoding Settings dialog.

In the listing on the PS3, is the file listed as DivX/XviD or something else?

05-02-2011, 07:03 PM
OK transcoding is definitely on for Mezzmo. The file is delivered fine to the Sony SMP-N100 (don't know if it is transcoded for it or not). But the PS3 won't see it. The PS3 can play it by Tversity, but Tversity can't be accessed from the N100.

Checked the PS3 properties and it says video codec is:


which isn't a lot of help.

I can't even navigate to the file on the PS3 because I can't even get into the directory. The directory is shown but cannot be selected. I presume it doesn't let me in because Mezzmo thinks there is no content inside able to be played on the device. Therefore, not sure the logging will help?

Yes am running

Secondly Mezzmo just popped up a dialogue box to ask if a generic device on .207 could be permitted. This is annoying as .207 is the N100 which is already configured. I hope I'm not going to have to continually reconfirm this.

05-03-2011, 09:46 AM
If you can't get into the folder where the file is, how did you get the properties? Or are those properties from TVersity? I'm a bit confused :) Can you please turn on logging (see this thread: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging) then restart Mezzmo server, browse to that folder, enter it (if you can) and try to play the file (if you can). After that, stop the server and send the logs to support (at) conceiva (dot) com and we'll sort it out.

The N100 is a separate issue - does it have a static or a dynamic IP? Can you please send a screenshot of your Media Devices dialog along with the logs and we'll take a look at it as well.

05-03-2011, 09:58 AM
Sorry should have been clearer. The file info properties I posted above came from Mezzmo's properties on the PC. On the PS3 I cannot even access the folder to see the file, using Mezzmo. Using Tversity and others I can, and it says codec is - . Mezzmo is transcoding some things as there is data in the transcoded file folder.

When you say "browse the folder etc" is that from the PS3, or from the PC? Presuming from the PS3? It plays fine on the PC via Mezzmo.

Tried Twonky last night and it worked on both PS3 and N100 with no issues, yet to try PMS. However I shall persist with Mezzmo for a while as I prefer the PC UI, options and configuration. Don't mind paying for what appears to be a more functional product.

The N100 has a dynamic IP but with a long lease so it doesn't change. Will send screenshots.

05-03-2011, 10:00 AM
Yes, please browse the folder on the PS3 and then send logs for that. I'd also recommend clearing out the transcoded files folder before doing that, so that we can get a better picture.