PDA

View Full Version : Little problem with MKV



4L3xN3t
05-28-2011, 08:08 PM
Hi,
i've a problem in sharing a specific mkv file.
i had mezzmo 2.3.0.0 installed on my little server...everything worked fine except for the fact that mezzmo doesn't recognize a single mkv file. it's in the same folder in which are the other that works perfectly.
I tried to manually add the file, to refresh the folder...nothing!!!

I tried to update mezzmo to the latest 2.3.2.0 version but the problem is the same...

then i tried to install mezzmo on my desktop pc and, very strange, the file appeared and is able to be played on my tv.

any idea about the cause of the problem???

thank you!!!

4L3xN3t
05-29-2011, 06:49 PM
i've just finish to re-mux the file...it's very strange, now mezzmo recognize the file...
how is this possible???

Paul
05-30-2011, 10:18 AM
That does sound strange - I cannot explain it. Perhaps there was an old transcoded file cached by Mezzmo that your DLNA device could not handle. You can remove all your previously transcoded files by clicking the "Delete Transcoded Files" button in the Transcoding Settings dialog in Mezzmo.

4L3xN3t
05-30-2011, 11:59 PM
I have transcoding disabled and there are no old files transcoded...
most strange too is that renaming the new muxed file (the name is the previos + "x" at the end: "nameX.mkv) with the old name, the file disappear from the list...
it sounds like the sw remembers that the file named xyz have not to be played!!!
i've never seen nothing like that during my short life ;)

Paul
06-01-2011, 09:24 AM
After renaming the file on disk, please run maintenance in Mezzmo to update its database. If the file shows up in Mezzmo, but doesn't play on the device, please post FFmpeg information on that file (in Mezzmo right-click on the file and use the "Get FFmpeg Information" command) and also let me know which device you have and which device profile you are using.

4L3xN3t
06-02-2011, 12:19 AM
Well...
we will call our file "foobar", just to simplify...
- the file with name "foobarX.mkv" is in the mezzmo playlist
- renaming it "foobar.mkv" the file disappear just refreshing the playlist
- if I run manteinance mezzmo processes all files except "foobar.mkv"
- the only way to make it to appear in the playlist is renaming it with every name except for "foobar.mkv"

the device is a samsung 32" C6000
the profile I use is Samsung C

the problem isn't the device cause just renaming the file the tv is able to play it normally
the problem seems to be neither mezzmo or the file, cause the same file with the "hated" name is normally shown in the playlist of the mezzmo installation of another PC...

is it possible that there's something cached somewhere???

the FFmpeg Info:

ffmpeg version git-N-30186-gd9d5603, Copyright (c) 2000-2011 the FFmpeg developers
built on May 25 2011 12:16:07 with gcc 4.4.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-mingw32- --enable-static --disable-shared --enable-zlib --disable-ffprobe --disable-ffplay --prefix=/media/windows/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --pkg-config=pkg-config
libavutil 51. 2. 1 / 51. 2. 1
libavcodec 53. 6. 0 / 53. 6. 0
libavformat 53. 2. 0 / 53. 2. 0
libavdevice 53. 0. 0 / 53. 0. 0
libavfilter 2. 10. 0 / 2. 10. 0
libswscale 0. 14. 0 / 0. 14. 0
libpostproc 51. 2. 0 / 51. 2. 0
[matroska,webm @ 01320320] Estimating duration from bitrate, this may be inaccurate
Input #0, matroska,webm, from '\\192.168.0.21\public\MKV\xBenvenuti Al Sud 1080P.mkv':
Duration: 01:45:49.22, start: 0.000000, bitrate: 1536 kb/s
Chapter #0.0: start 0.000000, end 290.874000
Metadata:
title : 00:00:00.000
Chapter #0.1: start 290.874000, end 630.713000
Metadata:
title : 00:04:50.874
Chapter #0.2: start 630.713000, end 848.765000
Metadata:
title : 00:10:30.713
Chapter #0.3: start 848.765000, end 1078.160000
Metadata:
title : 00:14:08.765
Chapter #0.4: start 1078.160000, end 1270.019000
Metadata:
title : 00:17:58.160
Chapter #0.5: start 1270.019000, end 1683.765000
Metadata:
title : 00:21:10.019
Chapter #0.6: start 1683.765000, end 1926.007000
Metadata:
title : 00:28:03.765
Chapter #0.7: start 1926.007000, end 2208.456000
Metadata:
title : 00:32:06.007
Chapter #0.8: start 2208.456000, end 2402.400000
Metadata:
title : 00:36:48.456
Chapter #0.9: start 2402.400000, end 2692.273000
Metadata:
title : 00:40:02.400
Chapter #0.10: start 2692.273000, end 2952.950000
Metadata:
title : 00:44:52.273
Chapter #0.11: start 2952.950000, end 3189.186000
Metadata:
title : 00:49:12.950
Chapter #0.12: start 3189.186000, end 3412.784000
Metadata:
title : 00:53:09.186
Chapter #0.13: start 3412.784000, end 3619.115000
Metadata:
title : 00:56:52.784
Chapter #0.14: start 3619.115000, end 3815.270000
Metadata:
title : 01:00:19.115
Chapter #0.15: start 3815.270000, end 4050.922000
Metadata:
title : 01:03:35.270
Chapter #0.16: start 4050.922000, end 4323.069000
Metadata:
title : 01:07:30.922
Chapter #0.17: start 4323.069000, end 4832.953000
Metadata:
title : 01:12:03.069
Chapter #0.18: start 4832.953000, end 5109.271000
Metadata:
title : 01:20:32.953
Chapter #0.19: start 5109.271000, end 5378.290000
Metadata:
title : 01:25:09.271
Chapter #0.20: start 5378.290000, end 5691.102000
Metadata:
title : 01:29:38.290
Chapter #0.21: start 5691.102000, end 5891.302000
Metadata:
title : 01:34:51.102
Chapter #0.22: start 5891.302000, end 6074.485000
Metadata:
title : 01:38:11.302
Chapter #0.23: start 6074.485000, end 6074.485000
Metadata:
title : 01:41:14.485
Stream #0.0(eng): Video: h264 (High), yuv420p, 1920x816, PAR 1:1 DAR 40:17, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Metadata:
title : Video Bitrate = 9245 kbps
Stream #0.1(ita): Audio: dca (DTS), 48000 Hz, 5.1, s16, 1536 kb/s (default)
Metadata:
title : DTS ITA 5.1 1509 kbps
At least one output file must be specified


---> DB Level Info: 41

Paul
06-02-2011, 08:48 AM
Sorry, I'm not sure that I completely understand the problem, but try the following:

1) rename the file back, so that it appears in Mezzmo
2) in Mezzmo delete the file and also check the box to delete it from the library
3) now rename the file on disk and go back to the folder with that file in Mezzmo

Does it appear with the new name now?

I assume that the playlist the file is in is actually a folder added using the "Add Folder" command, not a normal/smart/active playlist, right?

4L3xN3t
06-02-2011, 04:25 PM
yes, I used "Add Folder", so mezzmo says I can't delete the file...
everythink is very strange! ;)
I mean, renaming a file to make it work is not absolutely a problem but I would like to know if there's a problem somewhere in my mezzmo installation

where does mezzmo store info about files in playlist???

Paul
06-02-2011, 04:27 PM
Sorry, I should've been more clear:

1) go to a playlist such as "All Videos"
2) in there locate and delete that file (yes, you cannot delete a file from within a folder you've added, you need to go to some playlist to do that)
3) then go back to the folder that the file is in (the one you added using "Add Folder")
4) the file should be re-added at this point

All information is stored in Mezzmo's database (Mezzmo.db).

4L3xN3t
06-02-2011, 05:16 PM
I wrongly called "playlist" a normal folder
i removed the standard playlists, so "All Videos" is dead ;)

my situation
110

I'm gonna try to understand something in the mezzmo's database

Paul
06-03-2011, 08:43 AM
Just create a new smart playlist and set the file type to video in it - that'll show all your video files and you can delete from there.