View Full Version : Samsung UA55C7000 error streaming?

06-02-2011, 10:48 PM

I try to stream lord of the rings movie from my pc to tv via a wired connection. It starts off working fine and then at approx 2.5 mins the video stops and says audio codec not support, then after about 15 seconds the movie continues to play but with no sound.

how can i fix this?

CPU: Core i7 2.7ghz
RAM: 6gb
OS: Windows 7 64 bit
Latest version of mezzmo
Samsung C profile is being used for my tv and transcoding is turned on with default settings.
I ticked the box with max resolution to 1080p and turned cpu usage to high with 11 transcoders.


ffmpeg version git-N-30186-gd9d5603, Copyright (c) 2000-2011 the FFmpeg developers
built on May 25 2011 12:16:07 with gcc 4.4.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-mingw32- --enable-static --disable-shared --enable-zlib --disable-ffprobe --disable-ffplay --prefix=/media/windows/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --pkg-config=pkg-config
libavutil 51. 2. 1 / 51. 2. 1
libavcodec 53. 6. 0 / 53. 6. 0
libavformat 53. 2. 0 / 53. 2. 0
libavdevice 53. 0. 0 / 53. 0. 0
libavfilter 2. 10. 0 / 2. 10. 0
libswscale 0. 14. 0 / 0. 14. 0
libpostproc 51. 2. 0 / 51. 2. 0

Seems stream 0 codec frame rate differs from container frame rate: 47.95 (5000000/104271) -> 23.98 (24000/1001)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'E:\MOVIES\Lord of the Rings 1 - Fellowship of the Ring.mp4':
major_brand : isom
minor_version : 1
compatible_brands: isomavc1
creation_time : 2010-12-28 20:10:59
Duration: 02:58:25.11, start: 0.000000, bitrate: 3209 kb/s
Stream #0.0(und): Video: h264 (High), yuv420p, 1920x800 [PAR 1:1 DAR 12:5], 2804 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc
creation_time : 2010-12-28 20:10:59
Stream #0.1(eng): Audio: aac, 48000 Hz, 5.1, s16, 402 kb/s
creation_time : 2010-12-28 20:12:50
At least one output file must be specified

---> DB Level Info: 0

06-03-2011, 10:11 AM
That file should be passed through natively, so perhaps there's something in it's encoding that makes the TV reject it. I'd suggest then transcoding this file - to do that, edit the device profile (SamsungLA.prf) and change the "h264aac" container to be like this:

<avcontainer id="mov,mp4,m4a,3gp,3g2,mj2" name="h264aac" encode="0" mimetype="video/mp4" dlnaprofile="MP4" supportschunked="0">
<format id="h264" encode="0">
<format id="mpeg4" encode="0">
<format id="aac" encode="0">
<format id="pcm_s16le" encode="0">

This will only pass through such files with stereo AAC sound, so it should transcode this file.

Please let me know how that goes or if you're not sure how to edit the device profile.

06-03-2011, 04:08 PM
Still the same problem. I used notepad to change the file.. copied and pasted your code over the one in the original file, overwrote it.

closed mezzmo, started it up again, stopped server, started it and then streamed the movie, stopped at same location with same error msg.

i don't think it was transcoding it. my transcoding folder is still empty

06-03-2011, 04:11 PM
It should've transcoded the file with those changes. Please make sure that transcoding is turned on (in Transcoding Settings dialog and also in the Device Properties dialog) and that the server was restarted and is using the correct profile.

If it still fails, please turn on logging (see this thread: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging), then try playing the file again and once it fails, stop the server and send us the logs along with your modified device profile to support (at) conceiva (dot) com.

06-03-2011, 05:17 PM
My mistake, i didn't overwrite the file properly. I managed to do it properly and streamed it.

The audio now works but at the same spot the video still stops, the audio continues to play but then when the video comes back in about 15 seconds later, the audio is out of sync.

06-03-2011, 05:23 PM
Could be something to do with that file's encoding - it's hard to say without the actual file here. If that file is available for download anywhere, can you please send me a link to it (privately)?

Also, if you let it finish transcoding and try playing it again, does it still stop at the same spot?

06-03-2011, 05:40 PM
yes it still stops at the same spot even after its trasncoded.

I think it does have something to do with the files encoding because it stops at the same spot on my pc aswell.

Does the modified profile force transcoding for audio only? or video aswell?

I got the file from a private torrent tracker, i could send you the torrent if you want.

but the file is 4gb in size...

*I played it on my pc and if i skip to the middle of the movie or anywhere after that spot, the sound and video are perfectly fine. if i let the movie play until it reaches that spot then it stuffs up and the video and sound stops, then video continues without sound... so i think its definately something to do with the encoding at that spot? 2:37s

06-06-2011, 09:55 AM
Yes, can you please send a torrent link via PM or e-mail support and we'll check it out. However, if the file is somehow badly encoded in the middle and FFmpeg can't transcode it, then there's not much we can do (but at least we can confirm if that's the case or not) unfortunately.

The modified profile forces only audio encoding - the video stream will be remuxed into a different container. Perhaps a full re-code of the file will get it going.