View Full Version : Reproducible Blue Screens with Mezzmo 2.3.1 when streaming to Samsung C-series

06-20-2011, 01:55 AM
I am suffering from reproducible blue screens since a few days when streaming to my Samsung C8790. Streaming to my Pinnacle Media Center 200 still works. I have been using Mezzmo for 6 month now and it worked perfectly in various versions.

Due to the fact that I am creating regular image backups of my C-drive and keep a log of all maintenance actions I could go back to a working state and incrementally progress until I could nail the root cause down to an interference between Mezzmo 2.3.1 and an update of one of the following 3 programs:
Acronis True Image 2011 Update 2 Buld 6857
TuneUp Utililties 2011 10-0-4-200-95
GData Antivirus 2012

I have been using Acronis 2011 and TuneUp 2011 and GData Antivirus 2011 (!!) alongside Mezzmo for many months. So the issue lays in an interference with one of the updates.

My OS is Win7 Prof latest patch level but the patches are not affecting Mezzmo.
I already tried Mezzmo 2.3.2 and had the same blue screens with the above updates installed.

If I would have more time I could continue to nail down but it already consumed excess time to get to this state.

I tried to upload the log files with the latest blue screen when connecting from Samsung C and a successful streaming attempt to the Pinnacle MC200 but most log files were rejected. I have conserved them for you.

Please help.

Best Regards

06-20-2011, 10:01 AM
Thank you for the information - we'll try to test Mezzmo with those three programs to see whether there are any potential issues there.

Can you please zip up the logs and re-send them to us? Files over 10MBs are rejected, so if they're larger than that (zipper), please upload to www.megaupload.com or a similar site and we'll grab them from there.

06-21-2011, 03:09 AM
I attach the logs here:

They show a sequence of: Me streaming a file labelled 'Bilder aus Südtirol_06-18_12-27-00.mpg' to my Samsung C8790 with immediate BSOD when streaming starts, followed by a reboot and tehn me streaming the same file to my Pinnacle Media Center 200 without any trouble.

The BSOD's are perfectly reproducible. They always happen for my Samsung and always when streaming starts.

06-21-2011, 10:09 AM
Thanks for the logs.

Can you please tell me a bit more about your network hardware and also security settings? In the Samsung's logs, we're not able to find your network cards at first, but they come up later. Perhaps they're blocked by one of the software packages you are running? Also, I assume this is not a virtual machine, right?

Are the Samsung and Pinnacle on the same router/network card? Are they both wired/wireless or one is wired, while the other is wireless?

06-22-2011, 03:13 AM
I am running one LAN segment wired through a Netgear WNDR 3300 router. The wiring is Devolo Powerline LAN to both the Samsung and the Pinnacle MC 200. None of this setup has been touched.

My Win 7 installation is NOT a virtual machine.

From a network security perspective both the Samsung as well as the Pinnacle are behaving as they ever did before the updates: Mezzmo immediately visible, browsing the video repository being fast and flawless. Its only when I finally select a video on my Samsung and start the Replay that I cause an immediate Bluescreen.

06-22-2011, 09:50 AM
The logs look normal up to the point of BSOD (where they abruptly end of course), but it seems more-or-less consistent that those logs that show BSOD also show issues with accessing the network card in the beginning. Perhaps there's a hardware or driver issue here - can you please check if Windows Update updated any of your hardware drivers recently?

06-23-2011, 09:53 PM
First of all Thanks for your fast turnaround times - definitely remarkable in todays world of support responses usually being just a waste of time. You guys make a difference to your customers!

I spent the time nailing down the culprit further and can now firmly say that the BSODs coincide with having installed GDATA Antivirus 2012. The updates for Acronis True Image 2011 and TuneUp 2011 are NOT causing the BSOD's to arise when streaming to Samsung C. I also applied Mezzmo 2.3.2 and confirm no issues with that.

I did not find any Microsoft update to my network interface card.

There is a setting in GDATA Antivirus that monitors network access but that has been in use in my current GDATA Antivirus 2011 installation already and has never caused an issue with streaming. I can't of course tell whether GDATA Antivirus interrupts the video data stream.

To round off the analysis of the suspected network issue I attach two logfiles that show successful streaming of the very same video clip as in the previous logs to my Samsung C and Pinnacle MC200. The software status is 'all updates applied except GDATA Antivirus 2012'.

I will await your response and then report the issue to GDATA.

06-24-2011, 09:40 AM
Thank you for the kind feedback and additional information - we'll do some tests here with GDATA. If it blocks the network card for any reason, this may cause issues of course. Is there a way to add Mezzmo.exe and MezzmoMediaServer.exe to its exceptions list?

06-25-2011, 02:23 AM
Yes, I can add files to the exception list of GDATA Antivirus. I tried that just now but with the same result -> BSOD.

GDATA is analyzing the dumps during next week. I will keep you posted on any outcome.

06-29-2011, 10:13 AM
We've been trying to reproduce this here, but cannot (at least with trial versions of those products, but I assume they'd be the same). Please let me know if you hear back from GData.

Also, if you made any changes to default settings in it, can you please send me screenshots of your configuration dialogs, so that I could replicate them here exactly as you have them?

07-02-2011, 08:07 AM
GData responded today with their dump-analysis. The culprit was the driver of my network card.

I use an Atheros on-board network interface on my ASUS P5Q maninboard and had used the standard Windows 7 driver since migrating to Win7 six months ago. No driver update was offered by MS since. I updated the network driver from the ASUS website and upgraded to GDATA Antivirus 2012 and streaming to my Samsung C-series suddenly works.

Problem resolved! Cudos to the GData guys.

07-04-2011, 09:50 AM
I'm glad this is resolved; as I guessed earlier the driver was a problem (it usually is something to do with drivers when the system BSODs on you).