View Full Version : AVI files with AC3 sound problem

01-24-2008, 03:23 AM

I am having some problem playing avi files that uses the AC3 codec for sound..

they play allright in Mezzmo, but not on my PS3... File type unsupported.

I am not the only one with this problem.. I have learned that tversity also have this problem with the PS3..

Have you encountered this problem? and will it be fixed?
Will Mezzmo "transcode" these files on-the-fly in future updates/releases?

AVI that play fine:

AVI that do not play:


01-24-2008, 08:36 AM
Hi Tom,

Do you have the latest version of Mezzmo (v1.1.1.0)? There have been some changes in DLNA streaming since v1.1.0.0 and I can play the following file, for example, on the PS3:


Regarding transcoding on the fly - we do have plans to implement that, but I cannot give you a time frame on when it will be done at the moment, unfortunately. It is not far away though.


01-26-2008, 01:44 AM
Hi again..

I have made a fresh install of Mezzmo, latest release..

I removed ALL my codecs, and then installed only xp codec pack.

Still can not stream that file to my PS3...

I see your avi file only have 2ch sound, mine have 6... could this be the problem? Please try a file with 6ch AC3 sound...

As I said.. File plays perfectly on my computer, both in Mezzmo and Mediaplayer.


01-26-2008, 10:23 PM
Hi Tom,

I will try a 6 channel file and get back to you in this thread when I have some results. It's possible that the PS3 cannot decode it at the moment (maybe they will be able to in the future with a firmware update). In any case, I'll try it and see if I can get it to work.


01-27-2008, 01:31 AM
Hi again..

My toughts exactly.. Tried with Tversity to, no go.... :mad:

Have tested more files with the same avi info, same problem.. Others, 2ch sound works perfectly..

EDIT: Came across yet another file that will not play against the PS3.. However, this file have 2ch sound.. So that could not be the problem.. I am thinking of a codec issue.. Could it be that this exactly usage of codec when making the avi is not supported on the ps3? This is strange... My computer play both files perfectly...

Here is a screen of G-spot avi info:

01-29-2008, 09:37 AM
Well, I can play (via streaming of course) the following file fine on the PS3:


One small thing that I wanted to check with you - what are the file extensions for those video files that you have? I assume they're AVI, but need to be sure ;)

The codec used to create the file could be the problem - I'll try to find it and create a file with it, so that I could have exactly same file as you do.


01-29-2008, 11:33 AM
Yes.. Is avi...
Have a look at my first post about unplayable file (image).. That is one, and another in my post above from gspot.

Both files.. Avi.. Talked to my brother, he could not play these files either..

LoL.. Have no idea what it is... As I said, they play fine on my computer (my brothers also), but not stream to PS3, his or mine...

What codec used when creating the avi files, I have no idea... but.. if you know of a program of some sort that can retrieve more information than I already have provided, please let me know..


01-29-2008, 12:43 PM
One more question - do you get the "unsupported file type" message on the PS3 only when you try to play the file, or do they appear in the list like that initially?

Do you have a small file that you could perhaps send to me via e-mail (or a file sharing service such as RapidShare or MegaUpload or something) that has this problem so that I could test it here? If I could find a file that I cannot play (and I can't at the moment), then it will be a lot easier to resolve this problem.

Thank you!


01-29-2008, 11:46 PM
First, the file appear as any regular file in the PS3.

When i try to play it, the screen turns black, and "unsupported video file" displays in the middle of the screen.
Then the file will display as unsupported in the media list.

I could try to chop out a bit of the movie, but I do not have any programs to that. Any suggestions?


PS: As I said, I have tried Tversity to play these files with no luck also, and have had a look in their forum for some help, looks like I am not the only one with unsupported video file error on some avi files..

01-30-2008, 08:27 AM
Ok, if the file appears normally first, then I am almost certainly sure that it's the PS3's inability at the moment to play that specific file. Unfortunately, there's nothing we'll be able to do about that at the moment, so then there's no need to get your file. Hopefully they will rectify this problem soon by adding more supported codecs via a firmware update.

Another solution would be to recode the file using a different video codec. You could try our other product - ConvertHQ - if you wanted.

I do appreciate your help on this - thank you.


01-31-2008, 04:49 AM
No problem...

Actually, I am wondering about the codec used to make the avi..
Cutnpaste from Tversity forum:

I Don't know what I did but something is not working anymore a bunch of my videos now say "corrupted Data" or "unsupported data type" and "media cannot be played" it doesn't make sense because It played before! and now they just aren't working and Its weird because It plays some .avi files and for others it says "unsupported data type" which obviously is wrong because I was just playing .avi. I'm thinking it might be because ffdshow doesn't pop up beside tversity on the mini bar thing on my pc. ffdshow pops up if I use watch the videos on my wii or from my pc but not on my ps3 anymore!? is this whats causing the problem? how can I fix it?

the same thing happened to me.

if your using the latest tversity try reverting back to the one you previously used when everything worked okay,i did and now my videos all work ok.

I will try an earlier release of Tversity and see if my avi files play then.. If so, there is something wrong with Mezzmo :) I'll get back to you when I have tested it out..

01-31-2008, 08:12 AM
Yep, thank you. If the PS3 can play that file, then we'll be able to figure out a way to tell it to do that ;) Actually, one thing to try is to simply copy it over to the PS3 (using a USB drive or something) and try to play it - do they play like that?

02-01-2008, 07:21 AM
Didn't work that either... I reencoded the file, and it was able to play.. I am tired of researching this problem ;)

02-01-2008, 08:36 AM
Well, at least we've confirmed that the PS3 cannot natively play those files, so we'll have to wait for Sony to include more codecs.

Thank you for the patience and help on this!