PDA

View Full Version : FFMpeg takes 100% CPU



nebula
03-21-2012, 11:58 AM
Hi Support Team,

I'm using Mezzmo demo version on WindowsHomeServer2011 on HP-N40L server and whenever Mezzmo transcode any files FFMpeg takes up 100% CPU and FFMPeg process hangs around in the processes list until I stop Mezzmo server and start again.

For few vedio files I have stuttering on my TV unit specially while it transcode any 720 or 1080P MKV files and FFMPeg takes 100% CPU on the box while its trying to transcode. Once FFMepg takes 100% CPU my over computer slows down and crash.

I have Panasonic Viera (TH-P46GT30A) 46" Plasma which is DLNA capable TV unit and Fritzbox Gigabit router however my TV unit connects via Wireless N 5GH Channels so I have strongest signal. My HP-NN40L is connected to router via 1GB wired connection as well. Tried to have best possible setup. Practically I won't able to run a cable to my TV unit.

Troubleshooting:

1. I tired to change different Panasonice profile in media device but neither of them worked properly but currently my defualt profile which i have selected is Panasonic Viera 2011 models.
2. Turn off pre-transcoding option for any files which my TV unit doesn't support, but still FFMPeg hangs around in the Process chewing up 100% CPU.
3.By turnning of pre-trascoding TV wouldn't play the files which are supportedy by TV unit which is obviouse but than Mezzmo is not been utilize to its fullest as it doesn't work as it mean to.
4.Deleted TV profle and set it again but no luck.

Could you please advice what could be wrong and why Mezzmo (FFMPeg) takes 100% CPU, have stuttering videos?

Please help.

Paul
03-21-2012, 01:19 PM
Thanks for your detailed post. It's best we see a set of logs to determine what is the reason for the stuttering. Please enable logging (see this thread: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging) then start your Mezzmo server and connect to Mezzmo from your TV and stream a video file that you know will stutter. Once it starts stuttering, stop your Mezzmo server, zip up all the logs and send them us at support [at] conceiva [dot] com.

nebula
03-21-2012, 01:30 PM
Thanks Paul for your quick response, I will enable the debuging today and try to get the logs, zip it and send it to support@conceiva.com

nebula
03-21-2012, 08:26 PM
Hi Paul,

I'm sending the logs files to support@conceiva.com which you have requested for further debugging.

I tried 4 different MKV files like 1080P & 720P however all the files stutter while it streams on TV and FFMpeg also take 100% CPU.

Please advice what needs to be done in order to make this work.

Thanks for help, its very much appriciated.

nebula
03-22-2012, 09:42 AM
hi Paul,

Alternately you can download the logs from RapidShare.

https://rapidshare.com/#!download|737p4|1723509231|Logs.rar|1930

Paul
03-22-2012, 11:20 AM
Thanks for the logs. We will analyze them and reply via e-mail.

nebula
03-23-2012, 08:36 AM
Hi Paul,

I tried you suggestion by pretranscoding one of the smaller file and than played on the TV which got played successfully.

I have detected the main issue, my device profile - Panasonic Viera (20011, NTSC) is transcoding each and every file in my library even though it should not transcode the file as *.MKV, *.AVI, etc files because they are natively supported by my TV.

My device profile doesn't ignore the file extension which are supported by my TV unit and does transcoding for all files. So in order to remediate that issue I have turn off "Transcode incompitatible media files so they can be played on the device" by going in Media Device > Selected Panasonic Viera (2011 Model, NTSC) > Edit> Device Settings > Transcoing > uncheck the above option which i mentioned.

By doing this I don't see anymore FFMPeg which takes 100% CPU as it doesn't transcode majority of files neither I have stuttering issues playing those files on my TV. Now my 90% of files can be played successfully on my TV.

Now problem is I can't play those incomptible files (like MP4, etc) on my TV unit since i have turned off the option.

Could you please suggest the tweak so Mezzmo can recognise the which extesnion needs to be transcoded or played natively for my TV unit, for the files which are incompitable so I will try to pretranscode them in advance before I stream them?

I do realise my dual core cpu could not cope up to transcode the files over the fly and has to be pre-transcode them before streaming.

I dont understand why Mezzmo is not ignoring all the file type extensions (Even though selected the right device profile) which are natively supported by TV and does transcoding for all files which cuase more problems lik 100% CPU and stuttering.

Please advice.

Paul
03-23-2012, 10:34 AM
When you turn off transcoding, Mezzmo just delivers all the files natively to your TV and your TV decides if it can play them or not.

Since your TV can play 90% of your MKV and AVI files, please tell me the FFmpeg information for some of these files and we can tweak the device profile to match this support. To get FFmpeg information, right-click on the file in mezzmo and click 'Get FFmpeg Information'. Either post it here or send to us at support [at] conceiva [dot] com. We will then email you a tweaked device profile.

nebula
03-23-2012, 11:31 AM
I have extracted FFMPeg information for couple of working 720P-MKV, 1080-MKV, AVI, M2TS files which are natively played on the TV, aslo included the FFMPEG information for MP4 file which should be transcoded and played on TV.

I have sent the attachment to support@conceiva.com.

Alternatley you can download it from the rapidshare.

https://rapidshare.com/files/1700872104/FFMpeg.rar

nebula
03-23-2012, 11:41 AM
1080P MKV File:
ffmpeg version N-36036-ga40f43d, Copyright (c) 2000-2011 the FFmpeg developers
built on Dec 22 2011 13:44:49 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/media/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/dennis/cc/include --extra-ldflags=-L/home/dennis/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 46. 1 / 53. 46. 1
libavformat 53. 27. 0 / 53. 27. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0
Input #0, matroska,webm, from 'E:\ServerFolders\Videos\Hugo.2011.1080p.BluRay.X2 64-AMIABLE\Hugo.2011.1080p.BluRay.X264-AMIABLE.mkv':
Duration: 02:06:20.99, start: 0.000000, bitrate: 9910 kb/s
Chapter #0.0: start 0.000000, end 575.533000
Metadata:
title : 00:00:00.000
Chapter #0.1: start 575.533000, end 1040.665000
Metadata:
title : 00:09:35.533
Chapter #0.2: start 1040.665000, end 1412.911000
Metadata:
title : 00:17:20.665
Chapter #0.3: start 1412.911000, end 1834.541000
Metadata:
title : 00:23:32.911
Chapter #0.4: start 1834.541000, end 2306.262000
Metadata:
title : 00:30:34.541
Chapter #0.5: start 2306.262000, end 2856.270000
Metadata:
title : 00:38:26.262
Chapter #0.6: start 2856.270000, end 3337.543000
Metadata:
title : 00:47:36.270
Chapter #0.7: start 3337.543000, end 3823.695000
Metadata:
title : 00:55:37.543
Chapter #0.8: start 3823.695000, end 4366.862000
Metadata:
title : 01:03:43.695
Chapter #0.9: start 4366.862000, end 4799.169000
Metadata:
title : 01:12:46.862
Chapter #0.10: start 4799.169000, end 5230.100000
Metadata:
title : 01:19:59.169
Chapter #0.11: start 5230.100000, end 5583.495000
Metadata:
title : 01:27:10.100
Chapter #0.12: start 5583.495000, end 6161.280000
Metadata:
title : 01:33:03.495
Chapter #0.13: start 6161.280000, end 6827.779000
Metadata:
title : 01:42:41.280
Chapter #0.14: start 6827.779000, end 7198.441000
Metadata:
title : 01:53:47.779
Chapter #0.15: start 7198.441000, end 7580.990000
Metadata:
title : 01:59:58.441
Stream #0:0(eng): Video: h264 (High), yuv420p, 1920x1080, SAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Stream #0:1(eng): Audio: dts (DTS), 48000 Hz, 5.1(side), s16, 1536 kb/s (default)
Stream #0:2(eng): Subtitle: text
At least one output file must be specified


---> DB Level Info: 41, 100
---> Frame rate: 23.98
---> Aspect ratio: 16:9

nebula
03-23-2012, 11:41 AM
AVI Files:
ffmpeg version N-36036-ga40f43d, Copyright (c) 2000-2011 the FFmpeg developers
built on Dec 22 2011 13:44:49 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/media/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/dennis/cc/include --extra-ldflags=-L/home/dennis/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 46. 1 / 53. 46. 1
libavformat 53. 27. 0 / 53. 27. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0

Seems stream 0 codec frame rate differs from container frame rate: 47.95 (8000000/166833) -> 23.98 (24000/1001)
Input #0, matroska,webm, from 'E:\ServerFolders\Videos\Blue.Planet.1080p.BluRay. x264-REQ\blue.planet.e01.repack.1080p.bluray.x264-req.mkv':
Duration: 00:48:03.50, start: 0.000000, bitrate: 11835 kb/s
Stream #0:0(eng): Video: h264 (High), yuv420p, 1920x1080, SAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc
Stream #0:1(eng): Audio: dts (DTS), 48000 Hz, 5.1(side), s16, 1536 kb/s (default)
Stream #0:2(eng): Subtitle: text
At least one output file must be specified


---> DB Level Info: 41, 100
---> Frame rate: 23.98
---> Aspect ratio: 16:9

nebula
03-23-2012, 11:42 AM
M2TS files:
ffmpeg version N-36036-ga40f43d, Copyright (c) 2000-2011 the FFmpeg developers
built on Dec 22 2011 13:44:49 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/media/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/dennis/cc/include --extra-ldflags=-L/home/dennis/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 46. 1 / 53. 46. 1
libavformat 53. 27. 0 / 53. 27. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0
[NULL @ 02cbba40] start time is not set in estimate_timings_from_pts
[NULL @ 02cc1a00] start time is not set in estimate_timings_from_pts
[NULL @ 02cc7ae0] start time is not set in estimate_timings_from_pts
[NULL @ 02ccdaa0] start time is not set in estimate_timings_from_pts
[NULL @ 02cd3a00] start time is not set in estimate_timings_from_pts
[NULL @ 02cd9ac0] start time is not set in estimate_timings_from_pts
[NULL @ 02cf4080] start time is not set in estimate_timings_from_pts
[NULL @ 02cfa400] start time is not set in estimate_timings_from_pts
[NULL @ 02d05700] start time is not set in estimate_timings_from_pts
[NULL @ 02d0b680] start time is not set in estimate_timings_from_pts
[NULL @ 02d115a0] start time is not set in estimate_timings_from_pts
[NULL @ 02d17520] start time is not set in estimate_timings_from_pts
[NULL @ 02d1d440] start time is not set in estimate_timings_from_pts
[NULL @ 02d233e0] start time is not set in estimate_timings_from_pts
[NULL @ 02d292e0] start time is not set in estimate_timings_from_pts
[NULL @ 02d2f280] start time is not set in estimate_timings_from_pts
[NULL @ 02d351a0] start time is not set in estimate_timings_from_pts
[NULL @ 02d3b140] start time is not set in estimate_timings_from_pts
[NULL @ 02d41040] start time is not set in estimate_timings_from_pts
[NULL @ 02c770a0] start time is not set in estimate_timings_from_pts
[NULL @ 02c774c0] start time is not set in estimate_timings_from_pts
[NULL @ 02c77980] start time is not set in estimate_timings_from_pts
[NULL @ 02d580c0] start time is not set in estimate_timings_from_pts
[NULL @ 02d5e000] start time is not set in estimate_timings_from_pts
[NULL @ 02d5e440] start time is not set in estimate_timings_from_pts
[NULL @ 02d5e880] start time is not set in estimate_timings_from_pts
[NULL @ 02d5ecc0] start time is not set in estimate_timings_from_pts
[NULL @ 02d5f120] start time is not set in estimate_timings_from_pts
[NULL @ 02d5f560] start time is not set in estimate_timings_from_pts
Input #0, mpegts, from 'E:\ServerFolders\Videos\Transformers Dark of The Moon 1080p\00800.m2ts':
Duration: 02:34:23.33, start: 11.608967, bitrate: 40720 kb/s
Program 1
Stream #0:0[0x1011]: Video: h264 (High) (HDMV / 0x564D4448), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc
Stream #0:1[0x1100]: Audio: truehd (AC-3 / 0x332D4341), 48000 Hz, 7.1, s32
Stream #0:2[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 640 kb/s
Stream #0:3[0x1101]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 640 kb/s
Stream #0:4[0x1102]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 640 kb/s
Stream #0:5[0x1103]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 640 kb/s
Stream #0:6[0x1104]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 640 kb/s
Stream #0:7[0x1105]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 640 kb/s
Stream #0:8[0x1106]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 640 kb/s
Stream #0:9[0x1200]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:10[0x1201]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:11[0x1202]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:12[0x1203]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:13[0x1204]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:14[0x1205]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:15[0x1206]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:16[0x1207]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:17[0x1208]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:18[0x1209]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:19[0x120a]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:20[0x120b]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:21[0x120c]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:22[0x120d]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:23[0x120e]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:24[0x120f]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:25[0x1210]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:26[0x1211]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:27[0x1212]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:28[0x1213]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:29[0x1214]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:30[0x1215]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:31[0x1216]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:32[0x1217]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:33[0x1218]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:34[0x1219]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:35[0x121a]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:36[0x121b]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:37[0x121c]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
At least one output file must be specified


---> DB Level Info: 41, 100
---> Frame rate: 23.98
---> Aspect ratio: 16:9

nebula
03-23-2012, 11:43 AM
720PMKV Files

ffmpeg version N-36036-ga40f43d, Copyright (c) 2000-2011 the FFmpeg developers
built on Dec 22 2011 13:44:49 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/media/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/dennis/cc/include --extra-ldflags=-L/home/dennis/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 46. 1 / 53. 46. 1
libavformat 53. 27. 0 / 53. 27. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0
Input #0, matroska,webm, from 'E:\ServerFolders\Videos\Delhi Belly (2011) Dual Audio 720p DVDRip AC3 x264 TmG\Delhi Belly (2011) Dual Audio 720p DVDRip AC3 x264 TmG.mkv':
Duration: 01:42:49.49, start: 0.000000, bitrate: 6092 kb/s
Stream #0:0(eng): Video: h264 (High), yuv420p, 1280x544 [SAR 1:1 DAR 40:17], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Stream #0:1(eng): Audio: ac3, 48000 Hz, 5.1(side), s16, 448 kb/s (default)
Stream #0:2(hin): Audio: ac3, 48000 Hz, 5.1(side), s16, 448 kb/s
Stream #0:3(eng): Subtitle: dvd_subtitle (default)
Stream #0:4(eng): Subtitle: dvd_subtitle
At least one output file must be specified


---> DB Level Info: 31, 100
---> Frame rate: 23.98
---> Aspect ratio: 40:17

nebula
03-23-2012, 11:44 AM
MP4 720P Files

ffmpeg version N-36036-ga40f43d, Copyright (c) 2000-2011 the FFmpeg developers
built on Dec 22 2011 13:44:49 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/media/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/dennis/cc/include --extra-ldflags=-L/home/dennis/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 46. 1 / 53. 46. 1
libavformat 53. 27. 0 / 53. 27. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'E:\ServerFolders\Videos\Zee Cine Awards 5th Feb 2012 720p x264 HD MTR(www.mastitorrents.com)\Zee Cine Awards 5th Feb 2012 720p x264 HD MTR(www.mastitorrents.com).mp4':
Metadata:
major_brand : M4V
minor_version : 1
compatible_brands: isomavc1M4V mp42M4A
creation_time : 2012-02-06 19:21:00
Duration: 02:46:21.78, start: 0.000000, bitrate: 1853 kb/s
Stream #0:0(hin): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720, 1799 kb/s, 50 fps, 50 tbr, 200 tbn, 100 tbc
Metadata:
creation_time : 2012-02-06 19:21:00
handler_name : ?
Stream #0:1(hin): Audio: aac (mp4a / 0x6134706D), 48000 Hz, stereo, s16, 48 kb/s
Metadata:
creation_time : 2012-02-06 19:23:04
handler_name : GPAC ISO Audio Handler
At least one output file must be specified


---> DB Level Info: 50, 100
---> Frame rate: 50.00
---> Aspect ratio:

nebula
03-23-2012, 11:45 AM
Few More 1080P MKV FFMpeg information:
ffmpeg version N-36036-ga40f43d, Copyright (c) 2000-2011 the FFmpeg developers
built on Dec 22 2011 13:44:49 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/media/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/dennis/cc/include --extra-ldflags=-L/home/dennis/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 46. 1 / 53. 46. 1
libavformat 53. 27. 0 / 53. 27. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0

Seems stream 0 codec frame rate differs from container frame rate: 47.95 (20000000/417083) -> 23.98 (24000/1001)
Input #0, matroska,webm, from 'E:\ServerFolders\Videos\Recoil.2011.BluRay.1080p. DTS.x264-CHD\Recoil.2011.BluRay.1080p.DTS.x264-CHD.mkv':
Duration: 01:33:50.64, start: 0.000000, bitrate: 13290 kb/s
Stream #0:0(eng): Video: h264 (High), yuv420p, 1920x1080, SAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Metadata:
title : Recoil.2011.BluRay.1080p.DTS.x264-CHD
Stream #0:1(eng): Audio: dts (DTS), 48000 Hz, 5.1(side), s16, 1536 kb/s (default)
Metadata:
title : dts 5.1 1536kbps
At least one output file must be specified


---> DB Level Info: 41, 100
---> Frame rate: 23.98
---> Aspect ratio: 16:9

------------------------------------------------------------------------------------------

ffmpeg version N-36036-ga40f43d, Copyright (c) 2000-2011 the FFmpeg developers
built on Dec 22 2011 13:44:49 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/media/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/dennis/cc/include --extra-ldflags=-L/home/dennis/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 46. 1 / 53. 46. 1
libavformat 53. 27. 0 / 53. 27. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0

Seems stream 0 codec frame rate differs from container frame rate: 47.95 (5000000/104271) -> 23.98 (24000/1001)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'E:\ServerFolders\Videos\Canon the Barbarian\Conan_the_Barbarian_2011_1080p_BluRay_QE BS6_AAC51_PS3_MP4-FASM.mp4':
Metadata:
major_brand : isom
minor_version : 1
compatible_brands: isomavc1
creation_time : 2011-12-17 13:45:31
Duration: 01:52:42.83, start: 0.000000, bitrate: 3952 kb/s
Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1920x800 [SAR 1:1 DAR 12:5], 3537 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc
Metadata:
creation_time : 2011-12-17 13:45:31
handler_name : GPAC ISO Video Handler
Stream #0:1(eng): Audio: aac (mp4a / 0x6134706D), 48000 Hz, 5.1, s16, 410 kb/s
Metadata:
creation_time : 2011-12-17 13:48:30
handler_name : GPAC ISO Audio Handler
At least one output file must be specified


---> DB Level Info: 40, 100
---> Frame rate: 23.98
---> Aspect ratio: 12:5

Paul
03-23-2012, 06:15 PM
Thank for the FFmpeg information. Please give us a few days to tweak the device profile. We will email it to you early next week.

nebula
04-16-2012, 06:25 PM
Hi Paul,

Thanks for sending me the tweaked Panasonice 2011 model profile, howerver I tried it out yesterday and still whenever I play any MKV file its try to transcode it all the time and my server couldn't transacode the files over the fly, hence its video stutter.

Any other suggestions, I was away on holiday and came back so I would be fast in replying back to you.

Paul
04-17-2012, 10:00 AM
Please enable logging in Mezzmo (see this thread: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging) then restart your Mezzmo media server. Connect to Mezzmo using your TV and then play a video file that stutters. When it starts to stutter, stop your Mezzmo media server and exit Mezzmo. Zip up all the log files and send them to us at support [at] conceiva [dot] com.