View Full Version : Mezzmo, WD TV Live and Windows 7

05-10-2010, 01:50 AM
Hi i had a trial of Mezzmo a month or so ago and it worked great for streaming all my video files to my WD TV Live from my PC running Windows XP Pro, so i bought the software and all was well.

I bought a new PC the other day and installed Windows 7 Ultimate x64 on it and reinstalled Mezzmo, i am now having problems playing any mkv files, they play from anything from 10 seconds to about 5 mins then just freezeup and it goes back to the menu. All the mkv files i have all played perfectly via Mezzmo when it was installed on Windows XP, its just since i installed Windows 7 im having these problems. Normal avi's etc seem to play ok with no freezing etc.

Is there some settings that are different for Windows 7 or some network settings in Windows 7 itself that i need to change to get my mkvs to play again ?

Any help would be greatly appreciated.


05-10-2010, 08:36 AM
Hi Graham,

Can you please check in the Media Devices dialog that the WD TV Live is actually selected as the device? It has same user-agent as some other devices, so by default it's not picked correctly and you have to manually override it.

Please let me know how that goes.

05-12-2010, 05:32 AM

Yeah i had it set to WD TV Live profile and it was freezing, seems my normal xvids as also doing the same and freezing after a short period of time and going back the menu. Cant seem to figure out why its doing it as it worked perfectly on Windows XP


05-12-2010, 08:50 AM
Hi Graham,

Can you please generate a log file of trying to play one of those freezing files (see this thread for information on log files: http://forum.conceiva.com/showthread.php?t=419) and send it to support@conceiva.com for further investigation?


05-14-2010, 05:54 AM
Have sent a copy of the logs to the support email.


05-14-2010, 02:32 PM
I suspect that if the problem only occurs with mkv files, this might be caused by having a buggy version of the MKV splitter installed. Uninstall any MKV splitter that you currently have, and get the latest version of Haali splitter from http://haali.su/mkv/ . See if that helps.

Also, I had a similar random freeze problem myself, where my AVIs would freeze up at random intervals, sometimes resuming after 15-20 secs, sometimes losing the connection. Seems that the issue was caused by a buggy version of the firmware I was using on my router where UPNP packets could occasionally cause the router CPU to hit 100%. Upgrading to a newer version of the firmware seems to have fixed the issue. By any chance, are you using a router with the DD-WRT firmware installed?

06-16-2010, 11:59 AM
Hello Conceiva staff, do we get to find out what Graham's issue turned out to be? I'm asking because I'm in a similar situation. I downloaded the trial version of 2.1.7 the other day, and installed it on my Windows 7 (32-bit) PC. I'm using the WD TV Live (latest firmware), and my files typically play anywhere from only 5 seconds to 45 minutes before freezing. They freeze for a few seconds, then play back in fast-motion as if the file is trying to catch up. Sometimes it will start playing fine again after that, and sometimes it will freeze again.

Things I've checked:

My Media Device is set to WD TV Live.
My Belkin router is running with the latest firmware.
My CPU is not hitting anywhere near 100%, as per RMerlin's experience.
I've tried disabling my VirusScan (Avast - free version), but the problem persists.
I only have the minimum codecs installed on my PC (no crazy multi-codec packs that can conflict with each other).
My Windows Firewall is off, and I'm using the hardware firewall in my Belkin router instead. I've opened up ports 53168, 2869, and 1900. (Side note - Please add these ports to your FAQ; I found these by accident in one of the other posts here, and they're too important not to post where everyone can see them!)
Streaming using Windows Media Player 12 works just fine; no freeze-ups at all. This suggests to me that the problem lies within Mezzmo.

Things that I can still try:

Completely disable my Belkin's hardware firewall, thus opening up all ports.
Update my Haali Media Splitter as per RMerlin's suggestion. (I'm only a couple of releases behind, but I can give it a try.)

I've generated a couple of log files from the past couple of nights. I see lots of "we are blocked on socket <nnnn>" messages, even though the socket numbers are not your port numbers listed above. Of course, I'm assuming that "socket" has the same meaning as "port" in this case. Anyway, I've just sent my log files to your support e-mail.

Thanks a bunch,

06-16-2010, 12:39 PM
Thank you for the logs - I've received them and I'll reply to you via e-mail after reading through them.

I agree with your point regarding the ports and we'll add them to the FAQ. The 1900 and 2869 are standard ports, while 53168 is user-configurable (changed via the Media Server Settings dialog).

Mezzmo is not using any codecs actually, so Haali Media Splitter wouldn't cause any issues.

I can confirm that we've currently found one issue with streaming when the server can cause hickups or even abort streaming (depending on the device, actually) and we're working very hard on fixing it right now. I suspect that it's what you're experiencing as well.

Being blocked on a socket is a normal state, as it'll be retried later (to send more data) - a socket is not the same as a port, although they are somewhat related (http://en.wikipedia.org/wiki/Internet_socket).

06-16-2010, 07:07 PM
Actually experienced this issue twice last night.

07-11-2010, 02:00 PM
Hey guys,

Just wanted to provide an update... I've been working with Dennis on this freeze-up problem, and over the course of the past month he has provided me with 4 patches, but so far none of them have been successful. :(

Meanwhile, I've been using Windows Media Player 12's standard media streaming, as it doesn't have these freeze-up issues. The only downside to this is that I'm forced to use Windows standard DLNA menus, which is a minor annoyance.

I should mention that I stream over a Wireless N network. This shouldn't make much of a difference, as I mentioned that WMP12's streamer works just fine.

I'll post again once Dennis and I find a working patch. :confused:


07-29-2010, 02:49 PM
Hello again,

Dennis managed to produce a working patch, as I've confirmed that the freezing problem isn't happening with my WD TV Live anymore. The patch is included with Mezzmo 2.1.8.

Unfortunately, I'm experiencing another problem that's most likely to do with Mezzmo not being able to handle the sheer number of files I'm trying to share (probably around 600). I will start a new thread in regards to this.


07-29-2010, 03:11 PM
Is that 600 video, audio or combined files?

07-30-2010, 02:20 AM
Actually, I forgot about one of my folders, so it's a lot more than 600 :eek:. At any rate, please jump to this thread (http://forum.conceiva.com/showthread.php/595-Does-Mezzmo-have-a-limit-to-the-of-files-in-a-folder-share); a patch for this issue is coming shortly.

11-27-2010, 11:05 AM
Just bought Mezzmo, and my AVI's drop out randomly whilst playing, same as other discussion in this thread... help please if you can.

Mezzmo v2.1.11.0 on Window 7 (all upto date with SPs etc)
Billion BiPac 7300N wireless router (Firmware 1.07 A) up to date.
WDTV Live with latest WD Firmware installed as per auto download on the unit.
McAfee SecurityCenter v10.5

Also, not all AVI file types seem to be playable - is this a transcoding error in Mezzmo, as I thought Mezzmo could serve anything up to its compatible hardware devices as a media server.

Bought Mezzmo instead of using TVersity, but beginning to think TVersity has it over Mezzmo cause its free (albeit Mezzmo user interface is better!) so might even go back to TVersity as there seems to be less of these AVI file dropouts whilst streaming.

Help please... somewhat dissapointed.


11-29-2010, 09:04 AM
Can you please confirm that you're using the "WD TV Live" device profile - you can check that using the Media Devices dialog. By default, the WD TV Live is auto-detected as a DLink DSM-750, which could be causing the transcoding issues.

11-29-2010, 07:11 PM
Hi Dennis,

Yes, I can confirm that Mezzmo is using the WDTV Live profile... I noticed this setting anomaly and corrected as part of initial install and looking through the Mezzmo menu options. Still, when playing AVI's it typically locks up at random time intervals. Eg.: last night, watching a movie, the streaming stopped like 4x times throughout 2.5 hrs of play - the AVI container hosted XVID @ 900Kbps, 640x336 resolution, and MPEG Audio @ 128Kbps - so as you can see, not even really high qulaity AVI at that.

If Mezzmo tech support can help - appreciated!

I'll drop other thread corrospondence, focus in on this thread, and as per your suggestion Dennis - send a message to support (at) conceiva (dot) com.

Thank you....

11-30-2010, 09:14 AM
Ok, so if it's not transcoding-related (which would be the case with the wrong profile), it's possible that you're hitting a network drop issue we're working on resolving right now. If you already sent a message to support, then I'll send you a version to try.