PDA

View Full Version : Mezzmo Crashes... HELP



philhobden
06-07-2010, 03:17 PM
I cllick on the ICOn to open Mezzmo. Loading window opens, then the program crashes and doesnt boot up.

Any ideas? Have reintalled and that doesnt work either

Running: Windows 7

Paul
06-07-2010, 03:39 PM
Can you please delete your Mezzmo library (you can select this option when uninstalling Mezzmo or just search your computer for "Mezzmo.db" file and delete all files in that folder), then re-install and try again?

If it still crashes, can you please enable diagnostic logging, so that I could see better what's happening by following these steps:

1) go to this folder: C:\Users\<your login>\AppData\Local\Conceiva\Logs
2) in it you should see two subfolders - "Mezzmo.exe" and "MezzmoMediaServer.exe"
3) in each of those folders please create an empty file called "Logging" (just right click in the Windows explorer, select "New" -> "Text Document", then enter "Logging" as the name - please note, it doesn't have an extension)
4) after that try running Mezzmo again
5) after it crashes, you should see some log files created in those folders - please zip them up and send to support@conceiva.com for investigation

Please let me know how that goes and if you need any further help.

philhobden
06-08-2010, 01:58 AM
Cant find the log file to do this with.. search whole PC for AppData and cant find that anywhere.

Paul
06-08-2010, 08:50 AM
If you're on Windows 7, then there should be such a folder:

C:\Users\<your login>\AppData\Local\Conceiva\Logs

where "<your login>" is your user name you use to log into Windows. For example, if you use "phil" as your name, the folder will be:

C:\Users\phil\AppData\Local\Conceiva\Logs

philhobden
06-08-2010, 02:40 PM
Okay have done that and created log files. Run Mezzmo and checked both log files which are empty.

Paul
06-08-2010, 02:42 PM
Have you put the empty files "Logging" in both \Mezzmo.exe and \MezzmoMediaServer.exe folders? Were there any .txt files created in those folder after you run Mezzmo?

philhobden
06-08-2010, 03:09 PM
Put in both created new file, text, called logging. Closed out and run mezzmo. Nothing in either file.

Paul
06-08-2010, 03:15 PM
Is the file:


C:\Users\phil\AppData\Local\Conceiva\Logs\Mezzmo.e xe\Mezzmo.txt

being created at all? (remember to replace "phil" with your Windows login name)

Just to confirm, you've put file "Logging" (without any extension in the
C:\Users\phil\AppData\Local\Conceiva\Logs\Mezzmo.e xe\ folder - it's not a file, right?) And yes, you'll also need to restart Mezzmo after putting the Logging file.

philhobden
06-09-2010, 01:56 AM
Have now emailed this to Support as requsted. Sorry obviously not very good at PC stuff!

Paul
06-09-2010, 08:45 AM
No problem - thanks for e-mailing them in. I'll get back to you via e-mail.

LinkoVitch
06-28-2010, 05:02 AM
Is there a fix to this, I am experiencing the exact same issue (Windows 7, Mezzmo and Mezzmo server start up but then crash out). It was working without issue approximately a week ago

Paul
06-28-2010, 08:47 AM
Is there a fix to this, I am experiencing the exact same issue (Windows 7, Mezzmo and Mezzmo server start up but then crash out). It was working without issue approximately a week ago
Can you please also generate a diagnostic log file and send it to support for further investigation?

LinkoVitch
06-28-2010, 09:08 PM
Erm, tried that, but now Mezzmo seems to be stable! I have no installed anything new or any patches, all I have now done is create two files as per your description and Mezzmo seems to be running (and the service). I have added some new video files to it, I will see if they play OK.

Oh and there doesn't seem to be any log files being created... I have not yet checked but suspect that Win7 is appending .txt to the filenames silently and hiding extensions.

Paul
06-29-2010, 08:43 AM
Well, at least it's working :)

After you enable logging in the Options, click the View Log Files button and that should bring up your Windows explorer with the log root folder already selected. In there you'll see two subfolders - each of those should contain a "Logging" file (it's empty and doesn't have a file extension). If there's one, then logging was enabled, if it's not there, something is wrong.

LinkoVitch
07-01-2010, 12:30 AM
Well its gone again :/

I have emailed the logs to support. (It was Windows 7 appending .txt onto the files when creating a blank text document, remove that and bingo. Might I suggest in a future version it checks for Logging and Logging.txt, just to make it simpler).. anyway

The fault seemed to raise its head again when I added some new files to a folder which I have added to my Mezzmo Library.

So, I have a folder which contains some AVI files. I added this folder to Mezzmo, all worked fine and dandy. No problems

I have then copied files into that folder within windows. When I then start up Mezzmo, it starts runs for a few seconds and then falls over.

Leads me to believe that it is something to do with adding these new files. I tried removing the folder no change.

HTH

Paul
07-01-2010, 08:44 AM
Thank you for the logs - I'll reply to you via e-mail.

LinkoVitch
07-13-2010, 06:00 AM
Thought I should probably post this here as it seems to be the case for me...

If I connect my iPhone to my PC to charge (would assume any form of removable storage will do) this seems to cause Mezzmo to have a meltdown and crash as has been described. If I then remove the device I can restart Mezzmo and all is happy. I suspect something to do with a drive letter appearing/disappearing from the point at which the library is first created is upsetting Mezzmo. No idea if removing/inserting a CD would have similar effect.

But this seems to be the cause for me, every time I connect my phone (which appears as a drive on the PC) Mezzmo gets upset, remove it, all is well again with Mezzmo.

HTH

RMerlin
07-13-2010, 07:29 AM
I have the same issue with my iPod Touch - as soon I connect it, Mezzmo (both the service and the client if it's open at the time) crashes.

I hadn't reported it yet because at first I thought it was related to other software changes that occured at the same time and I needed to find some time to troubleshoot it, but since you confirm having the same issue... I know that it didn't happen in the past, so it's related to something that changed. A few things that happened at about the same time the problem appeared:

- Upgraded the iPod to iOS 4.0
- Installed Norton Antivirus 2011 beta (I thought it was the cause at first)

In my case, it only happens with my iPod Touch - not with an USB drive.

I'll send Conceiva the crash dump generated by this issue. Let me know if you need any additional info or test done.

Paul
07-13-2010, 08:32 AM
Thought I should probably post this here as it seems to be the case for me...

If I connect my iPhone to my PC to charge (would assume any form of removable storage will do) this seems to cause Mezzmo to have a meltdown and crash as has been described. If I then remove the device I can restart Mezzmo and all is happy. I suspect something to do with a drive letter appearing/disappearing from the point at which the library is first created is upsetting Mezzmo. No idea if removing/inserting a CD would have similar effect.

But this seems to be the cause for me, every time I connect my phone (which appears as a drive on the PC) Mezzmo gets upset, remove it, all is well again with Mezzmo.

HTH


I have the same issue with my iPod Touch - as soon I connect it, Mezzmo (both the service and the client if it's open at the time) crashes.

I hadn't reported it yet because at first I thought it was related to other software changes that occured at the same time and I needed to find some time to troubleshoot it, but since you confirm having the same issue... I know that it didn't happen in the past, so it's related to something that changed. A few things that happened at about the same time the problem appeared:

- Upgraded the iPod to iOS 4.0
- Installed Norton Antivirus 2011 beta (I thought it was the cause at first)

In my case, it only happens with my iPod Touch - not with an USB drive.

I'll send Conceiva the crash dump generated by this issue. Let me know if you need any additional info or test done.

Thanks for letting us know! We'll investigate here... Mezzmo dynamically detecs iPhones and adds them to the Library listing so that you could browse your iPhones files, I'm guessing something goes wrong in there.

JamboUK
07-14-2010, 08:24 PM
Dennis. Same issue here. iPhone connected then Mezzmo crashes every single time. Unplug iPhone. Mezzmo opens perfectly fine.

jnardone
07-15-2010, 12:03 AM
Mezzmo crashes when I connect my iPhone 4 to the PC. Same problem occurs with my older 3G iPhone with iOS 4.0.

Paul
07-15-2010, 08:29 AM
Thank you for reporting that - we're trying to reproduce that problem here as well. What OS and what iTunes version do you have?

RMerlin
07-15-2010, 08:42 AM
For me:

iTunes 9.2.0.61
Windows 7 64-bit
iPod Touch 3rd generation with iOS 4.0

Did you receive the crash dump I emailed? Not sure if it made it - the attachment should have been small enough hopefully.

Paul
07-15-2010, 08:45 AM
Yes, thank you - we've fot he dump here. Thanks for the info as well - we'll get a system like that going here to see if it help us reproduce it.

Paul
07-15-2010, 11:31 AM
Thanks for all the logs and information. We have reproduced the problem you have all reported and have fixed it.

The next release will include the fix. We expect the new version to be released in a few days.

catharsys
07-22-2010, 07:02 AM
Pheww...
just bought the application yesterday and it was working... and out of nowhere (i thought) the app started crashing and everything...
Now I know why... Iphone here :)
Disconnected and it is working :)

Paul
07-22-2010, 08:32 AM
Yes, it can be a bit surprising ;) This has been fixed and will be part of the next update, as Paul mentioned.