View Full Version : Mezzmo on virtual machine

11-14-2012, 08:46 AM
I'm trying mezzmo on a virtual machine, but all the file that I need to share are on the "real" PC. I connected as network drive the HD where all the file are and in I've imported in mezzmo with no problem.

When i look at those file on the TV, I have the error "codec unsopported".
This error doesn't occur when the file is directly on the virtual machine.

Mezzmo can't share file coming from my home network?


11-14-2012, 09:58 AM
You can certainly stream files from network shares on your home network. This is a common use of Mezzmo for most of our users, who own NAS drives, other computers, etc.

One common reason for files on network shares not to be delivered is due to access permissions on the network share. See this FAQ to solve this problem - http://forum.conceiva.com/showthread.php/4597-FAQ-Accessing-files-from-external-computers-and-NAS-drives-on-your-home-network

"Codec unsupported" suggests the file was delivered to your TV, but your TV could not decode and play the file.

A few questions to help us determine the problem:

What TV model do you have?
What device profile is assigned to your TV in Mezzmo? Go to the Media Devices dialog in Mezzmo to see this.
What is the FFmpeg information on the file that says 'codec unsupported'? To get this, right-click on the file in Mezzmo and click 'Get FFmpeg Information'.

11-20-2012, 09:31 AM
Thankyou very much, it was due to access permissions.

But insted while one problem solved another one comes out:
While viewing an MTS file, coming from a Panasonic camcoder, for few minutes the video is played correctly, but then the video is corrupted. In the back there is the video playing but some little square disturb the video.

The TV is a Samsung 46D8000, and the profile in Mezzmo is correct selected on Samsung D Series, i tried even setting this value on BDP 3D but the problem is still coming out.

here below ffmpeg's informations

ffmpeg version N-40693-gc457a29 Copyright (c) 2000-2012 the FFmpeg developers
built on May 15 2012 12:57:14 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/home/peter/ffmpeg/build/gpl --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/peter/cc/include --extra-ldflags=-L/home/peter/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 51.100 / 51. 51.100
libavcodec 54. 21.101 / 54. 21.101
libavformat 54. 5.100 / 54. 5.100
libavdevice 53. 4.100 / 53. 4.100
libavfilter 2. 73.100 / 2. 73.100
libswscale 2. 1.100 / 2. 1.100
libswresample 0. 11.100 / 0. 11.100
[h264 @ 003cc640] Increasing reorder buffer to 1
Input #0, mpegts, from '\\prova.m2ts':
Duration: 00:01:00.03, start: 0.501322, bitrate: 15560 kb/s
Program 1
Stream #0:0[0x1011]: Video: h264 (High) (HDMV / 0x564D4448), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 50 fps, 50 tbr, 90k tbn, 50 tbc
Stream #0:1[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, stereo, s16, 256 kb/s
Stream #0:2[0x1200]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
At least one output file must be specified

---> DB Level Info: 40, 100
---> Frame rate: 50.00
---> Aspect ratio: 16:9

Thank you very much

11-20-2012, 10:32 AM
The MPEG-TS video has a high bitrate (15Mb) and that may be the reason for the stuttering or block artifacts you are seeing. Try this: In Mezzmo, right-click on the file and click 'Pre-transcode Files'. In the Pre-transcode Files dialog, select your Samsung D-series TV and click Choose Formats. In the Transcoding Formats dialog, select the bolded format (mkv). Then click the 'Force full transcode' checkbox. Click OK to start transcoding. Go to the Transcoding pane to monitor progress. Once transcoding has completed, try streaming the MPEG-TS video to your Samsung D-series TV and see if it is better now. Let us know how you go.

11-21-2012, 08:37 AM
I tried, after the transcoding the file, i can't see anything on the TV, when I press play on the tv the error "video codec unsupported" appear.

For coming back and see the video, with the problem mentioned before, I have to delet all the transcoding file, and disable it.

11-21-2012, 10:38 AM
Please contact us at support [at] conceiva [dot] com and we will provide you with a patch that may fix the issue.

12-07-2012, 02:02 AM
I have a similar problem (in reference to the original post of this thread). I have a local folder and a networked folder created in Mezzmo. On my TV, I can see and play the video files in the local folder. However, I do not see the files in the networked folder. Additionally, when trying to play a networked file (from the All Videos playlist), I get the "codec unsupported" error.

I have looked at the network share FAQ, but my networked server does not have any username/password associated with it. Any ideas?

12-07-2012, 09:45 AM
Please send us a set of logs and we'll take a look at what could be going wrong. Turn on logging (see http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging) and restart your Mezzmo server. Connect to Mezzmo from your device and try to browse folders/playlists that contain files from your networked folder. When it fails to list these files, stop your Mezzmo server and exit Mezzmo. Zip up all the logs and email them to us at support [at] conceiva [dot] com.