View Full Version : AVCHD streaming jerky on Panasonic DMP-BDT220

01-08-2013, 02:24 PM
I recently bought a Panasonic DMT-BDT220 bluray player and was looking for a DLNA server that can stream AVCHD videos from my desktop (Vista) to my bluray player and after tweaking with some network setting, Mezzmo fit my needs perfectly. I am now able to watch picture and stream music and some videos perfectly.
But when I try to play an AVCHD file, it freezes for like a second after playing with say 4-5 seconds. First I thought it could be because of the transcoding, but I am having this problem even with transcoding off. Please note that my desktop (server) as well as the bluray player (client) both are connected wirelessly to the router and I have selected Panasonic BDP as the device profile.
Another problem is the bluray player does not support AVI files, so basically I need a way to tell Mezzmo to transcode the avi files but not other files. I am not sure how/where to configure that.
Any help is much appreciated and thanks in advance. It would be great if I get this all sorted out before my trial version expires and I can make a decision to buy this. I mean for all the other purposes, this product is very good but I would feel better spending money if it works flawless.

01-08-2013, 03:48 PM
the Panasonic BDP (MPEG-TS) device profile supports h264 video in mpegts containers so it should play your AVCHD files much better than the Panasonic BDP profile and it will also transcode your avi files.

01-13-2013, 03:09 PM
If I select BDP (MPEG-TS) profile, with transcoding on, if I try to play m2ts file, it says "Cannot play". Even if I pre-tranascode the file to mpegts/h264/ac3, it still says cannot play.

01-13-2013, 03:11 PM
Looks like the only way I can play m2ts file is choosing any of those 2 Panasonic BDP profiles and selecting Off for transcoding. Unfortunately it freezes so bad every couple seconds that it makes the video unwatchable. Please help.

01-14-2013, 09:07 AM
Please post the FFmpeg information on your m2ts file. To do this, right-click on the video in Mezzmo and click 'Get FFmpeg Information'.

01-14-2013, 10:43 AM
ffmpeg version N-40693-gc457a29 Copyright (c) 2000-2012 the FFmpeg developers
built on May 15 2012 12:57:14 with gcc 4.6.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/home/peter/ffmpeg/build/gpl --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/peter/cc/include --extra-ldflags=-L/home/peter/cc/lib --pkg-config=pkg-config --disable-w32threads
libavutil 51. 51.100 / 51. 51.100
libavcodec 54. 21.101 / 54. 21.101
libavformat 54. 5.100 / 54. 5.100
libavdevice 53. 4.100 / 53. 4.100
libavfilter 2. 73.100 / 2. 73.100
libswscale 2. 1.100 / 2. 1.100
libswresample 0. 11.100 / 0. 11.100
[h264 @ 0182d1e0] Increasing reorder buffer to 1
Input #0, mpegts, from 'C:\Users\pktiwary\Videos\Webcam\20110402125336.M2 TS':
Duration: 00:00:45.05, start: 0.471633, bitrate: 15422 kb/s
Program 1
Stream #0:0[0x1011]: Video: h264 (High) (HDMV / 0x564D4448), yuv420p, 1440x1080 [SAR 4:3 DAR 16:9], 59.96 fps, 59.94 tbr, 90k tbn, 59.94 tbc
Stream #0:1[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, stereo, s16, 256 kb/s
At least one output file must be specified

---> DB Level Info: 40, 100
---> Frame rate: 59.96
---> Aspect ratio: 16:9

01-14-2013, 11:06 AM
Thanks. If you have transcoding turned off and your Panasonic BDP is playing the file with stuttering, then it suggest something is not coping your M2TS video. One reason for the stuttering is that your M2TS files have a very high bitrate and either (i) your home network is causing the stuttering (try using Ethernet cables for fast, stable streaming or if you are using wireless, make sure you are using wireless-N with full signal strength), or (ii) your device may not be able to decode and play the high-bitrate video in real time.