PDA

View Full Version : Problem with subtitle



dd8
02-24-2013, 10:15 PM
Hi, i have an sony kdl-32ex650 and i try to stream .mkv movies with subtitle but i can't.
I have last version of mezzmo and i don't know what's the problem ? Maybe compatibility with my product...
There may be a solution to watch movies with subtitle? i can watch 1080p but idk how to run the subtitle.
Or i can burn the subtitle in movie but now in 10 hrs....?
I will appreciate any message.
Thanks.

Paul
02-25-2013, 09:29 AM
From our knowledge, Sony Bravia TVs don't support streaming external subtitle files or embedded subtitle channels in video files. So, Mezzmo will burn your subtitles into your video when streaming your video to your Sony Bravia TV. If your subtitle is an embedded channel inside your MKV, then you will need to extract it first. Right-click on the MKV video in Mezzmo and click Properties. Go to the Subtitles tab and click Extract Subtitles to extract the embedded subtitle and save it as an external subtitle. Next, go the the Transcoding tab and delete any transcoded files for this MKV file. Now try streaming the MKV to your Sony Bravia TV. Mezzmo will start transcoding the MKV file so that your subtitle is burnt into the video.

Also, make sure you have upgraded to the latest version of Mezzmo (v3.0.2.0) as it has improvements for streaming subtitles.

BlueCrane
02-26-2013, 01:45 AM
Hi there,

Thanks, Paul. That helped me for some of my files. Though I have another question about subtitles. I'm trying to stream Chinese subtitles to my Samsung D tv, but it's not working correctly (I think because the tv hasn't got the correct character set: with some Chinese sub-files I get jibberish, some show a few good characters, but together with squares).
So I want to transcode the file with the subtitles. In the subtitle tab for the video, everything is fine (.srt, recognized as Chinese, external, correct ANSI/OEM Simplified Chinese encoding, and in the Subtitle Settings everything looks fine).
In the Device Settings, I set the "Burn subtitles for these languages" on Chinese and "Burn subtitles into video files" is checked. On the transcoding tab I checked the box for transcoding incompatible files too.

The result is that it streams (not transcodes) the file to my tv with jibberish subtitles. Can you tell me what I'm missing here?

Thanks in advance,

Blue

Paul
02-26-2013, 11:09 AM
Hi Blue,

Regarding the jibberish characters displayed on your TV, did you try changing the subtitle encoding on your Samsung D-series TV? Press the Tools button on your remote control when the video is playing and go to Subtitle Settings -> Encoding settings on your TV. You may need to change the encoding to Chinese to get the characters displayed correctly.

If no better, then there's a few ways to get subtitles burnt into your videos:


If you want all your videos to have burnt subtitles for your device (rather than streaming external or embedded subtitles), then go to the Media Devices dialog in Mezzmo and edit your device. On the Device Settings dialog, go to the subtitles tab and turn off 'Stream external subtitles' and 'Stream embedded subtitles' checkboxes, so that the 'Burn subtitles into video files' checkbox is the only subtitle streaming type turned on. Now when you stream a file to your TV, any associated subtitle will be burnt into your video. You will see this in the Transcoding pane in Mezzmo when you are streaming a video.
If you just want certain video files to have burnt subtitles (since the other videos & their subtitles display fine on your TV), then leave the external and embedded subtitles checkboxes turned on in the Device Settings dialog. Now, right-click on the video file in Mezzmo and click 'Pre-transcode Files'. In the Pre-transcode Files dialog, choose your TV and click 'Choose Formats'. Choose the bolded format and then select the 'Force burning subtitles' checkbox. Click OK to save the format setting and click OK to start transcoding. Once transcoding has completed, try streaming the file to your TV again.

BlueCrane
02-27-2013, 01:19 AM
Thanks a bunch Paul, that helped me a lot. It works now, unchecking the Streaming and Embedded boxes worked: it's streaming/transcoding with the proper Chinese characters. (Still don't know why it didn't work with the "Burn subtitles for these languages" set to Chinese and the subtitle correctly recognized as Chinese)

However, I still have a problem. The subs are really tiny and more or less in the left center of the picture (should be at the bottom/middle). If I check the Subtitle Settings dialog for this particular file and corresponding subtitle (where the preview shows the text also in the center of the picture), I can enlarge the font to a maximum of 44, which increases the burnt subtitle size, but it is still quite small and difficult to read from 4 meters away. I could also not find any option to change the placement of the burnt (*.srt) subtitles in the application of Help function.

So is there a way to change the size/placement of the burnt subtitle?

Thanks in advance, your help is much appreciated!

-Blue

Edit: Changing the encoding settings on the tv didn't work, there is no option for Chinese, just Hebrew, Arabic, Korean, etc.

Paul
02-27-2013, 08:56 AM
Hi Blue,

Thanks for reporting this. We'll reproduce that here and fix this. Can you take a photo of your TV when playing the video with the small subtitles? Email it to us at support [at] conceiva [dot] com. In your email, please also include the external subtitle file (.SRT, .SMI, etc.) that is being burnt into the video. And, also send us the FFmpeg information on the video that you are streaming. To get this info, right-click on the video in Mezzmo and click 'Get FFmpeg Information'.

BlueCrane
02-28-2013, 06:23 AM
Hi all,

I found the problem, but it's still not completely fixed.
When transcoding the file, I used a standard PAL preset (768x576) for my full hd tv (1920x1080). This caused the subtitles to be misplaced and shrunk. Changing the preset to my native resolution (1920x1080) solved the problem, but takes a lot more time to transcode.

I don't know if there will be a fix for this in the future, but for now I can work around this.

Cheers,

-Blue

Paul
02-28-2013, 10:48 AM
Thanks for reporting this, Blue. We'll test this here and try to reproduce the problem. Also, we have your logs that you sent via email. We will analyze them shortly & will report back.