View Full Version : Playing subtitles embedded in mkv and selection of audio

08-05-2010, 10:34 AM
Hi, is it possible to play subtitles embedded in mkv ? And how do i select different audio and select subtitles to be played along with the mkv file ? thanks !

08-05-2010, 11:06 AM

Which device are you streaming to? Some devices support subtitles embedded in MKVs, some don't. If the device supports them, then you should be able to select them using the device's remote control. If not, then the next major update for Mezzmo will allow burning subtitles in, so that they'll be shown when you play the file.

08-05-2010, 09:18 PM
thanks for fast reply, I'm using Samsung UA40C7000WM but i cant seem to play audio embedded in MKVs and certain MKV such as

FFmpeg version SVN-r24378, Copyright (c) 2000-2010 the FFmpeg developers
built on Jul 21 2010 12:51:48 with gcc 4.4.0
configuration: --enable-static --disable-shared --enable-memalign-hack --enable-libmp3lame --extra-cflags=-I/c/msys/local/include --extra-ldflags=-L/c/msys/local/lib --enable-zlib --enable-w32threads --extra-cflags=-fno-common --enable-gpl --enable-libx264 --disable-ffplay --disable-ffprobe --disable-ffserver --enable-postproc --enable-runtime-cpudetect --extra-cflags=-U__STRICT_ANSI__
libavutil 50.22. 0 / 50.22. 0
libavcodec 52.84. 0 / 52.84. 0
libavformat 52.76. 0 / 52.76. 0
libavdevice 52. 2. 0 / 52. 2. 0
libavfilter 1.25. 1 / 1.25. 1
libswscale 0.11. 0 / 0.11. 0
libpostproc 51. 2. 0 / 51. 2. 0
[matroska @ 014bc940] max_analyze_duration reached
[matroska @ 014bc940] Estimating duration from bitrate, this may be inaccurate

Seems stream 0 codec frame rate differs from container frame rate: 47.95 (5994/125) -> 23.98 (24000/1001)
Input #0, matroska, from 'C:\lolol\[Kanketsu-hen] Inuyasha - The Final Act - 25 [720p][37EAC012].mkv':
Duration: 00:23:49.90, start: 0.000000, bitrate: N/A
Stream #0.0: Video: h264, yuv420p, 1280x720, PAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc
Stream #0.1(jpn): Audio: aac, 48000 Hz, stereo, s16
Stream #0.2(eng): Subtitle: [0][0][0][0] / 0x0000
Stream #0.3: Attachment: [0][0][0][0] / 0x0000
filename : Amira-Semibold.otf
Stream #0.4: Attachment: [0][0][0][0] / 0x0000
filename : arial.ttf
Stream #0.5: Attachment: [0][0][0][0] / 0x0000
filename : Arialtbg.ttf
Stream #0.6: Attachment: [0][0][0][0] / 0x0000
filename : icedeart.ttf
Stream #0.7: Attachment: [0][0][0][0] / 0x0000
filename : Nonserif.ttf
Stream #0.8: Attachment: [0][0][0][0] / 0x0000
filename : PAPYRUS.TTF
Stream #0.9: Attachment: [0][0][0][0] / 0x0000
filename : y2k.ttf
Stream #0.10: Attachment: [0][0][0][0] / 0x0000
filename : ALIEN5.TTF
At least one output file must be specified

08-06-2010, 08:47 AM
I could be wrong, but I don't think that the Samsung TVs support embedded subtitles (in MKV or other files). They support external SRT/SUB files though.

That file doesn't play at all or it just doesn't show subtitles? Are you using the "Samsung B" or "Samsung C" device profile for it (it'll be in the Media Devices dialog)?

08-06-2010, 09:24 AM
I can play most of the MKV files only certain file such as the one above i cant. For those playable, all of them doesn't show subtitles. As for profiles i had no idea, need to check it when i reach home :P. Is it possible to select audio if there's two different audio embedded in the MKV ?

08-06-2010, 09:36 AM
At the moment you cannot choose which audio will be streamed via Mezzmo. Some devices allow you to choose an audio stream when the video is playing. This should be available in Mezzmo with the next major update (along with subtitles).

I'll wait for you to tell me which device profile you're using and we'll proceed from there.

08-07-2010, 01:27 AM
Hi i tried both profile, doesn't work =(

08-09-2010, 09:02 AM
Can you please turn on logging (see this thread: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging), then try to play that file using the "Samsung C" device profile and once it fails, stop the server and send the log to support (at) conceiva (dot) com for investigation. Also, it'd be great if we could have a copy of that file, if that's possible (either through www.megaupload.com or a similar site or if you can give us an original download link via the support e-mail).

09-17-2011, 07:11 PM

this thread is 1 year old, and I wish to know if now it is possible to play mkv with subtitle embedded.
I use a samsung TV ue40d5720 serie 5 and the mezzmo profile 'samsung D'.
The video play but the subtitle is not display. Just for information, on this kind of TV, MKV with more than one audio stream work fine, I can change the audio.
I encounter the subtitle problem on this kind of video :

ffmpeg version N-31788-g0d4ea7b, Copyright (c) 2000-2011 the FFmpeg developers
built on Aug 10 2011 11:16:35 with gcc 4.4.2
configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-mingw32- --enable-static --disable-shared --enable-zlib --disable-ffplay --prefix=/media/windows/ffmpeg --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --pkg-config=pkg-config
libavutil 51. 11. 1 / 51. 11. 1
libavcodec 53. 10. 0 / 53. 10. 0
libavformat 53. 6. 0 / 53. 6. 0
libavdevice 53. 2. 0 / 53. 2. 0
libavfilter 2. 28. 1 / 2. 28. 1
libswscale 2. 0. 0 / 2. 0. 0
libpostproc 51. 2. 0 / 51. 2. 0
[matroska,webm @ 018db000] max_analyze_duration 5000000 reached at 5000000
[matroska,webm @ 018db000] Estimating duration from bitrate, this may be inaccurate
Input #0, matroska,webm, from 'E:\Data\audio\Placebo-Once_More_With_Feeling-Retail-2004-NOV\video\Placebo -Twenty years - sub ENG FR.mkv':
Duration: 00:03:25.32, start: 0.000000, bitrate: N/A
Stream #0.0: Video: mpeg4, yuv420p, 640x480 [SAR 1:1 DAR 4:3], 25 fps, 25 tbr, 1k tbn, 25 tbc (default)
Stream #0.1: Audio: pcm_s16le, 44100 Hz, 2 channels, s16, 1411 kb/s (default)
Stream #0.2(eng): Subtitle: [0][0][0][0] / 0x0000 (default)
title : Lyrics ENG
Stream #0.3(fre): Subtitle: [0][0][0][0] / 0x0000
title : Lyrics FR
At least one output file must be specified

---> DB Level Info: -99, -99
---> Frame rate: 25,00
---> Aspect ratio: 4:3

Thanks a lot !

09-19-2011, 09:07 AM

If the TV doesn't support embedded subtitles, then nothing has changed yet - the burn-in subtitles feature will be released with the next major Mezzmo update. If you press the Tools button - do you get a subtitles option in that menu (while you are playing the video)? If you don't then most likely your TV doesn't support embedded subtitles. If you get an .SRT, it should work though.

09-23-2011, 02:14 AM
Hi !
Thank you for your answer.
My Tv seems to doesn't support embedded subtitles.

For the .srt file, is this can works even if the video I run is accessible via a smart playlist which filter by video file type (and perhaps exclude the srt file type) ?

Thanks !

09-23-2011, 08:49 AM
Yes, it doesn't matter how you access the video, we'll find a subtitle file for it, if it's in the same folder on disk with the same filename, but just a different extension.

09-24-2011, 01:01 AM
Hi Dennis,

Ok. Thank you very much for your quickly aswer, as usual :).


10-09-2011, 09:16 PM
my current equpment includes two DLNA players:
64D8000 Samsung TV set that supports external only subtitles (srt) via the lan.
PDP-S480 Sony BD player which supports embedded only subtitles from USB DOK located files.

By moving to mezzmo, can I expect any upgrade of subtitles capabilities, such as DLNA lan external on Sony ?

10-10-2011, 09:27 AM
If the Sony doesn't support external subtitles, then at the moment Mezzmo cannot help you. We'll be releasing a version that supports burning subtitles in and once that's out, Mezzmo will be able to grab your external subtitles and burn them onto the video to show on the Sony.

10-10-2011, 05:18 PM
Dennis thanks.
What seems to be the rough schedule for new release?
Do you know if current mezzmo revision supports embedded subtitles via the LAN on Sony ?
I'm currently using serviio which doesn't support Sony embedded via the net. So the only way to show embedded subtitles is by playing the mkv file on Sony blue-ray via USB device.
Unfortunately Samsung D series doesn't support embedded at all (not on USB device as well), although I like it's streaming control menu as it seems to be superior to Sony's.

10-11-2011, 08:45 AM
There is an option in Mezzmo to try and copy embedded subtitles when transcoding, so it may or may not work - if you'd like, please open a suport ticket and we can give it a try (it has to be manually enabled, as it's off by default). If the Sony supports embedded subtitles and they are successfully copied, then it may work.

Unfortunately I cannot disclose any schedules. The next major development step to be released is pre-transcoding and that's coming out soon; after that subtitles will be the next big thing.

10-15-2011, 05:58 PM

My question is, does anyone have .srt subtitle files working with Mezzimo and Samsung TV's or Blu ray players?
I've tried everything (except hard encoding the subtitle into the video) and nothing works so far.

I have a Samsung BD-C6900 bluray player and 50C7000 TV. I know the bluray player supports subtitles with discs anyway.
I've tried both the BD player and the TV DLNA network streaming with Mezzimo and nothing works so far.

Has Mezzimo incorporated hard encoding of subtitles as mentioned above yet? If not, I would encourage this as a priority, since I think everything else about Mezzimo is fine so far (and working well).

I have ver of Mezzimo. And 'yes, the .srt file has the same name as the .m2ts file and is in the same folder'.
There is no subtitle menu available from the TV or bluray's remote's tools button.

I would be happy if I could get the subs to at least work on the TV's DLNA input as it seems to have a more advanced tools menu than the blu ray player does. Luckly I have an ARC HDMI port and can loop the multi channel audio back to my audio system instead of using the TV speakers. Was glad to get that working but disappointed the subtitles still won't work.

I see a lot of posts about questions with subtitles but no "Yeah it works!" replys so far. This is a big problem if the movie has a lot of forced subtitles and you don't speak both languages.
I would much rather see this is resolved before any other improvements are made.

TIA :)

10-16-2011, 04:54 AM
Another vote for subtitles...

10-17-2011, 09:03 AM
When you added that file to Mezzmo, were the subtitles already in the folder, or did you drop in the subtitles later? If later, then you need to run maintenance for them to be picked up.

If you've done that, then please enable logging (see this thread: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging), then browse to that file on the BDP and start playing it. After a few seconds stop it, stop the server and send in the logs and we'll investigate.

10-17-2011, 03:38 PM
Hi Dennis,

Thanks for the reply and am happy to report that subtitles are indeed working with Mezzimo and my BD-C6900 Samsung bluray player using the Samsung BDP-3D profile under the 'media devices' tab.

I am not sure why it is suddenly working now except that before I enabled logging I moved the original .m2ts video file and .srt file to a new location, re-named the directory and re-added it to the Mezzimo play list. That forced the video to be re-encoded by Mezzimo and VOILA subtitles worked! I now have the 'subtitles' menu on the C6900's tools remote button too!

Previously, I had tried adding the subtitles .srt file to the folder that already contained the transcoded version of the .m2ts video file and even though I had deleted the original playlist reference and re-added the folder with the transcoded and .srt files to the Mezzimo play list, the subtitles still wouldn't work.

So my remaining question is, does the video have to be transcoded by Mezzimo to see the subtitles? I'm still not sure why it's working now, but very happy about it either way :)!


10-17-2011, 03:42 PM
No, the video doesn't have to be transcoded. If you add subtitles to a file after that files has already been added to Mezzmo, you need to run Maintenance (choose only to update changed information) and that'll pick the subtitles up.

10-17-2011, 04:42 PM
Awesome! I wonder if that's why a lot of people are having problems with subtitles? A refresh problem?

Subtitles are now working on both my Samsung C7000 TV and C6900 bluray player.

Thanks Dennis, from another satisfied customer! :)

10-17-2011, 04:44 PM
I'm glad it's working! :)

We do have a note in release notes on the forum (News section) about maintenance, but it's not prominent enough, unfortunately...