View Full Version : Firefox integration no longer works

08-22-2010, 10:47 PM
Few days ago the Firefox integration started not working anymore, without a reason. Both the toolbar and right-click context menu items are gone. I've tried to uninstall and install the DownloadStudio Extension again, but got no luck.

OS is Windows XP Pro, w/ Firefox 3.6.8 and latest ver. of DS.

Anyone could help? Thanks a lot in advance!

08-23-2010, 08:04 AM
The DownloadStudio firefox extension sometimes has problems with other Firefox extensions, have you recently installed a new firefox extension or updated an existing one? Try disabling the other extensions in firefox until you can get DownloadStudio to work.

09-10-2010, 09:14 AM
I also have Firefox 3.6.8 with DownloadStudio Integration plugin 6.0. I've disabled all other plugins and still face the issue of not being able to save any changes to the plugin options. The options page for DownloadStudio comes up, but the OK button to save the changes does nothing. Any thoughts?

09-10-2010, 09:29 AM
It is possible that the DownloadStudio extension files have become corrupted and are causing the DownloadStudio addon to malfunction. The options will fail to operate correctly if the DownloadStudio XPCOM component is not registered correctly, could you please try uninstalling the DownloadStudio firefox addon and then re-install?
Do you see the DownloadStudio toolbar?
If you right-click the page do you see the DownloadStudio menu?

09-10-2010, 09:53 AM
right click doesn't show downloadstudio.
toolbar doesn't show up eventhough when I go to View->Toobars the downloadstudio toolbar is checked
uninstall/re-install had no effect

Is it possible to do a clean uninstall of the plugin? I used to have an older version that worked perfectly, but when I upgraded to this version, that's when the problem started.


09-10-2010, 10:04 AM
FYI...I used Flashgot instead of the downloadstudio plugin and the integration works now.

09-10-2010, 10:20 AM
It sounds like the registry entry for DownloadStudio's path is missing, the DownloadStudio Firefox extension relies on the path in HKEY_LOCAL_MACHINE\SOFTWARE\Conceiva\DownloadStudi o to find DownloadStudio. If DownloadStudio is not found then it is determined that DownloadStudio is not installed and the toolbar and menu items should not be shown.

Are you able to run regedit.exe and check to see if the 'Path' exists in this registry key?

09-10-2010, 11:52 AM
The path exists and is correct. I did a complete uninstall and re-install of DownloadStudio itself and that removed some old registry entries for the previous version (5.0) but still the problem persists.

Things are working now that I'm using Flashgot, but there is definitely an issue with the Downloadstudio plugin.

09-10-2010, 01:26 PM
We have made some changes to the firefox plugin for Firefox 4 that affect they way it is registered within firefox, could you please try this latest extension to see if it works for you?
You can download it from http://www.conceiva.com/temp/downloadstudio.zip, you will need to rename the file once you have downloaded it to 'downloadstudio.xpi' so that you can install it into firefox, just drag and drop it onto the firefox window to install.

09-27-2010, 10:27 AM
Following up on this - I started the trial then promptly upgraded to Firefox 3.6.8. After that Firefox upgrade the plugin stopped working. Upgraded Firefox to 3.6.9 and 3.6.10 and the plugin still didn't work. Finally I uninstalled the plugin, completely uninstalled Download Studio, installed DS, and finally it looks like the plugin is working. Hopefully I can complete the trial now since I've heard pretty good things about DS.

BTW I had another plugin act the exact same way when they made changes for Firefox 4.0 and it also required multiple uninstalls plus editing the prefs.js file.

09-27-2010, 02:45 PM
Thanks for the information, we will investigate this and see if we can reproduce the behavior.