View Full Version : Samsung UE40B8000

08-31-2010, 05:16 PM
I'm trying to get Mezzmo working correctly for my Samsung UE40B8000 TV.

By default it selects the Samsung A profile, but then only plays for like 5 seconds. But it plays the video full screen, which is the first DLNA player who does it with all vid's ;)

When I switch to Samsung B profile (which should be the right one for this TV) I cannot play anything. It keeps telling me that the video codec is not supported for all types of videos.

When I turn off transcoding I can only play MKV files.

I'm running version

Can you please help me?

08-31-2010, 05:27 PM
I could be that your files are being transcoded by Mezzmo, but transcoding may be slow on your computer (speed of transcoding is directly related to your available CPU and memory). So, Mezzmo may not be able to stream the video to your TV since it's being transcoded & there's nothing to send to your TV at the moment.

To confirm this, perhaps try selecting a file to play on your TV and start it playing. If it stops, then wait for a few minutes, and try it again. Don't try other files during this time - just wait. Try playing it again, and if it gets further, then that tells you that the file is being transcoded and it's taking quite a long time. You will have to be patient or look into your computer's available CPU and memory.

We will be adding in a few new features into Mezzmo that will help you in this area. Stay tuned!

08-31-2010, 06:24 PM
It seems that you are right. I've been able to watch several minutes now.

However, my pc has a Intel Core2 Quad CPU (2.66GHz) and 8 GB of RAM. Maybe it has something to do with the fact that I'm running Windows 7 x64 and that Mezzmo is x86?

Looking forward to the new features. If you need me to test something, please let me know.

One other thing though. Why do I have to select the Samsung A profile on my B tv?

08-31-2010, 06:40 PM
Mezzmo runs very well on 64-bit Windows, so that will not be the issue.

Use Task Manager to check your available memory and CPU. That may pinpoint if you are running other apps at the same time.

Transcoding video can be very CPU and memory intensive - especially HD video. It will take many minutes to transcode a full-length HD-quality movie.

When transcoding, you will see ffmpeg.exe in your list of processes in Task Manager.

Some of our users recommend using the latest build of FFmpeg.exe to increase performance. If you are willing to experiment a little, you can get FFmpeg builds from this site (http://ffmpeg.arrozcru.org/autobuilds/). Make a backup of the existing ffmpeg.exe file in case you need to revert back to the version Mezzmo provides.

08-31-2010, 08:49 PM
Thanks for the help, but untortunately I'm still facing the same issue.

I've tried todays build of FFmpeg, but that gives the same result. The same does an older x64 build (just trying). When transcoding it starts four threaths (as expected), but only one claims CPU time.

I've also tried to lower the video bitrate through the device settings window of my TV (in Mezzmo). Again, the same result and without noticeble difference on tv.

Any ideas?

08-31-2010, 09:40 PM
The factors that are critical for transcoding speed are: the file you are transcoding (size, bitrate, format, etc.), the format you are transcoding it to, the location of the file being transcoded (slow NAS drive or fast harddisk?), and the available CPU/memory of your computer.

Send me a set of log files of you connecting, browsing and trying to play media, and we'll take a look. See this thread how to do it: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging. Zip all log files and send to support [at] conceiva [dot] com. Also send me the FFmpeg information that you are transcoding. To do this, right-click on the file in Mezzmo and click "Get FFmpeg Information".

08-31-2010, 10:44 PM
Send you the information by mail.

Thanks again for the support.

02-11-2012, 10:20 AM

I have the same TV model as bengels --> Samsung UE40B8000. I am trying to use the MEZZMO for streaming mkv's with subtitles and I must emphasise that I am really happy with mezzmo app and its transcoding capabilities thanks to FFmpeg.
I read somewhere that mezzmo does not support embedded subtitles, but it should support text subtitles ( subtitle should match the same name as video file in the same folder... ), correct me if I am wrong.
My problem with subtitles is that I can see the subtitles just going through on the TV screen really fast the first few seconds at the very beginning when I start playing the video from mezzmo DLNA server, at the time when TV set is doing its local caching or whatever it is doing at the beginning when it is preparing to decode the stream.

I am using the latest fw on my TV set, and i am using Mezzmo build

It would be really cool if I could get the subtitles working.

Thanks and Kind Regards

02-11-2012, 07:51 PM
I had the same issue. It can be solved by changing profile. In this version of Mezzmo I use the Samsung B (compatible) profile.
If you start the movie you will see that the timer is very fast. Thats why you dont see the subtitles ;)


Ps: i don't use any transcoding. The tv can handle almost every format by itself.

02-11-2012, 11:34 PM
Hi Bengels,

Thx for the info.
My default setting was Samsung B profile and I already tried the Samsung B (compatible) and i have this issue with both profiles. Actually i am still on B - compatible,
I will try to turn off the transcoding for all connected devices and if that does not work i will install the same version of the mezzmo DLNA server you are using ( )
Can you tell me which fw version u are using on the TV set?

Here is my info:


I will let you know how it goes

02-12-2012, 12:10 AM
With this version I meant that I'm using Mezzmo, the latest version atm. I run the same firmware version as you do and I don't think any newer version will ever come ... :(

The strange thing with Mezzmo is that it's different after every update. Sometimes I need to use the Samsung B profile, which worked quite well for a while until yesterday, that's why I switched to the B compatible profile.

Which files are you trying to play AVI of MKV? I noticed that with MKV that has DTS sound the tv is unable to play it without transcoding. Instead of transcoding I change the audio stream.

Good luck!

02-12-2012, 12:18 AM

I have turned off the transcoding, but only one of the 10 mkv's i tried worked and even this one had some problems with subtitles ( the subtitles were few seconds off )
2 or 3 mkv's didn't work at all. All the rest had audio problem ( i believe Samsung supports AC3 and majority mkv's have DTS )
I believe that when transcoding videos "on the fly" the subtitles are being force pushed the decoder ( TV ), and the rest of the content ( mpegts ) is being decoded normally.

I will pre-transcode the files and try again. I'll be back. :)

BTW, I also noticed that when I have the feature "transcoding for all connected devices" ON I could fast forward and rewind, but with this feature OFF i couldn't

02-12-2012, 02:26 AM
Instead of transcoding i use handbrake to make the mkv's compatible with the tv. However, i only need to do that very rarely. Maybe 1 out of 50, but i also use it when audio and video are out of sync.

have you already tried to play these files using another profile; e.g. Samsung C? Maybe it plays those files fine then?

Or post the ffmpeg info on here, to see whats wrong with the file.


02-13-2012, 10:42 AM
Yes, please let us know how your testing goes, but just to clarify things a bit - external subtitles are sent to the device separately from the video file. Basically we tell the TV that we have an .srt file and the TV then requests it when it decides to. After that it's up to the TV to decode the .srt file and display it on screen. So, Mezzmo does not handle/touch the .srt subtitles in any way. It's possible that they can be out of synch with transcoded files, but once a file has been fully transcoded (pre-transcoded), they should work.

Can you please send one of your subtitle files to support, so that we could check if there's anything wrong with it?