View Full Version : Karaoke audio

09-19-2010, 12:52 PM

I'm using Mezzmo streaming karaoke .vob to my LG bluray. Everything works perfectly except one tiny problem. When I try to change audio type from 1 to 2 (to make the vocal silent, just the music), it does not work. It seems like it always using audio 1 with the vocal. If I play the .vob in standalone player on my laptop, it works as expected. Does anyone know how to make this work? My LG 570 does not play .vob directly so I think Mezzmo has done some transcoding on the fly. I'm not sure if that's the reason? TIA



09-20-2010, 09:17 AM

Yes, that would be the reason - when transcoding occurs, only one audio channel is kept (currently the first one in the file), so that drops the other audio streams from the file.

On a side note, if the VOB is a standard MPEG2, then I would think that the LG should play it natively without transcoding? Can you please post FFmpeg information on one of those files (in Mezzmo right-click on the file and use the "Get FFmpeg Information" command). Maybe a device profile update will solve this issue :)

09-21-2010, 06:40 AM
Thanks Dennis. I already updated LG's firmware to the latest and the issue is still there.

Here's the FFmpeg info:

FFmpeg version SVN-r24894, Copyright (c) 2000-2010 the FFmpeg developers
built on Aug 24 2010 15:03:07 with gcc 4.4.0
configuration: --enable-static --disable-shared --enable-memalign-hack --enable-libmp3lame --extra-cflags=-I/c/msys/local/include --extra-ldflags=-L/c/msys/local/lib --enable-zlib --enable-w32threads --extra-cflags=-fno-common --enable-gpl --enable-libx264 --disable-ffplay --disable-ffprobe --disable-ffserver --enable-runtime-cpudetect --extra-cflags=-U__STRICT_ANSI__
libavutil 50.24. 0 / 50.24. 0
libavcore 0. 6. 0 / 0. 6. 0
libavcodec 52.86. 1 / 52.86. 1
libavformat 52.78. 3 / 52.78. 3
libavdevice 52. 2. 1 / 52. 2. 1
libavfilter 1.37. 0 / 1.37. 0
libswscale 0.11. 0 / 0.11. 0
[mpeg @ 016ae6b0] max_analyze_duration reached
Input #0, mpeg, from 'C:\My Videos\karaoke-sample.vob':
Duration: 00:05:00.78, start: 0.060000, bitrate: 4905 kb/s
Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x480 [PAR 32:27 DAR 16:9], 8200 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
Stream #0.1[0x81]: Audio: ac3, 48000 Hz, stereo, s16, 448 kb/s
Stream #0.2[0x80]: Audio: ac3, 48000 Hz, stereo, s16, 448 kb/s
At least one output file must be specified

09-21-2010, 08:51 AM
Thanks for the info - that file should be passed through natively, without transcoding. Can you please enable logging (see this thread: http://forum.conceiva.com/showthread.php/419-FAQ-How-to-turn-on-diagnostic-logging), then try to play that file, after it starts playing, stop the server and send the log to support (at) conceiva (dot) com and we'll take a look at why it's being transcoded.

09-21-2010, 02:12 PM
Thanks Dennis. I just sent the log file to support. Hope to hear from you soon.

09-21-2010, 02:15 PM
Yes, I received the logs - I'll get back to you shortly via e-mail.