PDA

View Full Version : MP4 not filtered by categories



WillPittenger
08-12-2016, 01:51 PM
When I download videos from YouTube, they turn out to be MP4 files. For some reason, DownloadStudio fails to put them into the Video category. I verified that MP4 is one of the files I thought would be filtered out. But it isn't.

Peter
08-15-2016, 09:58 AM
Hi,
the video category does not contain the *.mp4 extension so you will need to add it. Go to Tools then select Options and under General select File Types. Expand Video Files and click Add... then type the Name as Mp4 and set the Group as Video Files if it is not already set and type the Extensions as *.mp4 then click OK. Then go to 'File Type Lists' and select Video Files and click 'Edit...'. Expand Video Files and check the box for mp4. Your video files should now get categorized and set in the Video folder. Make sure in Categories under Video the box 'Default Download folder' is checked.

WillPittenger
08-17-2016, 05:47 AM
I checked that and found "*.mp4" in the list. If it wasn't in there originally, I added it. They still aren't being filtered. I thought I set up a different default download folder for videos.

Peter
08-17-2016, 09:08 AM
Hi,
please check in Options under General->Categories that 'Use Auto Categorization to add downloaded files to categories based on file type' is checked. This is off by default.

WillPittenger
08-17-2016, 09:24 AM
It's checked for me. I must have turned it on when I first configured the application.

Peter
08-17-2016, 09:52 AM
Please also make sure 'Default Download Folder' is checked in the Video category 969. This is also unchecked by default.

WillPittenger
08-17-2016, 09:56 AM
It's checked.

Peter
08-17-2016, 10:41 AM
It may be a problem with the filename generated, DownloadStudio uses the file extension to auto-categorize. Please try with the patch I sent you to see if this resolves the problem.

WillPittenger
08-17-2016, 10:55 AM
Patch installed. No change noted.

Peter
08-17-2016, 01:51 PM
I reproduced the problem here and found that the only way to get it to auto-categorize mp4 was to add a separate mp4 to the filetype lists then add this to the video category and it worked to auto-categorize. Go to Tools then select Options and under General select File Types. Expand Video Files and click Add... then type the Name as Mp4 and set the Group as Video Files if it is not already set and type the Extensions as *.mp4 then click OK. Then go to 'File Type Lists' and select Video Files and click 'Edit...'. Expand Video Files and check the box for mp4.

WillPittenger
08-17-2016, 02:11 PM
Thanks. Do you think it'll be fixed in a future version?

Peter
08-17-2016, 02:37 PM
Yes, we will fix this for the next version we release.