PDA

View Full Version : Firefox compatibility



DrTeeth
10-13-2019, 11:07 AM
Does DLS work with the latest versions of Firefox? The site gives the impression that it does, but the last I heard from Conceiva was that the plugin stopped working with the plugin change that Mozilla instigated. I am currently using Firefox 70 beta and *all* download utilities have stopped working sadly.

Cheers

DrT

Peter
10-14-2019, 08:11 AM
Yes DLS does work with the latest versions of Firefox. Go to https://addons.mozilla.org/en-US/firefox/addon/downloadstudio/ in Firefox and install the addon.