Results 1 to 4 of 4

Thread: Debugging PLayback Issues

  1. #1
    Join Date
    Nov 2015
    Posts
    4

    Default Debugging PLayback Issues

    I am setting up my media server after a long downtime. My collection of movies (DVD and Bluray) are in ISO format. Currently we have Roku devices of varying models on every television, which are different in functionality as what what was used before.

    Transcoding is turned off, as the hardware is stated to support streams of MPEG/VOB and M2TS formats.

    I am having issues playing back many titles, which I never had issue with before. The common error ends up being "File Not Playable - The File Might Be Damaged Or Corrupt". This does not happen with every title, but a lot of them. It also happens with both DVD and Bluray ISOs.

    How can I debug the failure for the playback of these titles? If I "Enable Diagnostic Logging For Customer Support Analysis", the produced log file is full of so much unrelated information, I can't make use of it. If this is not enabled, the logs that are left, it is unclear where I should be looking.

    Thank you

  2. #2
    Join Date
    Jun 2012
    Posts
    415

    Default

    You might want to look at the audio format and not just the video container of the ones that fail and see what is in common. The Roku devices historically have had a limited audio codec set especially for bitstream audio formats (i.e. True-HD, DTS MA etc..). Do they all play if transcoding is enabled ? I suspect so.

  3. #3
    Join Date
    Nov 2015
    Posts
    4

    Default

    Quote Originally Posted by jbinkley60 View Post
    You might want to look at the audio format and not just the video container of the ones that fail and see what is in common. The Roku devices historically have had a limited audio codec set especially for bitstream audio formats (i.e. True-HD, DTS MA etc..). Do they all play if transcoding is enabled ? I suspect so.
    I understand the audio codec problem with Roku's, which is why I wanted to gather more information for debugging. I could spend many many days going through the whole library, loading the iso, checking the default audio stream, try playing it on all streaming devices, and logging where it fails. One of the Roku's seem to play more than others, and just doesn't play audio on some, because I'm *guessing* that it just plays the incompatible audio track. But also, it fails to load some ISOs at all.

    Yes, they play with Transcoding enabled, but the lack of transcoding options really makes that feature undesirable. It would be nice, rather than full transcoding, that if it is simply an audio incompatibility, that Mezzmo server would rather demux, recode the audio, then remux on the fly.

  4. #4
    Join Date
    Sep 2009
    Posts
    2,221

    Default

    Mezzmo does demux, recode the audio and remux the video on the fly where possible but some containers do not support the video/audio codecs so a full transcode is required in these cases. None of our Roku Streaming Player profiles have mpegts or mpeg support enabled because the Roku does not support seeking in these containers. To debug why some videos fail you can try right-clicking on the file in Mezzmo and select 'Get FFmpeg Information...' then see what the audio and video codecs are and also the video bitrate because if this is too high the video might not play.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

Similar Threads

  1. PS3 Playback Issues
    By Ahlitah in forum Mezzmo Questions and Support
    Replies: 10
    Last Post: 06-18-2014, 04:40 PM
  2. Sony BDP S580 Update and Playback Issues
    By hangnail in forum Mezzmo Questions and Support
    Replies: 23
    Last Post: 11-05-2012, 05:02 PM
  3. playback issues
    By Dissident in forum Mezzmo Questions and Support
    Replies: 4
    Last Post: 12-20-2011, 05:39 PM
  4. LG BD670 Display, Connection and playback issues.
    By Slyck in forum Mezzmo Questions and Support
    Replies: 29
    Last Post: 08-26-2011, 10:16 AM
  5. Various playback issues on two different players
    By kaotik78 in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 04-05-2011, 10:07 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •