Results 1 to 7 of 7

Thread: Infuse 7 Updating LastPlayDate When Browsing Playlists

  1. #1
    Join Date
    Jul 2013
    Posts
    45

    Default Infuse 7 Updating LastPlayDate When Browsing Playlists

    Infuse on my iOS devices work great with Mezzmo 6. That said, when I browse a playlist, all movies on the list are modified with the current date/time as their LastPlayDate. It only happens with Infuse. The issue is, I cannot maintain a "last 15" movie playlist because the legitimate movies are pushed off the list by Infuse. Very irritating. I have emailed Firecore about this too. Any idea how to stop this?

  2. #2
    Join Date
    Jun 2012
    Posts
    720

    Default

    Quote Originally Posted by vguitarist View Post
    Infuse on my iOS devices work great with Mezzmo 6. That said, when I browse a playlist, all movies on the list are modified with the current date/time as their LastPlayDate. It only happens with Infuse. The issue is, I cannot maintain a "last 15" movie playlist because the legitimate movies are pushed off the list by Infuse. Very irritating. I have emailed Firecore about this too. Any idea how to stop this?
    It might be some preview feature with Infuse. You might want to check the increment playcount option on Mezzmo and raise the percentage to see if that fixes it. I keep mine at 60%. You can find this option under Tools-->Options-->Streaming


    Jeff

  3. #3
    Join Date
    Jul 2013
    Posts
    45

    Default

    Here's what Firecore said (developer of Infuse): "During scanning, Infuse will read details from the video files in order to display things like duration and codec info. It looks like your server is treating these as plays.". While this is true, I don't buy their conclusion...but it is all I have.

    Similiar to jblinkley60's thought, a new setting in Mezzmo to pause the play clock until some portion of the movie plays -- say, 3 seconds (user defined) -- would fix my issue. It would allow the player to connect/disconnect the media files before the stream play clock begins counting. The tradeoff would be no resume for the few seconds the clock is paused. Just a thought.

    When I get a minute, I may Wireshark the stream to see exactly how Infuse is communicating differently than the other players.
    Last edited by vguitarist; 01-29-2022 at 10:58 AM.

  4. #4
    Join Date
    Jun 2012
    Posts
    720

    Default

    Quote Originally Posted by vguitarist View Post
    Here's what Firecore said (developer of Infuse): "During scanning, Infuse will read details from the video files in order to display things like duration and codec info. It looks like your server is treating these as plays.". While this is true, I don't buy their conclusion...but it is all I have.

    Similiar to jblinkley60's thought, a new setting in Mezzmo to pause the play clock until some portion of the movie plays -- say, 3 seconds (user defined) -- would fix my issue. It would allow the player to connect/disconnect the media files before the stream play clock begins counting. The tradeoff would be no resume for the few seconds the clock is paused. Just a thought.

    When I get a minute, I may Wireshark the stream to see exactly how Infuse is communicating differently than the other players.
    Mezzmo will change the lastplayed time when a video is accessed like this but the play counter isn't until the setting I mentioned has been reached. I do a last 150 played playlist but I set the criteria for the playcount to be > 0. A better way for Infuse to operate is to accept the uPNP information coming from Mezzmo which contains all of the information including the metadata, codec info, duration and more. That is the way most uPNP clients operate, which avoids this issue.

    This is how the Mezzmo Kodi client works and I believe the same for the rest of the Conceiva provided clients on other platforms. I suspect Infuse is being written as a client for many uPNP sources and lesser uPNP servers don't provide all of the information via uPNP. This is the issue I am dealing with for the multi-server version of the Mezzmo Kodi addon. There are a number of other uPNP servers which are not nearly as feature rich and standards based as Mezzmo.

    I am curious how Infuse would avoid the slowness of loading when it has to access each file for a couple of seconds ? It must do it in the background.


    Jeff

  5. #5
    Join Date
    Jul 2013
    Posts
    45

    Default

    Quote Originally Posted by jbinkley60 View Post
    Mezzmo will change the lastplayed time when a video is accessed like this but the play counter isn't until the setting I mentioned has been reached. I do a last 150 played playlist but I set the criteria for the playcount to be > 0. A better way for Infuse to operate is to accept the uPNP information coming from Mezzmo which contains all of the information including the metadata, codec info, duration and more. That is the way most uPNP clients operate, which avoids this issue.

    This is how the Mezzmo Kodi client works and I believe the same for the rest of the Conceiva provided clients on other platforms. I suspect Infuse is being written as a client for many uPNP sources and lesser uPNP servers don't provide all of the information via uPNP. This is the issue I am dealing with for the multi-server version of the Mezzmo Kodi addon. There are a number of other uPNP servers which are not nearly as feature rich and standards based as Mezzmo.

    I am curious how Infuse would avoid the slowness of loading when it has to access each file for a couple of seconds ? It must do it in the background.


    Jeff
    I appreciate the continued conversation about this issue.

    The "Last 30" playlist sortby rule is set to "date Last Played (Descending) and playlist limit set to 30. Mezzmo's playcount is defaulted to 20% before incrementing, so the brief touch by Infuse when browsing a playlist does not change the playcount.

    I just watched the status window on the Mezzmo server and browsed a playlist with Infuse (iPad). Almost immediately, every video on the playlist began streaming in the status window. "Mezzmo Server Streaming file: 'FileName.xxx' to device iPad (xxx.xxx.xxx.xxx). Exactly six seconds later, the files dropped off the list. It doesn't matter what kind of video it is; home movies do the same thing when browsing a playlist.
    Last edited by vguitarist; 01-30-2022 at 10:25 AM.

  6. #6
    Join Date
    Jun 2012
    Posts
    720

    Default

    Quote Originally Posted by vguitarist View Post
    I appreciate the continued conversation about this issue.

    The "Last 30" playlist sortby rule is set to "date Last Played (Descending) and playlist limit set to 30. Mezzmo's playcount is defaulted to 20% before incrementing, so the brief touch by Infuse when browsing a playlist does not change the playcount.

    I just watched the status window on the Mezzmo server and browsed a playlist with Infuse (iPad). Almost immediately, every video on the playlist began streaming in the status window. "Mezzmo Server Streaming file: 'FileName.xxx' to device iPad (xxx.xxx.xxx.xxx). Exactly six seconds later, the files dropped off the list. It doesn't matter what kind of video it is; home movies do the same thing when browsing a playlist.
    One way to fix this is to add a parameter to the playlist where playcount is > 0 . It might give you the behavior you are looking for. At that point they will only show up on the list once you've played 20% of the file (or whatever you set it for).


    Jeff

  7. #7
    Join Date
    Jul 2013
    Posts
    45

    Default

    Unfortunately, it does not fix the issue -- although setting the number high (I now have set to 95%) does keep the play count from incrementing. Looks like I may have to abandon Infuse for another player like VLC.

Similar Threads

  1. After rebooting Apple 4K TV the Infuse Pro 5 connection is lost to the Mezzmo
    By MDensler in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 03-02-2019, 10:20 PM
  2. Active playlists not updating with new files
    By forwardt in forum Mezzmo Questions and Support
    Replies: 5
    Last Post: 11-04-2013, 05:47 PM
  3. 3.1x not updating playlists with new content
    By forwardt in forum Mezzmo Questions and Support
    Replies: 6
    Last Post: 05-20-2013, 10:24 AM
  4. Slow browsing
    By pacmon in forum Mezzmo Questions and Support
    Replies: 4
    Last Post: 03-01-2013, 11:00 AM
  5. Playlists not updating
    By Gumbyohson in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 01-04-2012, 09:03 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •