Results 1 to 9 of 9

Thread: Mezzni server crashed 0 No longer able to connect to server from any device

  1. #1
    Join Date
    Feb 2023
    Location
    London, UK
    Posts
    19

    Default Mezzni server crashed 0 No longer able to connect to server from any device

    My hard drive was on the point of failing, I imaged the drive, repaired windows 10, but...

    Mezzmo seemed unaffected, the Server shows as started, the Mezzmo manager seems to be ok however, none of my clients, Android, Samsung, etc. can even detect or connect to the Server.

    Any suggestuins on what action(s) I can take to recover from this?

  2. #2
    Join Date
    Sep 2009
    Posts
    2,696

    Default

    Please try temporarily disabling your Windows Firewall to see if the clients can detect the server. Also check the interface list in 'Media Server Settings' to see if Mezzmo is listening on the correct interface.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  3. #3
    Join Date
    Feb 2023
    Location
    London, UK
    Posts
    19

    Default

    Quote Originally Posted by Peter View Post
    Please try temporarily disabling your Windows Firewall to see if the clients can detect the server. Also check the interface list in 'Media Server Settings' to see if Mezzmo is listening on the correct interface.
    Turned off the Firewall, still no connection with Mezzmo clients, the Android app will not even allow me to ADD the server manually, and the Samsung TV's will not access the server. Strangely enough, the Server is accessible from the File Manager on my other PC's though, showing as a Network Location.

    I can also log in on all the devices using web browsers, just not the Mezzmo apps (Android/Samsung)
    Last edited by DaveyDee; 05-16-2023 at 11:34 AM.

  4. #4
    Join Date
    Sep 2009
    Posts
    2,696

    Default

    Try enabling logging in Mezzmo then after restarting your Mezzmo media server browse for servers from a device and look in the MezzmoMediaServer log for a GET request on /desc
    GET /desc

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  5. #5
    Join Date
    Feb 2023
    Location
    London, UK
    Posts
    19

    Default

    Quote Originally Posted by Peter View Post
    Try enabling logging in Mezzmo then after restarting your Mezzmo media server browse for servers from a device and look in the MezzmoMediaServer log for a GET request on /desc
    GET /desc
    GET /desc HTTP/1.1
    HOST: 192.168.0.210:53168
    ACCEPT-LANGUAGE: en-us
    Connection: Keep-Alive
    USER-AGENT: DLNADOC/1.50 SEC_HHP_[TV] Samsung 5 Series (32)/1.0 UPnP/1.0
    Content-Length: 0


    135058 - May 16 09:53:31.063 [ThreadID:18b0] - [18B0] > ---------------------------------------------------------------------
    135059 - May 16 09:53:31.063 [ThreadID:18b0] - [18B0] INFO > OnData: we have complete response packet: DeferDestruction = 0 on socket 5500 (1443)
    135060 - May 16 09:53:31.064 [ThreadID:18b0] - [18B0] INFO > GetTargetDeviceProfile: Device IP does not exist or communication time has expired

    135061 - May 16 09:53:31.064 [ThreadID:0090] - [0090] > _GetLocalMAC: found MAC address (90-2B-34-30-F4-0C) for local IP address (192.168.0.210)
    135062 - May 16 09:53:31.065 [ThreadID:0090] - [0090] > _GetLocalMAC: found MAC address (90-2B-34-30-F4-0C) for local IP address (192.168.0.210)
    135063 - May 16 09:53:31.065 [ThreadID:0090] - [0090] > 90 PostMX_MSEARCH (rcode = 0) NOT RESPONDED TO: urn:schemas-upnp-org:device:RemoteUIServerDevice:1 on socket 1536
    135064 - May 16 09:53:31.065 [ThreadID:0090] - [0090] INFO > 90 fd_counts: readset = 5, writeset = 0, errorset = 3, tv_sec = 86400, tv_usec = 0, slct = 0, v = 86400000
    135065 - May 16 09:53:31.107 [ThreadID:18b0] - [18B0] IN > 18B0 [ Generic Device (NTSC)]: HTTP-PACKET for 192.168.0.210 (/desc)
    135066 - May 16 09:53:31.108 [ThreadID:18b0] - [18B0] INFO > VerifyDevice: Device IP does not exist or communication time has expired
    135067 - May 16 09:53:31.120 [ThreadID:18b0] - [18B0] WARN > MediaServer_ProcessHTTPPacket: BLOCKED DEVICE BECAUSE OF PERMISSION SETTINGS
    135068 - May 16 09:53:31.120 [ThreadID:18b0] - [18B0] INFO > Sending bytes from 0, length=0
    135069 - May 16 09:53:31.120 [ThreadID:18b0] - [18B0] OUT > 18B0 SendTo: (send) socket 5500, length = 45, bytes sent = 45
    HTTP/1.1 403 Forbidden
    Content-Length: 0


    SERVER DETAILS:

    Ethernet adapter Ethernet:

    Connection-specific DNS Suffix . :
    IPv6 Address. . . . . . . . . . . : 2a02:c7c:6514:a100:8def:2d7c:5a72:c208
    IPv6 Address. . . . . . . . . . . : fd14:384e:747e:0:7630:4d33:53bc:f59b
    Temporary IPv6 Address. . . . . . : 2a02:c7c:6514:a100:191f:4c04:afb2:e24c
    Temporary IPv6 Address. . . . . . : fd14:384e:747e:0:191f:4c04:afb2:e24c
    Link-local IPv6 Address . . . . . : fe80::9091:d829:a8f:3e43%14
    IPv4 Address. . . . . . . . . . . : 192.168.0.210
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : fe80::3e45:7aff:fede:22f9%14
    192.168.0.1

  6. #6
    Join Date
    Jun 2012
    Posts
    1,046

    Default

    Do you have your Mezzmo server set to allow the device to connectt ? And to allow new devices to connect ?


    Jeff
    Last edited by jbinkley60; 05-16-2023 at 10:04 PM.

  7. #7
    Join Date
    Feb 2023
    Location
    London, UK
    Posts
    19

    Default

    Yes, all settings to allow, but in the log I am now seeing some strange (to me) items, a lot of sem_destroy items, and entries from HOST:239.255.255.250:1900 that just make no sense...

    The service ffmpeg.exe is currently running at 86.9% CPU, and 30.1MB/s Disk within Mezzmo (32 bit) according to Task Manager

    Also getting log items like there:

    (sample):

    50528 - May 16 14:45:48.932 [ThreadID:084c] - [084C] > ---------------------------------------------------------------------
    50529 - May 16 14:45:48.932 [ThreadID:084c] - [084C] OUT > 84C SendTo: (sendto) socket 3468, length = 236, bytes sent = 236
    NOTIFY * HTTP/1.1
    HOST: 239.255.255.250:1900
    NTS: ssdp:byebye
    USN: uuid:463ce794-9c92-4eda-bc3c-3c1f5041bddb::urn:schemas-upnp-org:service:ContentDirectory:1
    NT: urn:schemas-upnp-org:service:ContentDirectory:1
    Content-Length: 0


    50530 - May 16 14:45:48.932 [ThreadID:084c] - [084C] > ---------------------------------------------------------------------
    50531 - May 16 14:45:48.932 [ThreadID:084c] - [084C] OUT > 84C SendTo: (sendto) socket 3468, length = 252, bytes sent = 252
    NOTIFY * HTTP/1.1
    HOST: 239.255.255.250:1900
    NTS: ssdp:byebye
    USN: uuid:463ce794-9c92-4eda-bc3c-3c1f5041bddb::urn:microsoft.com:service:X_MS_Media ReceiverRegistrar:1
    NT: urn:microsoft.com:service:X_MS_MediaReceiverRegist rar:1
    Content-Length: 0


    50532 - May 16 14:45:48.932 [ThreadID:084c] - [084C] > ---------------------------------------------------------------------
    50533 - May 16 14:45:48.932 [ThreadID:084c] - [084C] SOCK > 84C shutdown socket 3468 (AsyncSocket_Destroy)
    50534 - May 16 14:45:48.932 [ThreadID:084c] - [084C] SOCK > 84C closed socket 3468 (AsyncSocket_Destroy)
    50535 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50536 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50537 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50538 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50539 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50540 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50541 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50542 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50543 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50544 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50545 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50546 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50547 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50548 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50549 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50550 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50551 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50552 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50553 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50554 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50555 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50556 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50557 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50558 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50559 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)
    50560 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy (185)
    50561 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: sem_destroy done(187)
    50562 - May 16 14:45:48.933 [ThreadID:084c] - [084C] INFO > Destroy: PendingSend_Head: 0 (170)......
    Last edited by DaveyDee; 05-17-2023 at 01:46 AM.

  8. #8
    Join Date
    Sep 2009
    Posts
    2,696

    Default

    It could be that the device is in the Media Devices list but in the properties the box to allow the device to connect is not checked.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  9. #9
    Join Date
    Feb 2023
    Location
    London, UK
    Posts
    19

    Default

    I did check that, and also the Allow all new devices to connect to Mezzmo was ticked.

    I think Ihave finally tracked dwon the problem, to a certain extent, I can now connect devices to the server, however, either the client or server (not sure which) will allow me to play one movie/episode, when that finishes, the client freezes out, and when I back all the way out, I have lost the connection to the server again... It is really strange.

Similar Threads

  1. Mistakenly deleted a media device from my server
    By Nwc46 in forum Mezzmo Questions and Support
    Replies: 2
    Last Post: 04-20-2020, 09:01 AM
  2. Mezzmo Server No Longer Visible In Server List
    By some_evil in forum Mezzmo Questions and Support
    Replies: 2
    Last Post: 05-17-2018, 12:45 PM
  3. Pc based program to connect to the server
    By stewart in forum Mezzmo Wish List and Feedback
    Replies: 7
    Last Post: 12-19-2016, 12:17 PM
  4. Media Device Seen On Mezzmo Server But Not Detected On TV
    By simplyMe in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 11-19-2016, 09:43 PM
  5. Device cannot find server after upgrading to 3.0
    By bsantelli in forum Mezzmo Questions and Support
    Replies: 2
    Last Post: 02-05-2013, 11:30 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •