Results 1 to 6 of 6

Thread: Compatibility issue with files encoded in Handbrake 0.9.5?

  1. #1

    Default Compatibility issue with files encoded in Handbrake 0.9.5?


    I have a Sony BDP-S570 and until recently I have been encoding video files using Handbrake 0.9.4 (using the H.264 (x264) codec).

    These files do not play natively on the Sony so when I play them, Mezzmo transcodes them, which is fine.

    I have just installed the latest version of Handbrake (0.9.5) and I am encoding files in the exact same way, but now I get the message 'File is corrupt or not supported' when trying to play them on the Sony. The files still play fine in iTunes/QuickTime, and a transcoded file is also still created by Mezzmo.

    I have downgraded back to the previous version of Handbrake for now, but as this program is widely used I thought I would mention it here in case the issue resides with Mezzmo (and therefore perhaps could be fixed?).

    I have attached the diagnostic log files that result from playing a file encoded with both old and new versions of Handbrake if it helps; can provide source files (and transcoded equivalents) if required also.


    EDIT: I tried encoding a file using MPEG-4(ffmpeg) in v0.9.5 and this worked fine, so the issue only seems to be with the H.264(x264) codec.
    Attached Files Attached Files
    Last edited by captainham; 01-22-2011 at 08:04 AM. Reason: Additional info

  2. #2
    Join Date
    Jun 2010


    Well looking at your transcoding logs. I can see you added subtitles in the 0.9.5 file. Maybe it doesn't like them. Try burning those into the video instead of a separate stream.

  3. #3


    Tried again, this time with no subtitles - same result unfortunately. Logs attached.

    For info, the default option I use in Hanbrake (in both old and new versions) is burned in only, as opposed to separate stream.

    Log files - HB0.9.5 no

  4. #4
    Join Date
    Nov 2007
    Melbourne, Australia


    Mezzmo is remuxing that file, not really transcoding, so the video stream is untouched. It's possible that HB 0.9.5 encoding is broken. To dig deeper into this, it would be great if we could have one of the original files here - then I could test it with current FFmpeg and also the previous one and also an up-to-date build and see if it's our FFmpeg or the one used by HB.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at
    Wiki: User Guides & Reference Manual at

  5. #5


    Hi Dennis,

    Have sent a mail to your support address with a link to download the original file.

    Thanks for your help.


  6. #6


    For the benefit of anyone else finding this thread, the issue is not with Mezzmo or with Handbrake...this thread here explains here:

    Haven't tested it yet, but just about to!

    Thanks to the Conceiva guys for looking into the issue in the first place though, gold star for your efforts

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts