Results 1 to 6 of 6

Thread: Close, restore, minimize icons disappear sometimes

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    May 2009
    Posts
    18

    Default Close, restore, minimize icons disappear sometimes

    I have a dual wide screen system and currently use Download Stuido 5.1.3.0. Sometimes the icons in the right upper corner (close, restore, minimize) disappear when the window is maximized (see attached screenshot). They reappear when I double click on the top bar (equivalent of restore command), and then maximize again. I hope you will be able to reproduce and fix the problem.

    It is funny, I submitted the post and noticed your closing X for viewing the submitted pictures is right in the middle of the problem area. Can you change your viewer (add a margin on top or move the X icon) so that your closing X icon is outside the picture area.
    Attached Images Attached Images
    Last edited by aloha; 05-06-2009 at 02:12 AM.

  2. #2
    Join Date
    Jan 2008
    Location
    Melbourne, Australia
    Posts
    251

    Default

    I have been unable to reproduce this. I have tried various dual screen resolutions and settings but have not seen what you have described. Can you tell me what resolutions your monitors are running at?

    One thing to note is the 'DownloadStudio' text in the application title bar is always centered, looking at the image you submitted the text is too far to the right which indicates that the window is bigger than seen in the image you submitted. Is it possible when you 'restored' the window from its maximized state it was just off the edge of the monitor? Can you confirm that this snapshot was taken when the window was maximized? Are you still seeing this issue?

    I see what you mean with the 'X' overlaying the image in our forum image viewer. We are using a common third party forum tool and it is their design so we don't have control over this.
    Conceiva. Download it with DownloadStudio. Stream it with Mezzmo.

  3. #3
    Join Date
    May 2009
    Posts
    18

    Default

    I can see now the window is clipped on the right and bottom as well.

    My left monitor is big screen TV with resolution 1744x972. My right and main window is LCD monitor with resolution of 1440x900.

    The window was maximized, but my guess is this window got wrong screen size information at some point. The maximized window "thinks" it is in 1744x972 screen but in fact is in 1440x900 screen thus producing some clipping.

    I've found a way to reproduce the bug: a) maximize the window, b) minimize to send it to the taskbar or system tray, c) double click to "maximize" again - bang! The problem (clipping) appears. Double click on the top of the window to restore - the window restores. Double click again - the window maximizes to correct size, no clipping, all bars and icons can be seen. Now if you go to steps b and c you will see the problem again.

    Aloha.
    Last edited by aloha; 05-07-2009 at 03:44 PM.

  4. #4
    Join Date
    Jan 2008
    Location
    Melbourne, Australia
    Posts
    251

    Default

    Thanks for the steps, we have reproduced the issue here and will have a fix in the next update.
    Conceiva. Download it with DownloadStudio. Stream it with Mezzmo.

  5. #5
    Join Date
    May 2009
    Posts
    18

    Default

    I am at v5.1.5.0, the problem is still there. Is it in your "to do" list?

  6. #6
    Join Date
    Jan 2008
    Location
    Melbourne, Australia
    Posts
    251

    Default

    Yes, it is still on our todo list. Sorry about the delay, our developers have not got to it just yet, but hope to have it fixed for the next update.
    Conceiva. Download it with DownloadStudio. Stream it with Mezzmo.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •