Results 1 to 3 of 3

Thread: Mezzmo doesn't work with multicast routing (PIM)

  1. #1

    Default Mezzmo doesn't work with multicast routing (PIM)

    I run a cisco 877 router for DSL/wireless/connection to internal switch/LAN.
    my TV(samsung PS50C6500) connects via wireless
    DLNA server is wired on LAN

    traditionally i had my wireless and LAN running in a bridged mode. this means that they are both on the same Layer 2 segment, But with ever increasing bit rates i ran into a problem. running in bridge mode causes all packets to be "process" switched, instead of using "CEF" (cisco express forwarding) what this means is that my router starts to run out of CPU at the 10Mbit throughput range and causes movies to stutter.

    to get around this i have changed the configuration so my wireless and my Lan are separate layer 3 segments (which puts it back in CEF mode). DLNA uses multicast, so to get DLNA traffic between my DLNA server and my TV i had to enable multicast routing (PIM). this works fine. the TV can see and connect to mezzmo.

    what happens is that the device doesn't appear in the device list so i cant select a profile, it appears to default to (generic) NTSC and it tries to transcode almost everything instead of playing natively, if i force trans-coding off for all devices it will force stream it and play natively. but i am missing all the buttons (pause, ff, rw , chaptering)

    the log has this error everytime mezzmo talks to the TV
    787 - Sep 30 21:29:43.031 -      > ---------------------------------------------------------------------
     788 - Sep 30 21:29:43.031 - INFO > OnData: we have complete response packet: DeferDestruction = 0 on socket 4564 (1409)
     789 - Sep 30 21:29:43.031 - IN   >  960 [         Generic Device (NTSC)]: HTTP-PACKET for (/SmallIcon.png)
     790 - Sep 30 21:29:43.031 - ERROR> failed to retrieve MAC address with error 31 (destIP:, srcIP:
     791 - Sep 30 21:29:43.031 - OUT  >  960 SendTo: (send) socket 4564, length = 103, bytes sent = 103

    I have a very nasty plan and might work and that is to NAT the address to a 172.19.2.X address and give my router in the range 172.19.2.X the same mac address as the TV(i dont know if i have to do this, will try first without). but obviously this isn't a very nice solution!!!!

  2. #2



    2.4.4 fixes this problem via "use only ip addresses"

  3. #3
    Join Date
    Nov 2007
    Melbourne, Australia


    I'm glad you found that in 2.4.4 and thanks for letting us know!

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at
    Wiki: User Guides & Reference Manual at

Similar Threads

  1. Stream IPTV multicast UDP
    By nttranbao in forum Mezzmo Questions and Support
    Replies: 6
    Last Post: 10-18-2012, 03:18 AM
  2. MTS files don't work for me
    By Gargo in forum Mezzmo Questions and Support
    Replies: 9
    Last Post: 08-03-2011, 04:52 PM
  3. MP4 Doesn't work on 2.2.0
    By bryanradtke in forum Mezzmo Questions and Support
    Replies: 2
    Last Post: 03-07-2011, 03:40 PM
  4. Will Mezzmo work for me?
    By rbn1 in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 01-01-2011, 09:42 AM
  5. Does Mezzmo work with philips streamium products?
    By Emjay in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 11-30-2010, 09:32 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts