Results 1 to 2 of 2

Thread: experience with .wtv files & 802.11n connections

  1. #1
    Join Date
    Nov 2011

    Question experience with .wtv files & 802.11n connections


    I installed Mezzmo yesterday and am in my trial period. I've tried ~5 DLNA servers and Mezzmo looks to be a very nice package- and I like the pricing structure (one competitor package charges by the client and another charges if you go over a certain amount of video GB storage- egad, how crazy!) The free servers don't seem to work well at all for me. I like the polish and the pricing of Mezzmo, so I'm very interested in getting it working.

    I may have a couple of issues going, but I don't know what others are experiencing. I'm in the US, I just got a Ceton Infini USB cablecard tuner for my dedicated Windows Media Center HTPC (Core i3-2100T CPU, 4 GB RAM, integrated Intel 2000 graphics.) I am hoping to serve video recorded from my cable company to other devices via DLNA. I have a Western Digital Live Hub, a Samsung TV, a LG Blu Ray Player and a HP TouchPad. The other kicker is that at the moment, everything is only on a wireless 802.11n network. I'm renting a house while I'm having a new house built. I'm not going to try to wire the rental with ethernet (have young kids that take 98% of my time!) but my new house will be wired. So perhaps I should put this off until I'm in the new house.

    Anyway, playing .wtv files to the WD Live Hub and and the Samsung is very slow to start, and pauses for ~5 seconds every ~8 seconds or so. I can play ripped Blu-ray files (to some sort of .mkv) okay- just a few video glitches every now and then. But the .wtv files are unwatchable. My question- is this something that should be doable, if I decrease the quality settings? I have tried decreasing the bandwidth (I've selected 802.11n, 802.11g/a and the HomePlug 85, but those didn't help.) I've also slid down the "Video bitrate" setting and that didn't help. I can't get the LG Blu Ray player or TouchPad to work at all.

    Is there an issue with .wtv files and ffmpeg? I've found these two posts elsewhere on the web:


    After doing a bit of reaearch it appears that the open source transcoder that Serviio & Mezzmo use (ffmpeg) has a problem with the file structure of WTV files. Apparently WTV structures it's container strangely which confuses ffmpeg so that it can't determine the size and length of the file. That is why some smaller WTV files will play correctly (<600mb I believe) whereas the vast majority do not.

    The last line of the ffmpeg output tells the tail. I had this one every single h.264 .wtv file. This is a known FFMPEG issue and there are a couple of patches out there but if you go to your ffmpeg source directory and edit libavformat/utils.c around lines 3171 and 3176 (the current git source as of 2011-10-15) and comment out the two lines in that range that say "return AVERROR(EINVAL);" all will be fine. In other words change those lines to read:
    /* return AVERROR(EINVAL); */
    instead. IIRC this bug generally only appears with .wtv files containing h.264 encoded video. By do the above I can transcode all the .wtv files (all h.264) pefectly every time

    I'm a software engineer, I assume ffmpeg uses gcc and perhaps I will dive in and try to make this change (I'm a .Net dev with Visual Studio (flame away), have a little knowlege of using gcc on linux, but not gcc on Windows...) Because of my kids I don't have much time for this stuff...

    Also, I see in other posts that the HP TouchPad is supported. But when I try to play any file (ripped blu-ray, ripped DVD or a .wtv file), I get the "Video format not supported". I do have the "HP TouchPad" Device Profile selected. I'm not sure what I'm doing wrong there. I'm using the BHome video player.

    So, it seems like support for .wtv files needs a little help, and perhaps I need to wait until I can get to my fully wired network. But, I've got this application called "Remote Potato" working fine on my HTPC that serves the .wtv files flawlessly to laptops via it's web interface and to Apple i products via the Remote Potato app. Plus, my WD Live Hub & LG Blu Ray player play HD content back from Netflix fine. So it seems like with the correct transcoding, the bandwidth should be available to do this on my 802.11n network.

    This needs to work with non pre-cached transcoded video (I've got 10 hours/day of video being generated (and auto deleted) every day (mostly from my wife's talk shows.)) I've noticed that the CPU is @ 65% utilization when ffmpeg is transcoding one of these HD .wtv files.

    I've enabled and took a quick look at the logs, but there's a ton of data and I don't know what to look for. They're huge- if anyone wants me to paste a section into this thread, please let me know.

    I'm really excited at the possibility to "zing" around my recorded TV content via DLNA. If anyone has any suggestions, please let me know!
    Last edited by LrngToFly; 11-05-2011 at 09:19 PM.

  2. #2
    Join Date
    Nov 2007
    Melbourne, Australia


    Logs would be a great place to start, so please zip them up and send in to support.

    We build new FFmpeg versions almost every week to test older issues and also see new changes, so possibly the WTV issue is already fixed or is at least working better now. If you send the logs in, we'll take a look and possibly send you the latest FFmpeg build to test (provided it's the culprit).

    It could also be related to slow transcoding speed - transcoding high-def video is best done using at least 4-5 cores (an i7, for example), so this may be an issue as well. If you have background transcoding turned on and then try to play this file later, does it play smoothly?

    We can also look at the HP TouchPad issue via e-mail.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at
    Wiki: User Guides & Reference Manual at

Similar Threads

  1. command line xml tag for number of connections?
    By hhwh in forum DownloadStudio Questions and Support
    Replies: 3
    Last Post: 03-16-2011, 08:17 AM
  2. Sony BDP-S370- DivX/XviD avi files stutter, MKV files work great
    By zelfred in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 02-04-2011, 03:22 PM
  3. Rapidshare Connections
    By quigong in forum DownloadStudio Questions and Support
    Replies: 35
    Last Post: 08-24-2010, 02:35 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts