Results 1 to 4 of 4

Thread: Playlists and WD TV Live

  1. #1

    Default Playlists and WD TV Live

    I have a major problem here and I cant see why it doesnt work. I am not trying to do anything complicated, so I must be missing something somewhere. Heres the scenario

    I have Mezzmo installed on a 2008 Standard server. I then add folders to Mezzmo. These folders are actually drive letters of drives that are mapped to shares on other servers

    So, I add a folder, give it a name of Movies and the location of o:\

    If I look in Mezzmo GUI, I can see all the video files in that folder playlist. If I look in All Video Files, I can see the same files. So far so good.
    If I fire up my WD TV Live, I can see the folder structure as expected. If I look in the All Video Files playlist, everything is there. If I look in the newly created Movies playlist, it tells me there is no content

    I create another folder playlist. For example, I add TV Series on drive t:
    As above, I can see the newly added files appear in All Video Files and the TV Series playlists in Mezzmo GUI. On WDTV, the All Video files playlist is correct, the TV Series playlist returns "no content"

    I also have a folder playlist that I DO NOT want sub-folders adding to the library. (NO, not my porn collection! A load of VIDEO_TS folders that dont add to library properly!)
    So I un-tick the box that says "include sub-folders". If I look in that folder playlist, everything is as expected. If I look in the "All Video Files" playlist, all the VTS files are there! WTF?

    Also, I find that sometimes, running a "Maintain Library" results in a small proportion of files being duplicated in the All Video Files playlist. The extra ones seem to have an extra "\" in the path (Although if I select them in WD TV, they still play)!

    Any ideas? I really cant believe it should be this difficult. I have been using MediaPortal for several years on my main livingroom PC, so am well used to the concepts behind what I want to achieve. I thought throwing a WDTV box and a DLNA server into a well established and tagged media folder structure should be easy, but it appears not!

  2. #2
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,646

    Default

    Quote Originally Posted by tmacca View Post
    If I look in Mezzmo GUI, I can see all the video files in that folder playlist. If I look in All Video Files, I can see the same files. So far so good.
    If I fire up my WD TV Live, I can see the folder structure as expected. If I look in the All Video Files playlist, everything is there. If I look in the newly created Movies playlist, it tells me there is no content
    This sounds like a permissions issue - the server has less permissions than the app and perhaps cannot access those mapped folders. Can you please check that the shared folders are accessible by "everyone" or at least the same user as you registered the server under.

    I also have a folder playlist that I DO NOT want sub-folders adding to the library. (NO, not my porn collection! A load of VIDEO_TS folders that dont add to library properly!)
    So I un-tick the box that says "include sub-folders". If I look in that folder playlist, everything is as expected. If I look in the "All Video Files" playlist, all the VTS files are there! WTF?
    Is it possible that those files were added previously from either scanning a drive or if you added a folder and didn't un-tick that box? If they have been added previously, they'll remain in the library until you delete them from the library. Try going to the "All Videos" and then delete those files from there. After that run maintenance and see if they come back or not.

    Also, I find that sometimes, running a "Maintain Library" results in a small proportion of files being duplicated in the All Video Files playlist. The extra ones seem to have an extra "\" in the path (Although if I select them in WD TV, they still play)!
    Strange, haven't experienced that before. Is the "\" before or after the path? Is it a UNC path?

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  3. #3

    Default

    OK, heres what I have found so far

    All of my media files are located on DFS (Distributed File System) shares across several Server 2008 servers that are members of a Server 2008 R2 domain.
    I have several drive letters mapped to these shares. I add these drive letters to Mezzmo as folders. Although I can see the media files in these folders in the Mezzmo GUI, I cannot see them in any DLNA client. I have tried several, including: Playstation3, WDTV Live, Windows Media Player, MediaConnect (on an iPhone 4s).
    This is because Mezzmo CANNOT properly see/understand/resolve the underlying UNC path for a DFS share.

    If I map a new drive directly to the server share itself (eg \\servername\d$\foldername) and add this to Mezzmo, everything works fine. However, if a drive is mapped to the DFS share (eg \\domainname\DFS\foldername) then Mezzmo fails to populate the playlists when passing them to a DLNA client. Dont ask me why, when the DFS playlists can be seen in the Mezzmo GUI, but this is the behaviour I am seeing

    Not really a problem, I have just created a few new drive mappings specifically for Mezzmo that map to the server share rather than the DFS share (I have also tested adding folders using UNC paths instead of drive mappings and this also works, so may use this instead of mappings at some point)

    As to why I am seeing duplicate entries in the media library database? I think what happens is that Mezzmo scans the playlists, then scans the local drives of the server it is installed on, and thinks that the DFS drive mapping, and the local drive, are two different sources (even though they may be the same thing, depending on which server any given DFS share is resolved to at any given time) and adds it twice. I think the extra "\" is a result of Mezzmo getting confused when adding the media - maybe because it doesnt quite understand\handle DFS properly

    Anyway, long story short, I think i have cracked it now. If anybody wants more info/assistance (including Mezzmo Development Team) I am happy and willing to answer any questions etc you may have

  4. #4
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,646

    Default

    Thanks for sharing that information. We'll test adding files from DFS here and fix things if they need fixing. I agree, the extra "\" could be the result of bad parsing or something like that and yes, it would cause Mezzmo to think the file doesn't exist in the database.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

Similar Threads

  1. Playlists/Auto Playlists with Rights/Permissions needed
    By Pattasatto in forum Mezzmo Wish List and Feedback
    Replies: 6
    Last Post: 04-12-2012, 08:33 AM
  2. WD My Book Live
    By asmith5714 in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 11-28-2011, 09:05 AM
  3. Is there a WD TV Live Hub 1TB Profile?
    By ithulnaga in forum Mezzmo Questions and Support
    Replies: 9
    Last Post: 03-29-2011, 01:17 PM
  4. WD TV Live and AVI files
    By rkneeshaw in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 01-24-2011, 12:54 PM
  5. WD TV Live not working with 2.1.9
    By techpatriot in forum Mezzmo Questions and Support
    Replies: 4
    Last Post: 08-27-2010, 12:08 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •