Page 1 of 6 123 ... LastLast
Results 1 to 10 of 59

Thread: I need to change from full hd to 720x406 in transcoding.

  1. #1
    Join Date
    Jun 2010
    Posts
    45

    Default I need to change from full hd to 720x406 in transcoding.

    Hi. Yesterday i made a post but now i canīt find it.

    Just to say that i am having problems in playing videos in full hd in my sony blu-ray player and my Netgear EV2000. I think with my network i canīt have full hd stream so i need the maximum size of 720x406 so that the video and audio doesnīt chops. The problem is that mezzmo isnīt transcoding for that sized that i stated in the Performance tab in media devices and also for the minum bit rate that iīve chosen also. For some reason the transcoder doesnīt transcode for the maximum video size but to: 1280x720. How can i change that? Where can i change manually the ffmpeg options like size, fps and bitrate? Do you have to run ffmpeg.exe from the command line? Is there any file i can change that? It was more practical to change the ffmpeg options for all videos in Mezzmo, than having to convert every file from a gui for example, each time you want to add a file. In my log (in the file MezzmoMediaServiceTranscoder.txt) you can see:

    1 - Jun 28 09:03:50.814 - TRANS> Input file: C:\Users\Carlos Alves\Pictures\2009-10-10\285.mov

    2 - Jun 28 09:03:50.815 - > Transcoder: Executing: C:\Program Files (x86)\DLNA\Mezzmo\ffmpeg.exe -i "C:\Users\CARLOS~1\Pictures\2009-1~1\285.mov" -y -vcodec mpeg2video -sameq -copyts -g 18 -r 29.97 -s 1280x720 -acodec ac3 -ac 2 -ab 448000 -ar 48000 -sn -f dvd -threads 2 -copyinkf "C:\Users\Carlos Alves\AppData\Local\Conceiva\Mezzmo\TranscodingFil es\55C881B4-1FB6-4027-8C77-73CDE5369B91\Video\4738-mpeg_ntsc-mpeg2video-ac3.mzt"

    3 - Jun 28 09:03:50.815 - > Ffmpeg --------------------------------------------------------------------

    4 - Jun 28 09:03:51.929 - FFmpeg version SVN-r23607, Copyright (c) 2000-2010 the FFmpeg developers

    built on Jun 15 2010 04:09:35 with gcc 4.4.2

    configuration: --target-os=mingw32 --enable-runtime-cpudetect --enable-avisynth --enable-gpl --enable-version3 --enable-bzlib --enable-libgsm --enable-libfaad --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libmp3lame --enable-libopenjpeg --enable-libxvid --enable-libschroedinger --enable-libx264 --extra-libs='-lx264 -lpthread' --enable-libopencore_amrwb --enable-libopencore_amrnb --enable-librtmp --extra-libs='-lrtmp -lpolarssl -lws2_32 -lwinmm' --arch=x86 --cross-prefix=i686-mingw32- --cc='ccache i686-mingw32-gcc' --enable-memalign-hack

    libavutil 50.19. 0 / 50.19. 0

    libavcodec 52.76. 0 / 52.76. 0

    libavformat 52.68. 0 / 52.68. 0

    libavdevice 52. 2. 0 / 52. 2. 0

    libavfilter 1.20. 0 / 1.20. 0

    libswscale 0.11. 0 / 0.11. 0



    Seems stream 0 codec frame rate differs from container frame rate: 6000.00 (6000/1) -> 30.00 (30/1)

    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'C:\Users\CARLOS~1\Pictures\2009-1~1\285.mov':

    Metadata:

    major_brand : qt

    minor_version : 537331968

    compatible_brands: qt CAEP

    Duration: 00:00:29.63, start: 0.000000, bitrate: 25906 kb/s

    Stream #0.0(eng): Video: h264, yuvj420p, 1280x720, 25198 kb/s, 30 fps, 30 tbr, 3k tbn, 6k tbc

    Stream #0.1(eng): Audio: pcm_s16le, 44100 Hz, 1 channels, s16, 705 kb/s

    [ffmpeg_output @ 01548a40]auto-inserting filter 'auto-inserted scaler 0' between the filter 'src' and the filter 'out'

    [scale @ 01549310]w:1280 h:720 fmt:yuvj420p -> w:1280 h:720 fmt:yuv420p flags:0x4

    [ac3 @ 02610ab0]No channel layout specified. The encoder will guess the layout, but it might be incorrect.

    Output #0, dvd, to 'C:\Users\Carlos Alves\AppData\Local\Conceiva\Mezzmo\TranscodingFil es\55C881B4-1FB6-4027-8C77-73CDE5369B91\Video\4738-mpeg_ntsc-mpeg2video-ac3.mzt':

    Metadata:

    encoder : Lavf52.68.0

    Stream #0.0(eng): Video: mpeg2video, yuv420p, 1280x720, q=2-31, 200 kb/s, 90k tbn, 29.97 tbc

    Stream #0.1(eng): Audio: ac3, 48000 Hz, stereo, s16, 448 kb/s

    Stream mapping:

    Stream #0.0 -> #0.0

    Stream #0.1 -> #0.1

    Press [q] to stop encoding

    [dvd @ 01dee8d0]buffer underflow i=0 bufi=234036 size=235740

    [dvd @ 01dee8d0]packet too large, ignoring buffer limits to mux it

    [dvd @ 01dee8d0]buffer underflow i=0 bufi=234036 size=235740

    frame= 11 fps= 0 q=0.0 size= 1586kB time=0.33 bitrate=38938.6kbits/s
    Last message repeated 1 times

    [dvd @ 01dee8d0]packet too large, ignoring buffer limits to mux it

    [dvd @ 01dee8d0]buffer underflow i=0 bufi=234036 size=235740

    [dvd @ 01dee8d0]buffer underflow i=0 bufi=235094 size=264436

    The [dvd @ 01dee8d0] message appears much more, but i think it would occupy much space in the post.

    I tried also to change video size in the Sony Bravia KDL profile (wich is the closest to mine) for the Blu-ray and it stills converts to full hd, in the .prf file. Even if i delete the allready transcoded files with *.mzt extension.

    What can i do?

    I have Vista 64 bit and the last version of Mezzmo.

    Can you pleae Help?

    Thank you.

    Comancheace

  2. #2
    Join Date
    Jun 2010
    Posts
    45

    Default Just an update

    One more thing. I switched my Sony Blu-ray profile to Netgear digital Entertainer Live, put wireless B connection - (11 Mbps) (I have a wired connection 100 Mps through a Netgear router, but i put this because itīs the only way it streams video content without loosing speed. Is it normal? Canīt you watch Full Hd movies in a wired connection?) and max video size to 720x406 and now works. Now i watch movies in 720x406 pretty nicely in my Blu-ray. The problem now is that i canīt watch m2ts movies without transcoding, thing i could do with the sony Bravia KDL profile. Do you now how to change profile settings to accept m2ts files? Or do you know a better profile for my Blu-ray?

    The only strange thing is that with the sony bravia kdl profile i watch m2ts files very nicely, and they are much larger than transcoded ones. Why do they run faster then the transcoded one?

    Thanks you.

    Very Nice program. I am verty insteresting in buy it. If i can make it work it nicely i will sure buy it.

    Best regards:

    Comancheace
    Last edited by Comancheace; 06-28-2010 at 10:09 PM.

  3. #3
    Join Date
    Mar 2010
    Posts
    146

    Default

    Hi,

    The resolution doesn't really matter for streaming performance, what is important is the bitrate at which the video was encoded. A well compressed H264 video should be easily stremed over 100 Mbits (I do so myself).

    For the maximum size, start Mezzmo. Then go into the "Media Server"->"Media Device" menu. Edit the properties of your media device, then go to the "Performance" tab. You should be able to set up max resolution, and lower bitrate. See if that can help.

  4. #4
    Join Date
    Jun 2010
    Posts
    45

    Default Another update

    I finally made it. Iīve opened NetgearDigitalEntertainerLive profile and added the following code:

    <avcontainer id="mpegts" name="mpegts" encode="0" mimetype="video/vnd.dlna.mpeg-tts" dlnaprofile="MPEG_TS_SD_EU" supportschunked="0">
    <video>
    <format id="mpeg2video" encode="0">
    </format>
    </video>
    <video>
    <format id="h264" encode="0">
    </format>
    </video>
    <audio>
    <format id="ac3" encode="0">
    </format>
    </audio>
    </avcontainer>

    Just after to </descriptiondeliveryrules>.

    This adds the support for m2ts file

    Itīs simple you just have to restart the server and it works. I donīt know if you can use notepad to add the code i think probably yes.

    Now i can watch transcoded videos in 720x46 and m2ts file in full hd.

    Just one thing:

    You have also to change the maximum video size

    <videomax width="1920" height="1080" /> when you want to watch the m2ts files.

    You first have to set max video size to the one you want to transcode. In my case 720x406. Then after you transcoded all your files you can put the max size to Full HD.

    Is ther a workaround for this? Can i assign for example max video size for transcoding: 720x406 and for playback 1920x1080? Apreciated if you could explain.

    Thank you

  5. #5
    Join Date
    Jun 2010
    Posts
    45

    Default Thanks for the reply!

    Hi RMerlin. My problem is that i want to transcode to 720x406 and playback in 1920x1080. My m2ts file are in full hd. If i put the max size 720x406 i think they donīt play, never tried it. Im gonna try that. Thanks for the tip

  6. #6
    Join Date
    Jun 2010
    Posts
    45

    Default Transcode to mt2s?

    Is it possible? Since the movies in my player run m2ts very good, can i transcode all my incopatible videos to m2ts? How can i do it?

    Thanks

  7. #7
    Join Date
    Jun 2010
    Posts
    45

    Default set up max resolution, and lower bitrate

    Tried that but the video gets very choppy and very bad audio. Any more options? Can you transcode to m2ts? In the Mezzmo home page it says it can transcode to m2ts. How do i change settings to do that?

    Thank you.

  8. #8
    Join Date
    Jun 2010
    Posts
    45

    Default File container

    "File container formats that Mezzmo can transcode to:

    Mezzmo can create the following container file formats for streaming to DLNA-enabled devices. A container file format may contain one or many audio, video or image streams within the file.

    MPEG-2 transport stream format (mpegts)"

    Does it mean i can convert almost any file to a m2ts file container and be able to play it?
    Can you describe better?

    Thank you

  9. #9
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Yes, you can convert all incompatible files to m2ts format by adding preferredtranscoded="1" to it, like this:

    Code:
    		<avcontainer id="mpegts" name="mpegts" encode="1" mimetype="video/vnd.dlna.mpeg-tts" dlnaprofile="MPEG_TS_SD_EU" supportschunked="0" preferredtranscoded="1">
    			<video>
    				<format id="mpeg2video" encode="1" preferredtranscoded="1">
    	                <copyts>1</copyts>
                        <samequality>1</samequality>
                        <framerate>25</framerate>
                        <gop>15</gop>
    	                <bitrate>25000000</bitrate>
    				</format>
    			</video>
    			<video>
    				<format id="h264" encode="0">
    				</format>
    			</video>
    			<audio>
    				<format id="ac3" encode="1" preferredtranscoded="1">
    	                <channels>2</channels>
                        <channels>6</channels>
                        <bitrate>448000</bitrate>
                        <maxbitrate>448000</maxbitrate>
    		            <minbitrate>64000</minbitrate>
                        <samplingrate>48000</samplingrate>
    				</format>
    			</audio>
    		</avcontainer>
    If you have any other questions on transcoding, please let me know and I'll help you out.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  10. #10
    Join Date
    Jun 2010
    Posts
    45

    Default preferredtranscoded="1"

    What does this mean? That this is the prefered output file type for transcoding incompatible file types or it choses the file with parameter to be included in transcoding?

    If it is the first you must chose only format right? The one you want to transcode to?

    Thanks

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •