Results 1 to 4 of 4

Thread: Some movies still don't play. I thought they were encoded on the fly?

  1. #1

    Default Some movies still don't play. I thought they were encoded on the fly?

    Hi there. I'm testing out this software for my Samsung LE37C650 and although I can now get some of the mkv files to play though the network (previously unsupported by the TV over the LAN) there are some that still won't play.

    Are there some settings somewhere to ensure that all files are re-encoded?

    It feels like I'm missing something somewhere.

    Thanks.

    [edit] one that won't play is an avi, the TV reports that the codec is unsupported although it plays fine on the PC. Others are mkv that the TV just refuses to play with no message.

    [edit] output from the avi that won't play:

    PHP Code:
    FFmpeg version SVN-r24378Copyright (c2000-2010 the FFmpeg developers
      built on Jul 21 2010 12
    :51:48 with gcc 4.4.0
      configuration
    : --enable-static --disable-shared --enable-memalign-hack --enable-libmp3lame --extra-cflags=-I/c/msys/local/include --extra-ldflags=-L/c/msys/local/lib --enable-zlib --enable-w32threads --extra-cflags=-fno-common --enable-gpl --enable-libx264 --disable-ffplay --disable-ffprobe --disable-ffserver --enable-postproc --enable-runtime-cpudetect --extra-cflags=-U__STRICT_ANSI__
      libavutil     50.22
    50.220
      libavcodec    52.84
    52.840
      libavformat   52.76
    52.760
      libavdevice   52. 2. 0 
    52. 2. 0
      libavfilter    1.25
    /  1.251
      libswscale     0.11
    /  0.110
      libpostproc   51. 2. 0 
    51. 2. 0
    [mpeg4 02cf08c0Invalid and inefficient vfw-avi packed B frames detected
    Input 
    #0, avi, from 'F:\film.avi':
      
    Metadata:
        
    ISFT            VirtualDubMod 1.5.10.2 (build 2540/release)
      
    Duration02:05:24.52start0.000000bitrate1565 kb/s
        Stream 
    #0.0: Video: mpeg4, yuv420p, 720x384 [PAR 1:1 DAR 15:8], 25 tbr, 25 tbn, 25 tbc
        
    Stream #0.1: Audio: ac3, 48000 Hz, 5.1, s16, 448 kb/s
    At least one output file must be specified 
    And one of the mkv's:

    PHP Code:
    FFmpeg version SVN-r24378Copyright (c2000-2010 the FFmpeg developers
      built on Jul 21 2010 12
    :51:48 with gcc 4.4.0
      configuration
    : --enable-static --disable-shared --enable-memalign-hack --enable-libmp3lame --extra-cflags=-I/c/msys/local/include --extra-ldflags=-L/c/msys/local/lib --enable-zlib --enable-w32threads --extra-cflags=-fno-common --enable-gpl --enable-libx264 --disable-ffplay --disable-ffprobe --disable-ffserver --enable-postproc --enable-runtime-cpudetect --extra-cflags=-U__STRICT_ANSI__
      libavutil     50.22
    50.220
      libavcodec    52.84
    52.840
      libavformat   52.76
    52.760
      libavdevice   52. 2. 0 
    52. 2. 0
      libavfilter    1.25
    /  1.251
      libswscale     0.11
    /  0.110
      libpostproc   51. 2. 0 
    51. 2. 0
    [matroska 014acb10max_analyze_duration reached
    [matroska 014acb10Estimating duration from bitratethis may be inaccurate

    Seems stream 0 codec frame rate differs from container frame rate
    47.95 (5000000/104271) -> 23.98 (24000/1001)
    Input #0, matroska, from 'L:\film.mkv':
      
    Duration01:37:26.52start0.000000bitrate640 kb/s
        Stream 
    #0.0(eng): Video: h264, yuv420p, 1280x528, PAR 1:1 DAR 80:33, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc
        
    Stream #0.1(eng): Audio: ac3, 48000 Hz, 5.1, s16, 640 kb/s
        
    Stream #0.2(eng): Subtitle: [0][0][0][0] / 0x0000
    At least one output file must be specified 
    [edit] please move to mezzmo support forum, sorry *facepalm*
    Last edited by Manny; 07-24-2010 at 10:18 PM.

  2. #2
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Hi,

    Are you using the latest Mezzmo 2.1.8?

    Both of these files are set as native for the TV, based on the "Samsung C" device profile, but it's possible that the TV itself is just refusing to play them. We can force encoding them of course - please send a message to support (at) conceiva (dot) com and I'll send you a device profile to try that will force transcoding on these videos. Or, if you prefer to tinker with the device profile yourself, I can post instructions on how to do that here.

    The codecs on the TV are different from your PC, so playing a file on the PC does not mean it'll play on the TV. What's worse is that even if the file plays from a USB stick that you can plug into the TV, it again doesn't mean it'll play when served via DLNA.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  3. #3

    Default

    Thanks for the reply. I am using version 2.8.1.0. It seems that the server just needed a little time to cache some of the files I think. There's just under 1TB on my server of media. Most of it seems ok now however there are just one or two that refuse to play because 'The codec isn't supported'.

    Could you post instructions on how to force encoding of these?

    Thanks.

    Here's one which doesn't play:

    PHP Code:
    FFmpeg version SVN-r24378Copyright (c2000-2010 the FFmpeg developers
      built on Jul 21 2010 12
    :51:48 with gcc 4.4.0
      configuration
    : --enable-static --disable-shared --enable-memalign-hack --enable-libmp3lame --extra-cflags=-I/c/msys/local/include --extra-ldflags=-L/c/msys/local/lib --enable-zlib --enable-w32threads --extra-cflags=-fno-common --enable-gpl --enable-libx264 --disable-ffplay --disable-ffprobe --disable-ffserver --enable-postproc --enable-runtime-cpudetect --extra-cflags=-U__STRICT_ANSI__
      libavutil     50.22
    50.220
      libavcodec    52.84
    52.840
      libavformat   52.76
    52.760
      libavdevice   52. 2. 0 
    52. 2. 0
      libavfilter    1.25
    /  1.251
      libswscale     0.11
    /  0.110
      libpostproc   51. 2. 0 
    51. 2. 0
    [matroska 003bcb00Too many streams
    [matroska 003bcb00Estimating duration from bitratethis may be inaccurate

    Seems stream 0 codec frame rate differs from container frame rate
    47.95 (20000000/417083) -> 23.98 (24000/1001)
    Input #0, matroska, from 'Z:\Film.mkv':
      
    Metadata:
        
    title           Film
      Duration
    02:41:41.68start0.000000bitrateN/A
        Stream 
    #0.0(eng): Video: h264, yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc
        
    Stream #0.1(eng): Audio: dca, 48000 Hz, 6 channels, s16
        
    Stream #0.2(eng): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.3(eng): Subtitle: [0][0][0][0] / 0x0000
        
    Metadata:
          
    title           Foreign parts
        Stream 
    #0.4(hrv): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.5(dan): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.6(dut): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.7(fin): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.8(fre): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.9(ger): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.10(hun): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.11(ita): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.12(nor): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.13(pol): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.14(por): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.15(rum): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.16(scc): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.17(swe): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.18(tur): Subtitle: [0][0][0][0] / 0x0000
        
    Stream #0.19: Attachment: [0][0][0][0] / 0x0000
        
    Metadata:
          
    filename        arial.ttf
    At least one output file must be specified 
    Last edited by Manny; 07-31-2010 at 05:08 PM.

  4. #4
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    That file should be passed through as native, according to the device profile.

    Can you please send a message to support (at) conceiva (dot) com and I'll send you an updated device profile with a patched server to try on the Samsung?

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •