Results 1 to 9 of 9

Thread: Since latest Mezzmo update- all devices and files stutter when playing

  1. #1

    Default Since latest Mezzmo update- all devices and files stutter when playing

    Hi,

    Since the latest update I have been having an issue with all mezzmo files stuttering on every device I watch them on. I currently watch on a Sony BDP-BX57, Sony BDP-S590, and Sony SMP-N100. I usually pre-transcode files before I watch if I know they are a big file, but that doesn't seem to make a difference. However, my transcoding is also very slow now and regularly fails on larger files. FFMpeg is pushing my CPU to nearly 100% when it runs. I'm using a an i7-3770K @ 3.5Ghz-3.9Ghz and have 32GB of ram, and W8-64. I upgraded the ffmpeg to the latest 64bit version and that made no difference. The other new thing I have noticed is that suddenly, my MezzmoCache folder is empty. I have a 1.5TB drive dedicated to the Cache so that it can keep cached files (regularly watched videos) so it doesn't have to transcode them again. Yet it is empty after the update. Do the updates clear the cache?

    The rub is- everything worked flawlessly before the 3.3 update. Should I just revert backwards?

    Thanks,
    Jon

  2. #2

    Default

    Here is FFmpeg information on a large file that worked pre-transcoded before the update:

    ffmpeg version N-56060-gbcd1c20 Copyright (c) 2000-2013 the FFmpeg developers
    built on Sep 6 2013 00:49:05 with gcc 4.7.3 (GCC)
    configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
    libavutil 52. 43.100 / 52. 43.100
    libavcodec 55. 31.101 / 55. 31.101
    libavformat 55. 16.101 / 55. 16.101
    libavdevice 55. 3.100 / 55. 3.100
    libavfilter 3. 83.104 / 3. 83.104
    libswscale 2. 5.100 / 2. 5.100
    libswresample 0. 17.103 / 0. 17.103
    libpostproc 52. 3.100 / 52. 3.100
    Input #0, matroska,webm, from 'M:\Video\largetestfile.mkv':
    Metadata:
    creation_time : 2013-03-04 12:57:18
    Duration: 02:49:41.23, start: 0.000000, bitrate: 13986 kb/s
    Chapter #0.0: start 0.000000, end 531.531000
    Metadata:
    title : 00:00:00.000
    Chapter #0.1: start 531.531000, end 778.903000
    Metadata:
    title : 00:08:51.531
    Chapter #0.2: start 778.903000, end 994.619000
    Metadata:
    title : 00:12:58.903
    Chapter #0.3: start 994.619000, end 1250.666000
    Metadata:
    title : 00:16:34.619
    Chapter #0.4: start 1250.666000, end 1509.007000
    Metadata:
    title : 00:20:50.666
    Chapter #0.5: start 1509.007000, end 1994.409000
    Metadata:
    title : 00:25:09.007
    Chapter #0.6: start 1994.409000, end 2306.804000
    Metadata:
    title : 00:33:14.409
    Chapter #0.7: start 2306.804000, end 2620.368000
    Metadata:
    title : 00:38:26.804
    Chapter #0.8: start 2620.368000, end 3012.301000
    Metadata:
    title : 00:43:40.368
    Chapter #0.9: start 3012.301000, end 3316.939000
    Metadata:
    title : 00:50:12.301
    Chapter #0.10: start 3316.939000, end 3424.838000
    Metadata:
    title : 00:55:16.939
    Chapter #0.11: start 3424.838000, end 4071.985000
    Metadata:
    title : 00:57:04.838
    Chapter #0.12: start 4071.985000, end 4331.369000
    Metadata:
    title : 01:07:51.985
    Chapter #0.13: start 4331.369000, end 4563.559000
    Metadata:
    title : 01:12:11.369
    Chapter #0.14: start 4563.559000, end 4926.463000
    Metadata:
    title : 01:16:03.559
    Chapter #0.15: start 4926.463000, end 5329.991000
    Metadata:
    title : 01:22:06.463
    Chapter #0.16: start 5329.991000, end 5523.518000
    Metadata:
    title : 01:28:49.991
    Chapter #0.17: start 5523.518000, end 6033.117000
    Metadata:
    title : 01:32:03.518
    Chapter #0.18: start 6033.117000, end 6190.357000
    Metadata:
    title : 01:40:33.117
    Chapter #0.19: start 6190.357000, end 6556.473000
    Metadata:
    title : 01:43:10.357
    Chapter #0.20: start 6556.473000, end 6848.098000
    Metadata:
    title : 01:49:16.473
    Chapter #0.21: start 6848.098000, end 7021.605000
    Metadata:
    title : 01:54:08.098
    Chapter #0.22: start 7021.605000, end 7831.455000
    Metadata:
    title : 01:57:01.605
    Chapter #0.23: start 7831.455000, end 7949.532000
    Metadata:
    title : 02:10:31.455
    Chapter #0.24: start 7949.532000, end 8021.228000
    Metadata:
    title : 02:12:29.532
    Chapter #0.25: start 8021.228000, end 8282.948000
    Metadata:
    title : 02:13:41.228
    Chapter #0.26: start 8282.948000, end 8412.869000
    Metadata:
    title : 02:18:02.948
    Chapter #0.27: start 8412.869000, end 8582.622000
    Metadata:
    title : 02:20:12.869
    Chapter #0.28: start 8582.622000, end 9242.073000
    Metadata:
    title : 02:23:02.622
    Chapter #0.29: start 9242.073000, end 9571.068000
    Metadata:
    title : 02:34:02.073
    Chapter #0.30: start 9571.068000, end 10181.227000
    Metadata:
    title : 02:39:31.068
    Stream #0:0(eng): Video: h264 (High), yuv420p, 1920x1080, SAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
    Metadata:
    stereo_mode : left_right
    Stream #0:1(eng): Audio: dts (DTS), 48000 Hz, 5.1(side), fltp, 1536 kb/s (default)
    At least one output file must be specified

    <MEZZMO>: Child process ended with code: 109, ExitCode=1


    ---> DB Level Info: 41, 100
    ---> Frame rate: 23.98
    ---> Aspect ratio: 16:9

  3. #3

    Default

    I have also downloaded the latest version of Mezzmo this morning and run the repair on my installation. My transcoding is up from 11fps to 30something (it's varying)- but before it was always 44 and higher.

    Device profiles in use:

    BDP-S590 = Sony BDP (Pal/NTSC, MKV, no Divx)
    BDP-BX57 & SMP-N100 = Sony BDP (NTSC, no Divx)

    All set to gigabit connections- because it runs smooth that way. The devices are wireless (with statically assigned IP address) but when I was initially setting up Mezzmo, on wireless setting they would stutter. On gigabit- they run perfect. Server is attached to router via 2 NIC's each running Gigabit speeds with Cat6 cables (so each device shows two instances of Mezzmo-great for streaming at two locations- one on each instance). Router is an ASUS RT-AC66U. Signal strength at each device is listed at 100%.

    I am going to let the large test file finish pre-transcoding (which is going to take an hour or so) and test again and report back.

    Thanks,
    Jon

  4. #4

    Default

    Nope- still stutters within seconds of starting the video, even pre-transcoded.

  5. #5
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Hi Jon,

    It's best we see a set of logs so we can see what's going wrong. Turn on logging (see http://forum.conceiva.com/showthread...nostic-logging) and restart your Mezzmo server and exit Mezzmo application. Run Mezzmo again and try streaming your file to your device. When it starts stuttering, stop your Mezzmo server and exit Mezzmo. Zip up all the logs and email them to us at support [at] conceiva [dot] com. Also, right-click on video you streamed in Mezzmo and click Properties. On the Properties dialog, go to the Transcoding tab and select the transcoded file. Click the Get FFmpeg Information button and email us this information.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  6. #6
    Join Date
    Oct 2013
    Location
    West Cumbria, UK
    Posts
    6

    Default

    +1, same problem.
    Logs etc sent.
    cheers,

  7. #7
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Thanks - we'll analyze your logs and report back via email.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  8. #8

    Default

    The latest update has me trans coding 1080p HD files over 10GB in size at an average speed of 45-50fps with bursts over 1500fps (don't know where that came from?). Now that I have my sony devices working again, I'm playing with profiles. The trans-coding is way better, but it still stutters on large files and a lot of files I had pre-transcodes of are now *corrupt or unsupported* when they were working just fine. After re-setting up my profiles the way I had them working before, I got back the files that were corrupt or unsupported. Then, to fix the stuttering further (there was still a mild amount), I reconfigured my router to prioritize TCP ports 53168 and 2869 as well as UDP port 1900. Once I completed that, I rebooted everything, and then started streaming two large files (10GB+) to two of my sony devices. I got a little bit of stutter as the first started up, and then smooth.
    Last edited by Jon; 10-14-2013 at 02:46 AM.

  9. #9
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Thanks for this update & information, Jon. Sounds like you are up and running now after a few tweaks. If you have any further problem, let us know.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

Similar Threads

  1. latest update had done somthing funny help please
    By sohail in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 09-04-2013, 03:06 PM
  2. Video stutter on multiple devices.
    By whyzerman in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 05-10-2012, 01:17 PM
  3. Latest update broke playback on my LG TV
    By suprdave in forum Mezzmo Questions and Support
    Replies: 2
    Last Post: 03-07-2011, 05:04 PM
  4. cpu at 100% since latest update (2.1.13)
    By vitesse in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 01-27-2011, 09:46 AM
  5. problem with latest update
    By red83 in forum DownloadStudio Questions and Support
    Replies: 3
    Last Post: 11-05-2008, 11:16 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •