Results 1 to 3 of 3

Thread: FFmpeg Processes

  1. #1
    Join Date
    Jan 2013

    Question FFmpeg Processes

    With the latest version, v3.4.1.0, I am having frequent problems with high CPU usage and the media server becoming unresponsive. When I check the task manager I find that there a dozen "FFmpeg.exe" processes that are active and consuming the bulk of the CPU. (No small accomplishment for this machine.)

    I am wondering if anyone else is having this problem and/or if there is a patch to fix it.

    p.s. Capturing logs to send to support does not seem reasonable based on the period of time this happens over.

  2. #2
    Join Date
    Jul 2010
    California, USA


    You could try changing the number of threads option. You will find it in the file FFmpegAdditional.xml located in the directory C:\ProgramData\Conceiva\Mezzmo\DeviceProfiles (this is on win7 with the sw installed on C.

    WARNING! Before you change anything back up the file.
    You should see a lot of entries like: <ffmpegadditional id="union+thread0">-threads 0 -async 0</ffmpegadditional> and
    <ffmpegadditional id="h264_encoding">-threads 0 -async 0 -pix_fmt yuv420p -copyinkf -coder 1 -flags +loop -fflags +genpts -subq 7 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -b_strategy 1 -x264opts direct-pred=auto:b-pyramid=normal:mixed-refs=1:weightb=1:8x8dct=1:fast-pskip=1:crf=22:ref=2:bframes=3:aud=1:me=hex -partitions -parti8x8-parti4x4-partp8x8-partp4x4-partb8x8 -bidir_refine 1 -strict experimental</ffmpegadditional>

    You will note that in both examples threads is set to 0. That tells ffmpeg to adjust automatically to the number of cores and threads your machine has. You can reduce the usage by setting a number. If for instance you have a quad core processor with hyper-threading you could have 8 ffmpegs running. Set the number to 4 and you will use only half the cpu. BUT it could take twice as long to transcode the material. Or you could just wait for Paul to give you the best advice.

  3. #3
    Join Date
    Nov 2007
    Melbourne, Australia


    We have not had any other users reporting this, but we'd like to fix the issue you are experiencing. A set of logs is best for us to see/understand what is happening. Turn on logging (see and restart your Mezzmo server. Try to reproduce the problem by playing several videos on your device(s). Check your Windows Task Manager and when you see many ffmpeg.exe processes running & consuming CPU. Then, stop your Mezzmo server and exit Mezzmo. Zip up all your logs and email them to us at support [at] conceiva [dot] com.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at
    Wiki: User Guides & Reference Manual at

Similar Threads

  1. FFMPeg
    By ftanner in forum Mezzmo Wish List and Feedback
    Replies: 5
    Last Post: 05-27-2014, 06:45 AM
  2. FFmpeg Bottleneck
    By Crafty in forum Mezzmo Questions and Support
    Replies: 6
    Last Post: 01-14-2013, 09:01 AM
  3. Multiple FFmpeg processes with an ipod
    By Roofus in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 03-01-2012, 09:19 AM
  4. Mezzmo and Malwarebytes Blocking Outgoing Processes Marked as untrusted
    By white westie in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 02-13-2012, 09:31 AM
  5. FFMpeg Crash
    By Tony in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 11-08-2010, 09:10 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts