Results 1 to 6 of 6

Thread: Subtitles showing random characters

  1. #1
    Join Date
    Mar 2014
    Posts
    3

    Default Subtitles showing random characters

    Hi all hope you can help.

    I'm streaming from mezzmo to lg tv, transcoded mp4 with spanish subtitles and the Subtitles are showing random characters on the tv. When I play it back on vlc the subtitles are perfect.

    Any ideas or what information can I provide?

    Thanks in advance.

  2. #2
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,599

    Default

    The likely problem is the encoding for the subtitles has not been set correctly. Read this FAQ to help configure your subtitles - http://forum.conceiva.com/showthread...3138#post23138

    You can adjust the encoding (and other attributes) for a subtitle as follows: Right-click on the video in Mezzmo and click Properties. On the Properties dialog, go to the Subtitles tab. You should see all your subtitles listed there. Select one and click the Subtitles Settings button. On the Subtitles Settings dialog, set the encoding, font, etc. as you desire.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  3. #3
    Join Date
    Mar 2014
    Posts
    3

    Default

    Hi Paul,

    thanks for the speedy reply, I changed the settings and the preview on mezzmo worked perfectly, it had got rid of all the dodgy characters, but then when I went back to the tv it was blank for the subtitles (as if I had no srt files attached to the video file), I'm sure it's a simple error I've overlooked!!

  4. #4
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,599

    Default

    Press the Options/Settings button on your TV's remote control when the video is playing and see if you can see subtitle settings. You may need to turn the subtitles on using your remote control.

    If no better, right-click on the video in Mezzmo and click Properties. On the Properties dialog, go to the Transcoding tab and delete transcoded files. Try streaming the video now.

    If that does not work, then tell us: (i) what device you are streaming to, (ii) the device profile you are using (go to the Media Devices dialog to see the device profile used), (iii) post the FFmpeg information for the video (right-click on the video in Mezzmo and click 'Get FFmpeg Information') and (iv) tell us what type of subtitle file you have (SRT, ASS, etc.)

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  5. #5
    Join Date
    Mar 2014
    Posts
    3

    Default

    Hi Paul, i tried that before I forgot to mention. Now it appears all my subtitles have gone, and the option is greyed out for every file on my tv in the settings.

    the device is an LG TV - [TV][LG]32LN570R-ZA
    device profile is LGTV (2013 models)
    Subtiles - SRT
    FFmpeg -
    ffmpeg version N-50460-g393dcbf Copyright (c) 2000-2013 the FFmpeg developers
    built on Jun 27 2013 17:20:20 with gcc 4.6.2 (GCC)
    configuration: --enable-memalign-hack --arch=x86_64 --target-os=mingw32 --cross-prefix=x86_64-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/home/peter/ffmpeg/build/gpl64 --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/peter/cc64/include --extra-ldflags=-L/home/peter/cc64/lib --pkg-config=pkg-config --disable-w32threads --enable-zlib
    libavutil 52. 17.103 / 52. 17.103
    libavcodec 54. 92.100 / 54. 92.100
    libavformat 54. 63.102 / 54. 63.102
    libavdevice 54. 3.103 / 54. 3.103
    libavfilter 3. 41.100 / 3. 41.100
    libswscale 2. 2.100 / 2. 2.100
    libswresample 0. 17.102 / 0. 17.102
    Input #0, avi, from 'D:\torrents\Breaking Bad Season 2\Breaking Bad - 2x01 - Seven Thirty-Seven.avi':
    Metadata:
    encoder : transcode-1.0.2
    Duration: 00:46:09.24, start: 0.000000, bitrate: 1062 kb/s
    Stream #0:0: Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 624x352 [SAR 1:1 DAR 39:22], 23.98 tbr, 23.98 tbn, 23.98 tbc
    Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 48000 Hz, stereo, s16p, 128 kb/s
    At least one output file must be specified

    <MEZZMO>: Child process ended with code: 109, ExitCode=1


    ---> DB Level Info: 5, 15
    ---> Frame rate: 23.98
    ---> Aspect ratio: 39:22 PAR=1:1

  6. #6
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,599

    Default

    Sorry for missing your post. We'd like to see a set of logs when you steam the video to your TV. Turn on logging in Mezzmo (see http://forum.conceiva.com/showthread...nostic-logging) and restart your Mezzmo server. Connect to Mezzmo form your TV and stream the video. When no subtitles are displayed, stop your Mezzmo server and exit Mezzmo. Zip up all the logs and email them to us at support [at] conceiva [dot] com.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

Similar Threads

  1. Random Disconnects
    By paulsalter in forum Mezzmo Questions and Support
    Replies: 7
    Last Post: 11-14-2013, 04:38 PM
  2. Order Playlist -> Random
    By Capachao in forum Mezzmo Wish List and Feedback
    Replies: 2
    Last Post: 03-28-2013, 06:02 PM
  3. Replies: 14
    Last Post: 10-26-2012, 10:19 AM
  4. Problem with Polish characters in forms.
    By sunset_station in forum DownloadStudio Questions and Support
    Replies: 1
    Last Post: 02-13-2012, 09:45 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •