Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Mezzmo not transcoding on the fly

  1. #1

    Default Mezzmo not transcoding on the fly

    I have just downloaded Mezzmo and have been using it with my Toshiba 37RV753. All is well except that Mezzmo doesn't seem to be transcoding on the fly. When I first used Mezzmo it found all my video files without problem and the TV was able to find Mezzmo and all of video files. However, although the files showed their running time I was not able to open them, just a long pause and then a Media Playback Error message. When I looked at my PC I found that ffmpeg was still running and when this stopped I found that I was then able to open and view the files from the TV. It would seem that these video files can only be viewed after they have been transcoded and not on the fly. Is this to be expected or perhaps I have set something incorrectly.

    A second issue is that 1280x720 files fill the screen but 624x352 files are only half size. When I have played the same files from a USB stick (on a different TV) they have been full screen, is there some way of controlling this?

  2. #2
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    10,010

    Default

    It's possible that the transcoding speed is not fast enough for smooth playback and that's why files are not playing right away. If you turn on diagnostic logging (see this thread: http://forum.conceiva.com/showthread...nostic-logging) then try to play a file you haven't tried yet and get it to transcode, we can take a look at the log and see what speed transcoding is going at.

    Regarding the size - are there any zoom controls on the TV's remote? Sometimes zoom is set to "original size" (for example, not sure what it's called on your TV) and that could cause such display. If that doesn't help or isn't the cause, please let me know and we'll investigate this further.
    Conceiva. Download it with DownloadStudio. Stream it with Mezzmo.
    Follow us on Twitter: https://twitter.com/conceiva_mezzmo Check out our Facebook page: http://www.facebook.com/Mezzmo.DLNA.Server
    SALE! Buy Mezzmo during this year's holiday season and get a 30% discount! Offer valid until end of January! See http://www.conceiva.com/buy/specialoffers.asp
    NEW! Try our new Mezzmo Android app. Install it on your tablet or smartphone to browse and stream files from your Mezzmo library to all your devices - including Google Chromecast. Full details at http://www.mezzmo.com

  3. #3

    Default

    Thanks Dennis, I have sent a log file to your support email address. For those following this post I have reduced the bandwidth to 11Mbps and the video bit rate to the minium setting but the file fully transcodes before the TV is able to diaplay it. Also of note is that the transcoded file is twice the size of the original. On the display size issue I do have zoom but on full zoom the movie is still displayed about half screen size.

  4. #4
    Join Date
    Mar 2010
    Posts
    146

    Default

    Just out of curiosity - is your file located on an NTFS, or a FAT32 filesystem? Locally (on the PC) or externally (USB drive or NAS)?

  5. #5

    Default

    Quote Originally Posted by RMerlin View Post
    Just out of curiosity - is your file located on an NTFS, or a FAT32 filesystem? Locally (on the PC) or externally (USB drive or NAS)?
    Its a hard drive on the PC

  6. #6

    Default

    I have a similar problem. I can begin to watch the movies immediately after starting the transcoding but, usually, it'll only last for a few seconds (probably the part that has been transcoded while the rest is missing). The result is that I have to play the file way before so that when I want to watch it it'll be fully transcoded and won't stop in the middle and I can use the skip functions (which are also disabled while the file is not fully transcoded). This is a huge limitation but one that I can understand...

  7. #7
    Join Date
    Mar 2010
    Posts
    146

    Default

    The next version of Mezzmo might help you with that, as it will use an improved version of ffmpeg that will take better advantage of multicore CPUs. What CPU do you have?

  8. #8

    Default

    I have a Core 2 Duo E6750 (2 cores, 2.66GHz) and 2GB of 800MHz DDR2

  9. #9
    Join Date
    Mar 2010
    Posts
    146

    Default

    While not very recent, this CPU should still be pretty decent for transcoding. The updated version of ffmpeg will help a bit by making use of both cores. If you want to try yourself with a ffmpeg version that supports multiple cores, replace your ffmpeg.exe file (in the Mezzmo installation folder) with one taken from this website: http://ffmpeg.arrozcru.org/autobuilds/ .

    If you still can't transcode fast enough, try reducing the transcode quality. Start Mezzmo, then go to "Media Servers -> Media DEvices". Select your device, and click on "Edit", and go to the Performance tab. Try reducing the Video bitrate, and see what happens when trying a file that was not transcoded yet.

  10. #10

    Default

    Thanks for the advice. I'll try it as soon as I arrive home. Do you foresee any possible issue/configuration needed or do I simply paste the file on top of the other?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •