I have been playing with the android app and especially as it running as a server. I have a couple of questions though...

On my phone, when I start the server all works ok to start with but my other devices soon loose it and I need to reboot my phone to get it back. This might be my phone, cant tell.

When it is working I have experimented streaming to other devices and software. Streaming to your own App running on my android stick works the best (as I would expect) and it also works with eHomeMediaCenter but BubblesUPnP, MediaHouse & XBMC all on the same android stick fail. They can (when its visible) see the groups, films, metadata etc but will not play when I select a film.

I also experimented with my ipad, copied a film from iTunes that plays (therefore no compatibility probs) to my android phone, found the film on my ipad but it will not play. Tried with 8Player, XBMC, ML Player Lite & Controller but nothing would play. I expected XBMC on both devices to play because that will play anything from my main Mezzmo PC with no transcoding needed.

Also did the same with my 2009 Pani, took a film that streams without transcode from mezzmo library, dropped onto phone, TV finds the film, shows all the details including type (AVI & MPEG tried) but will not play.

If it didn't work at all I would not think the app had this functionality but it plays great on your own app and one other, I just cant work out why the other devices and apps don't work. I was hoping to load up my phone which a tone of films and stream to my some what full ipad on holiday using XBMC as that normally plays anything but as yet, cant get anything on ipad to play.

PS: Also repeated on my ipod 4th Gen same result.

Any advice welcomed.

Cheers, realise this is v1 so I am not expecting a quick fix, happy to try anything, will test with another phone next.