Results 1 to 10 of 10

Thread: Samsung and ""Preparing to play"

  1. #1

    Default Samsung and ""Preparing to play"

    I've recently begun having problems playing back HD home movies with Mezzmo on my Samsung UN46C65000 LED: the movies pause briefly while the "Preparing to play" displays. These annoying pauses occur randomly and repeatedly throughout the movies. Curiously, Samsung's own DNLA (PCShare) plays the movies flawlessly as, once, did Mezzmo (edit: that was true earlier but not now: playing the movie on PCShare resulted in a half-dozen playback delays).

    These movies are (edit: MP4s) approximately 7000 KBPS, 1920x1080. Mezzmo plays run-of-the-mill (edit: MP4) files (eg., 1500 KBPS 1280x720) without difficulty.

    Any thoughts appreciated.
    Last edited by pbelisle; 07-16-2014 at 05:55 AM.

  2. #2
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    The stuttering or "preparing to play" issue can be caused by several factors - for example, a high video bitrate of the video, the available bandwidth of your home network, and whether or not Mezzmo is transcoding the video on-the-fly. See this FAQ for a full explanation of the possible causes and how to fix the problem - http://forum.conceiva.com/showthread...reaming-videos.

    If still no success, let us know and we'll help further.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  3. #3

    Default

    Hi Paul, thanks for your quick response and the link to the troubleshooting thread. I have resolved the problem (though I don't know yet what the cause was).

    Following the link, I did the following:

    Home network...

    - using wired network, 100MBs. Actual rate appears to be 65mbps using a network measuring tool
    - no other applications/congestion
    - router reset, just in case

    Mezzmo settings
    - default settings for device (Samsung C) and appropriate connection (100mps)

    Transcoding

    - N/A file not transcoded

    Video files

    - Device can play in real time (inserted the same file via USB on the TV) so the issue was not with the Samsumg tv.

    What I did was to install Mezzmo on the ancient PC that used to be my media server and was replaced by the more recent PC. Problem disappears! Same network, same router, same cable. Clearly, there is something (process, hardware?) on the culprit machine that is interfering with the smooth delivery of the video stream. I'll do more testing and see what I can come up with and report back. If you have any thoughts on what I could look for, please let me know.

    Pierre

  4. #4
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Good troubleshooting, Pierre. If you are streaming the same video file, with the same device profile and same Mezzmo settings, and one PC streams fine but the other causes your TV to constantly buffer (i.e. 'preparing to play' message), then then the problem must be caused by some bottleneck in network bandwidth. The first place to look is your PC's settings. Check the network adaptor & check for network driver updates. Try turning off the PC's firewall and anti-virus/system protection software. Let us know how you go.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  5. #5

    Default

    Quote Originally Posted by Paul View Post
    Good troubleshooting, Pierre. If you are streaming the same video file, with the same device profile and same Mezzmo settings, and one PC streams fine but the other causes your TV to constantly buffer (i.e. 'preparing to play' message), then then the problem must be caused by some bottleneck in network bandwidth. The first place to look is your PC's settings. Check the network adaptor & check for network driver updates. Try turning off the PC's firewall and anti-virus/system protection software. Let us know how you go.
    Well, I got tired of watching the same movie over and over, so I:

    - uninstalled the anti-virus system
    - turned off the firewall
    - updated the driver on the Fast Ethernet connector
    - removed a virtual box connector that might have been in conflict.

    And, one of those worked, but I can't tell you which one, I'm afraid! The movies all play without buffering.

    Thanks for your help!

    Pierre

  6. #6
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Excellent result, Pierre! Glad you are up and running now

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  7. #7
    Join Date
    Jan 2011
    Posts
    117

    Default

    Paul,

    I ran into the 'Preparing to Play' issue with HD videos streamed to Samsung C (Mezzmo 4.0.6) also. However it seemed that the phenomenon was random. A video either played flawlessly or paused with 'Preparing to Play' every 20-30secs.

    I think I found the culprit: I found a folder under my temp directory filling with Jpegs for those videos that paused with 'Preparing to Play', Now Mezzmo didn't report anything about transcoding and - when prohibiting transcoding for my Samsung C - the videos continue to play, hence must be natively played.

    So I turned to the subtitles settings and deactivated subtitles for my Samsung C. That seems to have entirely resolved the 'Preparing to Play' issue for the HD videos.

    Any idea what goes wrong here? My temp directory - where these jpeg folders are created when subtitles are active - are on a separate disc from the .mts videos. That separate disc is a superfast SSD so should not present any bottleneck.

  8. #8
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Hi BeFi,

    It sounds like Mezzmo is burning subtitles into the video, since when you turn off subtitling for your Samsung C, then the "Preparing to Play" issue disappears. But you don't see any transcoding taking place in the Transcoding pane - so that is strange. Can you email us a set of logs when the "Preparing to Play" issue occurs? And, also email us a few of the JPG images that are in the Temp folder. That should tell us what's going wrong.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  9. #9
    Join Date
    Jan 2011
    Posts
    117

    Default

    Hi Paul,

    I can confirm that deactivating all subtitle options has completely remedied the 'Preparing to Play' issue for me. I recognized that I never observed the 'Transcoding window'. I always only observed messages appearing in the 'Status Window'. So - if a video got transcoded and that was only messaged in the Transcoding Window I would not have seen it.

    It will take a few days for me to reproduce the issues. As stated before the 'Preparing to Play' issues appeared randomly for a specific video file. The same MTS-Video once played perfectly fine and on another occasion got interrupted every 20-30 secs. I will experiment during the next weekend and send logs and jpeg files as soon as I can reproduce.

    I must admit that I don't understand the importance of subtitles in Mezzmo yet. That seems to cause a lot of complexity and I personally have never had a use case for it so far.

    I would have expected a function that even needs video streams to be remuxed 'to burn subtitles into the video stream' is inactive by default and gets activated by users who have specific requirements. In my case the function was somehow activated as default by one of the last updates without prompting - potentially by me refreshing the device profiles of my two Samsung TVs.

  10. #10
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Thanks for the testing notes, BeFi. Look forward to seeing the logs & JPGs.

    By default, streaming subtitles with your videos is turned on in Mezzmo since we think people want to see them - especially if there are subtitles associated with the video files that are added into your Mezzmo library. As you mention, streaming subtitles can be easily turned off in the Options dialog for all devices or the Device Settings dialog for individual devices. We are also adding subtitle selection into our Mezzmo Android app so that it is more convenient to turn off/on subtitles and select what subtitle to display when streaming to a device on your home network.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

Similar Threads

  1. File "Title information" being displayed rather than file "Names"
    By lonewulf in forum Mezzmo Questions and Support
    Replies: 15
    Last Post: 06-22-2014, 08:17 PM
  2. Replies: 10
    Last Post: 01-22-2014, 09:18 AM
  3. Add "Does not start with "The *"" to Smart Playlist
    By Lifferds in forum Mezzmo Wish List and Feedback
    Replies: 4
    Last Post: 06-25-2013, 09:57 AM
  4. Replies: 9
    Last Post: 12-30-2012, 12:08 PM
  5. Logitech Revue- "cannot play video" for all videos
    By philgro in forum Mezzmo Questions and Support
    Replies: 4
    Last Post: 01-06-2012, 05:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •