Results 1 to 8 of 8

Thread: Subtitles and no way to strem them

  1. #1
    Join Date
    Dec 2012
    Location
    Austria
    Posts
    20

    Default Subtitles and no way to strem them

    Dear Conceiva, hello Paul
    Since many weeks I'm struggling with movies with subtitles (normally or forced) to get them played/shown.
    I'm not able to stream subs to my renderers with mezzmo.

    Renderer one: Sony BD S590 with profile: Sony BDP, HT, SMP (2012 Models)
    Renderer two: Samsung-TV, UE55F7080ST with profile: Samsung F
    All pictures, music works fine to the players, movies too without subs.

    My Mezzmo - 4.1.3.0 on Win7, 32GB Mem, 2TB Harddisk für media content.
    Connection from mezzmo to renderers: ethernet via homeplug (600MBit ones).

    What have i done:
    I rip a dvd to vob-structure with all subtitle tracks, espacially the forced subs to get the non-german dialogs from the movies shown.
    The result is the structure with audio-ts and video-ts as known. The subs are all in the movie. I can burn this vobs to dvd and the bd-player shows them correctly. I can play the movie(s) with Power-DVD or Intervideo WinDVD, all the sub-tracks are present.
    Or I rip the movie to container-format mkv. The mkv's are played well.

    Via mezzmo, the movie (vob or mkv) is shown on my both renderes well, but no subs anyway. The ffmpeg-information in mezzmo shows NO sub-track(s). Where have they gone?

    The past weeks I've read all the how-to's in the forum, tried all the hints (pretranscode, configuring the renderer in mezzmo and so on) and tested several ways with subtitles. No chance, I don't get the subs running.
    Now I'm at the end of my tries.

    Can anyone help a knocked-out man?

    Thanks for any ideas or hints
    Wolfgang

  2. #2
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,601

    Default

    Hi Wolfgang,

    Thanks for the detailed information. Let us know the following:

    • Right-click on one of the videos and click Properties. On the Properties dialog, go to the Subtitles tab and you should see your subtitles listed there. Take a screenshot of this dialog and post it here.
    • Right-click on the video and click 'Get FFmpeg Information'. Post that information here.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  3. #3
    Join Date
    Dec 2012
    Location
    Austria
    Posts
    20

    Default

    Dear Paul

    Thank you for the prompt reply.

    OK. My example.
    I ripped the movie "The Equalizer" with Denzel Washington with language german and all subtitles (normal and forced) to vob-structure.
    The result on harddisk I played with WinDVD as well as PowerDVD with the subs running. I burned the vob-structure to a dvd and played the dvd on my sony-player. The subtitles were present in all cases.

    Now to mezzmo:
    I examine the movie as you described:

    1) properties, subtitles
    result: empty, no subtitles present...

    2) ffmpeg-information:
    ffmpeg version N-66094-gbb8b752 Copyright (c) 2000-2014 the FFmpeg developers
    built on Sep 4 2014 16:23:51 with gcc 4.8.2 (GCC)
    configuration: --enable-memalign-hack --arch=x86_64 --target-os=mingw32 --cross-prefix=x86_64-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/home/peter/ffmpeg/build/gpl64 --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/peter/cc32/include --extra-ldflags=-L/home/peter/cc64/lib --pkg-config=pkg-config --disable-w32threads --enable-libvpx --enable-libvorbis
    libavutil 54. 7.100 / 54. 7.100
    libavcodec 56. 1.100 / 56. 1.100
    libavformat 56. 4.100 / 56. 4.100
    libavdevice 56. 0.100 / 56. 0.100
    libavfilter 5. 0.103 / 5. 0.103
    libswscale 3. 0.100 / 3. 0.100
    libswresample 1. 1.100 / 1. 1.100
    Input #0, mpeg, from 'pipe:':
    Duration: N/A, start: 0.287267, bitrate: 384 kb/s
    Stream #0:0[0x1bf]: Data: dvd_nav_packet
    Stream #0:1[0x1e0]: Video: mpeg2video (Main), yuv420p(tv), 720x576 [SAR 64:45 DAR 16:9], max. 9800 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0:2[0x81]: Audio: ac3, 48000 Hz, 5.1(side), fltp, 384 kb/s
    At least one output file must be specified

    <MEZZMO>: Child process ended with code: 109, ExitCode=1

    ---> DB Level Info: 8, 4
    ---> Frame rate: 25,00
    ---> Aspect ratio: 16:9 PAR=64:45
    ---> Duration: 02:06:38 (multi-file total)
    ---> List: #dv;1:1;0:4767944704;7598|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_1.vob|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_2.vob|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_3.vob|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_4.vob|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_5.vob


    It's a miracle, both look like no subtitles are in the movie.
    Where have they gone?

    Thank you for any information to that problem.

    Wolfgang

  4. #4
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,601

    Default

    Hi Wolfgang,

    Try this: Press down the Ctrl key on your keyboard and keep it pressed down. Right-click on the video in Mezzmo again and click 'Get FFmpeg Information'. Post that information here.

    Using the Ctrl key digs deeper into the video file to get more information about the video file. Hopefully that finds information about the subtitles.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  5. #5
    Join Date
    Dec 2012
    Location
    Austria
    Posts
    20

    Default

    Hi Paul

    OK - i did so.
    Here is the log:

    ffmpeg version N-66094-gbb8b752 Copyright (c) 2000-2014 the FFmpeg developers
    built on Sep 4 2014 16:23:51 with gcc 4.8.2 (GCC)
    configuration: --enable-memalign-hack --arch=x86_64 --target-os=mingw32 --cross-prefix=x86_64-w64-mingw32- --enable-static --disable-shared --enable-zlib --disable-postproc --prefix=/home/peter/ffmpeg/build/gpl64 --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/peter/cc32/include --extra-ldflags=-L/home/peter/cc64/lib --pkg-config=pkg-config --disable-w32threads --enable-libvpx --enable-libvorbis
    libavutil 54. 7.100 / 54. 7.100
    libavcodec 56. 1.100 / 56. 1.100
    libavformat 56. 4.100 / 56. 4.100
    libavdevice 56. 0.100 / 56. 0.100
    libavfilter 5. 0.103 / 5. 0.103
    libswscale 3. 0.100 / 3. 0.100
    libswresample 1. 1.100 / 1. 1.100
    Input #0, mpeg, from 'pipe:':
    Duration: N/A, start: 0.287267, bitrate: 384 kb/s
    Stream #0:0[0x1bf]: Data: dvd_nav_packet
    Stream #0:1[0x1e0]: Video: mpeg2video (Main), yuv420p(tv), 720x576 [SAR 64:45 DAR 16:9], max. 9800 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0:2[0x81]: Audio: ac3, 48000 Hz, 5.1(side), fltp, 384 kb/s
    Stream #0:3[0x21]: Subtitle: dvd_subtitle
    At least one output file must be specified

    <MEZZMO>: Child process ended with code: 109, ExitCode=1

    ---> DB Level Info: 8, 4
    ---> Frame rate: 25,00
    ---> Aspect ratio: 16:9 PAR=64:45
    ---> Duration: 02:06:38 (multi-file total)
    ---> List: #dv;1:1;0:4767944704;7598|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_1.vob|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_2.vob|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_3.vob|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_4.vob|I:\DVD-Archiv\3 Filmarchiv\The Equalizer\VIDEO_TS\vts_01_5.vob

    Wow - there is a subtitle stream.
    I hope, you get an idea what's going wrong.

    Thanks a lot for your examination.

    Wolfgang

  6. #6
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,601

    Default

    Hi Wolfgang,

    That's a good result. I'll explain what's happening. When you add your video files into Mezzmo, we analyse them to find all the video, audio and subtitle streams inside them. By default, we only analyse a certain portion of the file (for faster processing). In rare cases (like yours), this portion is not enough to find all streams and Mezzmo may miss finding some streams that are found later in the file.

    We have an override where you can manually set the portion of the file to analyse. Follow these steps:

    1. Stop your Mezzmo server and exit Mezzmo (Windows) app.
    2. Using Windows Explorer, go the following folder:

      C:\Users\<username>\AppData\Local\Conceiva\Mezzmo (for Win8/Win7/Vista)
      C:\Documents and Settings\<username>\Local Settings\Application Data\Conceiva\Mezzmo (for Win XP)
    3. Using a text editor like Notepad, edit the MezzmoMediaServer.ini file.
    4. In the MezzmoMediaServer.ini file, locate the [Subtitles] section and add:

      AnalyzeDuration=300

      If you do not see [Subtitles] section, then add this at the end of the file. The AnalyzeDuration value is the number of seconds of the video to analyze to find all streams. In the above example, 300 = 5 minutes. The maximum value is 3600 (= 60 minutes).

      Example:
      ...
      [Subtitles]
      AnalyzeDuration=300
      ...
    5. Save your changes to the MezzmoMediaServer.ini file.
    6. Run Mezzmo and delete the video (that has the missing subtitles) from your Mezzmo library. To do this, select the video & press the DEL key. If Mezzmo tells you that you cannot delete a file from a folder, then create a playlist using Create Playlist -> Playlist and then drag and drop this video into the playlist. Then select the file in the newly created playlist and press the DEL key. This will allow you to delete it.
    7. Add the video back into your Mezzmo library using 'Add To Library'->'Scan Drive/Folder For Media Files'. Set the folder path to I:\DVD-Archiv\3 Filmarchiv\The Equalizer when scanning for files so it picks up your ripped DVD.
    8. Mezzmo will find your DVD video and hopefully this time you will have subtitles listed as well. Go to the Properties dialog for the video and check the Subtitles tab. If you don't see them, then increase the "AnalyzeDuration=300" value to (say) "AnalyzeDuration=600" and repeat all the above steps. See if that helps.

    Let us know how you go.

    (BTW: We are improving analysing files for the upcoming Mezzmo v5.0, so you will not have to do these manual steps with Mezzmo v5.0)

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  7. #7
    Join Date
    Dec 2012
    Location
    Austria
    Posts
    20

    Default

    Hi Paul

    After several tries the last two days I can report the results.

    First: I did all the steps you described, removed playlists, stopped mezzmo, changed the written parameter (first with 300, than with 600), rescanned a directory with only 3 movies - all with subtitles. The Equalizer was one of them.
    I was really happy seeing the german subtitle shown in the in properties-dialog in all three movies!

    I went to living-room to my two renderes - sony-bd-player and samsung-tv, as descibed in my first post.

    My happiness was gone away soon - no subtitle(s) were shown while playing the movie(s)!
    Whatever happened on the way from mezzmo to the players....

    I tried some configuration-changes of my renderes in mezzmo (burn in subtitles, stream embedded subtitles and so on) - no effort anyway..

    What is wrong with my things? I'm at the end.

    If you have another idea, I will be very pleased.

    Thanks to you
    Wolfgang

  8. #8
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,601

    Default

    Hi Wolfgang,

    Glad that you now have the embedded subtitles collected and displayed in Mezzmo.

    The reason that your subtitles are not displayed on both your devices is that the subtitles are embedded subtitles inside your video file(s) and they are DVD (VobSub) subtitle format. Unfortunately, both your devices do not support displaying embedded DVD (VobSub) subtitles when streaming via DLNA. This is a restriction of your devices' firmware and not Mezzmo.

    The best solution is for you to download an external subtitle file from a subtitle web site like http://www.opensubtitles.org. Search for your movie and download an .SRT file in your preferred language. Save it in the same folder as your video file and give it the same name (see this FAQ post for file naming conventions - http://forum.conceiva.com/showthread...3140#post23140). Next, right-click on the DVD video in Mezzmo and click Properties. On the Properties dialog, go to the Subtitles tab and click 'Update Subtitles' button. You should see your new external subtitle listed there now. Now, go to the Media Devices dialog and edit your device(s). On the Device Settings dialog, go to the Transcoding tab and delete all transcoded files. Try streaming your files now. You should see your subtitles.

    If still a problem, let us know.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

Similar Threads

  1. 3D Subtitles
    By baletka in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 02-16-2014, 04:08 PM
  2. .sup subtitles ?
    By erimads in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 07-07-2013, 10:57 AM
  3. Need help with subtitles
    By DracoAzule in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 05-29-2012, 10:45 AM
  4. .sup subtitles ?
    By erimads in forum DownloadStudio Questions and Support
    Replies: 0
    Last Post: 02-12-2012, 11:46 PM
  5. No subtitles on the TV :(
    By d_singe in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 12-06-2011, 12:32 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •