Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: VLC iPad transcoding & AC3 audio

  1. #11
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,592

    Default

    Try adding single quotes around the URL and try running the ffmpeg command line again. Also don't forget to add the -i option. i.e. ffmpeg -loglevel debug -i 'http://10.0.0.249:5004/auto/v802?dlna'

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  2. #12
    Join Date
    Mar 2013
    Posts
    31

    Default

    Sorry about that! FFmpeg didn't like the quotes around the url but that -i flag is important You are likely aware of this already but the 406 error is a standard http error code indicating that the target device doesn't accept the http request headers sent. I've been playing around with the developer tools in firefox and the HDHomeRun doesn't seem too picky about the http requests. However the HDHomeRun does not appear to like the request headers sent by FFMpeg.

    I can send this request from Firefox:
    GET /auto/v802?dlna HTTP/1.1
    Host: 10.0.0.249:5004
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-US,en;q=0.5
    Accept-Encoding: gzip, deflate
    DNT: 1
    Connection: keep-alive

    And receive these http response headers along with a video stream
    HTTP/1.1 200 OK
    Server: HDHomeRun/1.0
    Connection: close
    Content-Type: video/mpeg
    Cache-Control: no-cache
    Pragma: no-cache
    transferMode.dlna.org: Streaming



    FFmpeg32

    C:\Program Files (x86)\Conceiva\Mezzmo\ffmpeg32>ffmpeg -loglevel debug -i http://10.0.0.249:5004/auto/v802?dlna
    ffmpeg version N-66094-gbb8b752 Copyright (c) 2000-2014 the FFmpeg developers
    built on Sep 4 2014 15:22:34 with gcc 4.8.2 (GCC)
    configuration: --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-static --disable-shared --enable-zlib --
    ild/gpl32 --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-pthreads --enable-runtime-cpudetect --extra-cflags=-
    me/peter/cc32/lib --pkg-config=pkg-config --disable-w32threads --enable-zlib --enable-libvpx --enable-libvorbis
    libavutil 54. 7.100 / 54. 7.100
    libavcodec 56. 1.100 / 56. 1.100
    libavformat 56. 4.100 / 56. 4.100
    libavdevice 56. 0.100 / 56. 0.100
    libavfilter 5. 0.103 / 5. 0.103
    libswscale 3. 0.100 / 3. 0.100
    libswresample 1. 1.100 / 1. 1.100
    Splitting the commandline.
    Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument 'debug'.
    Reading option '-i' ... matched as input file with argument 'http://10.0.0.249:5004/auto/v802?dlna'.
    Finished splitting the commandline.
    Parsing a group of options: global .
    Applying option loglevel (set logging level) with argument debug.
    Successfully parsed a group of options.
    Parsing a group of options: input file http://10.0.0.249:5004/auto/v802?dlna.
    Successfully parsed a group of options.
    Opening an input file: http://10.0.0.249:5004/auto/v802?dlna.
    [http @ 03ad0060] request: GET /auto/v802?dlna HTTP/1.1
    User-Agent: Lavf/56.4.100
    Accept: */*
    Range: bytes=0-
    Connection: close
    Host: 10.0.0.249:5004
    Icy-MetaData: 1


    [http @ 03ad0060] header='HTTP/1.1 406 Not Acceptable'
    [http @ 03ad0060] http_code=406
    [http @ 03ad0060] HTTP error 406 Not Acceptable
    http://10.0.0.249:5004/auto/v802?dlna: Input/output error

    FFmpeg64
    C:\Program Files (x86)\Conceiva\Mezzmo\ffmpeg64>ffmpeg -loglevel debug -i http://10.0.0.249:5004/auto/v802?dlna
    ffmpeg version N-66094-gbb8b752 Copyright (c) 2000-2014 the FFmpeg developers
    built on Sep 4 2014 16:23:51 with gcc 4.8.2 (GCC)
    configuration: --enable-memalign-hack --arch=x86_64 --target-os=mingw32 --cross-prefix=x86_64-w64-mingw32- --enable-static --disable-shared --enable-zlib --d
    eg/build/gpl64 --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/peter/cc32/i
    /lib --pkg-config=pkg-config --disable-w32threads --enable-libvpx --enable-libvorbis
    libavutil 54. 7.100 / 54. 7.100
    libavcodec 56. 1.100 / 56. 1.100
    libavformat 56. 4.100 / 56. 4.100
    libavdevice 56. 0.100 / 56. 0.100
    libavfilter 5. 0.103 / 5. 0.103
    libswscale 3. 0.100 / 3. 0.100
    libswresample 1. 1.100 / 1. 1.100
    Splitting the commandline.
    Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument 'debug'.
    Reading option '-i' ... matched as input file with argument 'http://10.0.0.249:5004/auto/v802?dlna'.
    Finished splitting the commandline.
    Parsing a group of options: global .
    Applying option loglevel (set logging level) with argument debug.
    Successfully parsed a group of options.
    Parsing a group of options: input file http://10.0.0.249:5004/auto/v802?dlna.
    Successfully parsed a group of options.
    Opening an input file: http://10.0.0.249:5004/auto/v802?dlna.
    [http @ 000000000033efa0] request: GET /auto/v802?dlna HTTP/1.1
    User-Agent: Lavf/56.4.100
    Accept: */*
    Range: bytes=0-
    Connection: close
    Host: 10.0.0.249:5004
    Icy-MetaData: 1


    [http @ 000000000033efa0] header='HTTP/1.1 406 Not Acceptable'
    [http @ 000000000033efa0] http_code=406
    [http @ 000000000033efa0] HTTP error 406 Not Acceptable
    http://10.0.0.249:5004/auto/v802?dlna: Input/output error

  3. #13
    Join Date
    Mar 2013
    Posts
    31

    Default

    Paul,

    Simply removing the ?dlna variable from the end of the url produces this output from ffmpeg64 along with a playable mpg file.

    C:\Program Files (x86)\Conceiva\Mezzmo\ffmpeg64>ffmpeg -loglevel debug -i http://10.0.0.249:5004/auto/v802 test.mpg
    ffmpeg version N-66094-gbb8b752 Copyright (c) 2000-2014 the FFmpeg developers
    built on Sep 4 2014 16:23:51 with gcc 4.8.2 (GCC)
    configuration: --enable-memalign-hack --arch=x86_64 --target-os=mingw32 --cross-prefix=x86_64-w64-mingw32- --enable-static --disable-shared --enable-zlib --d
    eg/build/gpl64 --enable-libmp3lame --enable-libx264 --enable-gpl --extra-libs='-lx264 -lpthread' --enable-runtime-cpudetect --extra-cflags=-I/home/peter/cc32/i
    /lib --pkg-config=pkg-config --disable-w32threads --enable-libvpx --enable-libvorbis
    libavutil 54. 7.100 / 54. 7.100
    libavcodec 56. 1.100 / 56. 1.100
    libavformat 56. 4.100 / 56. 4.100
    libavdevice 56. 0.100 / 56. 0.100
    libavfilter 5. 0.103 / 5. 0.103
    libswscale 3. 0.100 / 3. 0.100
    libswresample 1. 1.100 / 1. 1.100
    Splitting the commandline.
    Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument 'debug'.
    Reading option '-i' ... matched as input file with argument 'http://10.0.0.249:5004/auto/v802'.
    Reading option 'test.mpg' ... matched as output file.
    Finished splitting the commandline.
    Parsing a group of options: global .
    Applying option loglevel (set logging level) with argument debug.
    Successfully parsed a group of options.
    Parsing a group of options: input file http://10.0.0.249:5004/auto/v802.
    Successfully parsed a group of options.
    Opening an input file: http://10.0.0.249:5004/auto/v802.
    [http @ 000000000200f000] request: GET /auto/v802 HTTP/1.1
    User-Agent: Lavf/56.4.100
    Accept: */*
    Range: bytes=0-
    Connection: close
    Host: 10.0.0.249:5004
    Icy-MetaData: 1


    [http @ 000000000200f000] header='HTTP/1.1 200 OK'
    [http @ 000000000200f000] http_code=200
    [http @ 000000000200f000] header='Server: HDHomeRun/1.0'
    [http @ 000000000200f000] header='Connection: close'
    [http @ 000000000200f000] header='Content-Type: video/mpeg'
    [http @ 000000000200f000] header='Cache-Control: no-cache'
    [http @ 000000000200f000] header='Pragma: no-cache'
    [http @ 000000000200f000] header='transferMode.dlna.org: Streaming'
    [http @ 000000000200f000] header=''
    [mpegts @ 000000000200ea00] Format mpegts probed with size=2048 and score=99
    [mpegts @ 000000000200ea00] stream=0 stream_type=2 pid=1177 prog_reg_desc=
    [mpegts @ 000000000200ea00] stream=1 stream_type=81 pid=1178 prog_reg_desc=
    [mpegts @ 000000000200ea00] stream=2 stream_type=81 pid=1179 prog_reg_desc=
    [mpegts @ 000000000200ea00] Before avformat_find_stream_info() pos: 0 bytes read:9212 seeks:0
    [mpegts @ 000000000200ea00] All programs have pmt, headers found
    [mpeg2video @ 000000000030be40] Invalid frame dimensions 0x0.
    Last message repeated 24 times
    [mpegts @ 000000000200ea00] All info found
    [mpegts @ 000000000200ea00] After avformat_find_stream_info() pos: 1874924 bytes read:1875300 seeks:0 frames:62
    Input #0, mpegts, from 'http://10.0.0.249:5004/auto/v802':
    Duration: N/A, start: 35549.582100, bitrate: 512 kb/s
    Program 101
    Stream #0:0[0x1177], 26, 1/90000: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv), 1920x1080 [SAR 1:1 DAR 16:9], 1001/60000, max. 18000 kb/s,

    Stream #0:1[0x1178](eng), 16, 1/90000: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), fltp, 384 kb/s
    Stream #0:2[0x1179](spa), 20, 1/90000: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, mono, fltp, 128 kb/s
    Successfully opened the file.
    Parsing a group of options: output file test.mpg.
    Successfully parsed a group of options.
    Opening an output file: test.mpg.
    Successfully opened the file.
    detected 4 logical cores
    [graph 0 input from stream 0:0 @ 0000000004aa12e0] Setting 'video_size' to value '1920x1080'
    [graph 0 input from stream 0:0 @ 0000000004aa12e0] Setting 'pix_fmt' to value '0'
    [graph 0 input from stream 0:0 @ 0000000004aa12e0] Setting 'time_base' to value '1/90000'
    [graph 0 input from stream 0:0 @ 0000000004aa12e0] Setting 'pixel_aspect' to value '1/1'
    [graph 0 input from stream 0:0 @ 0000000004aa12e0] Setting 'sws_param' to value 'flags=2'
    [graph 0 input from stream 0:0 @ 0000000004aa12e0] Setting 'frame_rate' to value '30000/1001'
    [graph 0 input from stream 0:0 @ 0000000004aa12e0] w:1920 h:1080 pixfmt:yuv420p tb:1/90000 fr:30000/1001 sar:1/1 sws_param:flags=2
    [format @ 0000000004aa22a0] compat: called with args=[yuv420p]
    [format @ 0000000004aa22a0] Setting 'pix_fmts' to value 'yuv420p'
    [AVFilterGraph @ 0000000000399fa0] query_formats: 4 queried, 3 merged, 0 already done, 0 delayed
    [graph 1 input from stream 0:1 @ 0000000002006980] Setting 'time_base' to value '1/48000'
    [graph 1 input from stream 0:1 @ 0000000002006980] Setting 'sample_rate' to value '48000'
    [graph 1 input from stream 0:1 @ 0000000002006980] Setting 'sample_fmt' to value 'fltp'
    [graph 1 input from stream 0:1 @ 0000000002006980] Setting 'channel_layout' to value '0x60f'
    [graph 1 input from stream 0:1 @ 0000000002006980] tb:1/48000 samplefmt:fltp samplerate:48000 chlayout:0x60f
    [audio format for output stream 0:1 @ 0000000002006b00] Setting 'sample_fmts' to value 's16'
    [audio format for output stream 0:1 @ 0000000002006b00] Setting 'sample_rates' to value '44100|48000|32000|22050|24000|16000'
    [audio format for output stream 0:1 @ 0000000002006b00] Setting 'channel_layouts' to value '0x4|0x3'
    [audio format for output stream 0:1 @ 0000000002006b00] auto-inserting filter 'auto-inserted resampler 0' between the filter 'Parsed_anull_0' and the filter 'a
    [AVFilterGraph @ 000000000039a420] query_formats: 4 queried, 6 merged, 3 already done, 0 delayed
    0.414214 0.000000 0.292893 0.000000 0.292893 0.000000
    0.000000 0.414214 0.292893 0.000000 0.000000 0.292893
    [auto-inserted resampler 0 @ 0000000002006bc0] ch:6 chl:5.1(side) fmt:fltp r:48000Hz -> ch:2 chl:stereo fmt:s16 r:48000Hz
    [mpeg1video @ 0000000000310240] intra_quant_bias = 96 inter_quant_bias = 0
    [mpeg @ 0000000004cb00a0] VBV buffer size not set, using default size of 130KB
    If you want the mpeg file to be compliant to some specification
    Like DVD, VCD or others, make sure you set the correct buffer size
    Output #0, mpeg, to 'test.mpg':
    Metadata:
    encoder : Lavf56.4.100
    Stream #0:0, 0, 1/90000: Video: mpeg1video, yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 1001/30000, q=2-31, 200 kb/s, 29.97 fps, 90k tbn, 29.97 tbc
    Metadata:
    encoder : Lavc56.1.100 mpeg1video
    Stream #0:1(eng), 0, 1/90000: Audio: mp2, 48000 Hz, stereo, s16, 384 kb/s
    Metadata:
    encoder : Lavc56.1.100 mp2
    Stream mapping:
    Stream #0:0 -> #0:0 (mpeg2video (native) -> mpeg1video (native))
    Stream #0:1 -> #0:1 (ac3 (native) -> mp2 (native))
    Press [q] to stop, [?] for help
    [mpegts @ 000000000200ea00] Correcting start time by 6533
    *** 34 dup!
    [mpeg @ 0000000004cb00a0] First SCR: 0 First DTS: 45000
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=233676 size=2865424.5kbits/s dup=34 drop=0
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=233676 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=235705 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=235705 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=237746 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=237746 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=239787 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=239787 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=241828 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=241828 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=243869 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=243869 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=245910 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=245910 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=247951 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=247951 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=249992 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=249992 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=252033 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=252033 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=254074 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=254074 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=256115 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=256115 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=258156 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=258156 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=260197 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=260197 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=262238 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=262238 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=264279 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=264279 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=266320 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=266320 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=268361 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=268361 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=270402 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=270402 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=272443 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=272443 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=274484 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=274484 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=276525 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=276525 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=278566 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=278566 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=280607 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=280607 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=282648 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=282648 size=286542
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=284689 size=286542
    [mpeg @ 0000000004cb00a0] packet too large, ignoring buffer limits to mux it
    [mpeg @ 0000000004cb00a0] buffer underflow st=0 bufi=284689 size=286542
    frame= 374 fps= 33 q=31.0 Lsize= 6112kB time=00:00:12.44 bitrate=4023.0kbits/s dup=34 drop=0
    video:5515kB audio:564kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.544290%
    Input file #0 (http://10.0.0.249:5004/auto/v802):
    Input stream #0:0 (video): 368 packets read (22407096 bytes); 341 frames decoded;
    Input stream #0:1 (audio): 376 packets read (577536 bytes); 376 frames decoded (577536 samples);
    Input stream #0:2 (audio): 20 packets read (10240 bytes);
    Total: 764 packets (22994872 bytes) demuxed
    Output file #0 (test.mpg):
    Output stream #0:0 (video): 374 frames encoded; 374 packets muxed (5647655 bytes);
    Output stream #0:1 (audio): 501 frames encoded (577152 samples); 501 packets muxed (577152 bytes);
    Total: 875 packets (6224807 bytes) muxed
    745 frames successfully decoded, 0 decoding errors
    [AVIOContext @ 00000000048f7c60] Statistics: 0 seeks, 3056 writeouts
    [AVIOContext @ 000000000200f380] Statistics: 23848420 bytes read, 0 seeks
    Received signal 2: terminating.

  4. #14
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,592

    Default

    Thanks for the information. I think we're getting closer now. Your HDHomerun is certainly rejecting FFmpeg's HTTP GET headers for some reason. Use the following FFmpeg documentation (https://www.ffmpeg.org/ffmpeg-protocols.html#http) to tweak the FFmpeg command line so that FFmpeg's HTTP GET is accepted by your device. Hopefully you can isolate what header attribute is causing the problem. Let us know how you go.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  5. #15
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,592

    Default

    Based on your last post (where you removed ?dlna and it worked), then I want to double-check that the URLs that Mezzmo is collecting from your HDHomeRun Prime are correct (and not possibly truncated for some strange reason). We'd like a set of WireShark logs from you. I'm not sure if you are familiar with Wireshark (Ethereal as it used to be called), but it's very simple to use. Download it from http://www.wireshark.org and follow these steps:

    1. Turn off your HDHomeRun
    2. Exit Mezzmo (Windows) app
    3. Run Wireshark
    4. Go to Capture -> Interfaces
    5. In the dialog that pops up click the Start button opposite your network card (if you have multiple, please choose the one that's connected to the device)
    6. Turn on your HDHomeRun
    7. Run Mezzmo (Windows) app and use the Network media pane to browse your HDHomeRun. Browse into a folder/playlist and drag/drop a video URL into Mezzmo library.
    8. Click on Capture -> Stop in Wireshark
    9. Click on File -> Save in Wireshark and save the file as a Wireshark/tcpdump format (default)
    10. Zip it up and email it to us at support [at] conceiva [dot] com

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  6. #16
    Join Date
    Mar 2013
    Posts
    31

    Default

    Wireshark logs have been sent via email. Thanks

  7. #17
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,592

    Default

    Thanks for the logs. They show that the URLs delivered by your HDHomeRun to Mezzmo's Network media pane are (for example) http://10.0.0.249:5004/auto/v190?dlna. So they look exactly like what Mezzmo is asking FFmpeg to get information for. So Mezzmo is collecting the URLs correctly from your HDHomeRun. This eliminates Mezzmo from being the cause of the problem, and leaves the cause being the HDHomeRun's firmware returning a HTTP 406 error when certain HTTP GET header attributes are present or when "?dlna" is present in the URL.

    The FFmpeg HTTP GET looks like:

    GET /auto/v802?dlna HTTP/1.1
    User-Agent: Lavf/56.4.100
    Accept: */*
    Range: bytes=0-
    Connection: close
    Host: 10.0.0.249:5004
    Icy-MetaData: 1

    I have bolded the two header attributes that are probably causing your HDHomeRun to become confused. In Firefox developer tools, please add each of these bolded header attributes to try an replicate the 406 error. Let us know how you go.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  8. #18
    Join Date
    Mar 2013
    Posts
    31

    Default

    Thanks Paul,

    Making a HTTP request with Firefox to 10.0.0.249:5004/auto/v802?dlna with the response headers provided failed with a HTTP 406 status.

    User-Agent: Lavf/56.4.100
    Accept: */*
    Range: bytes=0-
    Connection: close
    Host: 10.0.0.249:5004
    Icy-MetaData: 1


    Making a HTTP request with the following headers (Range: bytes=0- removed) returns a HTTP 200 status & a playable file stream.

    User-Agent: Lavf/56.4.100
    Accept: */*
    Connection: close
    Host: 10.0.0.249:5004
    Icy-MetaData: 1

    Hope that helps.

  9. #19
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,592

    Default

    Thanks. It tells us that the range request attribute ("Range: bytes=0-") is the HTTP GET header attribute that your HDHomeRun's firmware rejects. There's no reason for this rejection, so I think it's a firmware bug/issue for the HDHomeRun folks to consider fixing. I suggest you jump onto their forums (https://www.silicondust.com/forum/) and post details about the problem. It will be easy for them to reproduce using ffmpeg.exe and the command line that we've been using above. Let us know if you need help and/or let us know the results.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  10. #20
    Join Date
    Mar 2013
    Posts
    31

    Default

    Thanks Paul. I'll follow up with Silicon Dust & see what they say. In the interim, is there any way I can manually add a stream address to my Mezzmo library? Or are you aware of any way to adjust the default headers sent by FFmpeg?

Similar Threads

  1. only transcoded Audio AC3
    By sfolguera in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 07-31-2015, 09:38 AM
  2. Video with 2 audio streams: DTS and AC3, how to choose?
    By peterhammer in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 01-26-2015, 09:26 PM
  3. ac3 audio in mkv for samsung bd-c5900
    By aguy in forum Mezzmo Questions and Support
    Replies: 11
    Last Post: 07-11-2013, 07:13 PM
  4. Mezzmo and Ipad streaming/transcoding
    By lmdfln in forum Mezzmo Questions and Support
    Replies: 5
    Last Post: 07-03-2011, 07:08 AM
  5. iPad works fine without any transcoding
    By Gus in forum Mezzmo Questions and Support
    Replies: 0
    Last Post: 02-23-2011, 09:54 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •