Results 1 to 7 of 7

Thread: FFmpeg Transcoding - permission denied

  1. #1

    Default FFmpeg Transcoding - permission denied

    Almost every day a new challenge :-)

    I am still trying to find out, what is the best way to use Mezzmo.
    If Mezzmo is installed on the WHS2011, I have to access it from the Client via the Remote Desktop Connection or directly on the WHS. Streaming works then, but I dont like to use it like this. Because I have to be "on the Server" always.
    If Mezzmo ist installed on the Client (my first choice), transcoding does not work: I can see it starts, but in a second it fails (permission denied), see the text from the MezzmoFFmpegTranscodeFileLog.txt

    ffmpeg version N-66094-gbb8b752 Copyright (c) 2000-2014 the FFmpeg developers
    ...
    ...
    ...
    \\SERVER-NAME\Filme\Film-Name.avi: Permission denied

    <MEZZMO>: Child process ended with code: 109, ExitCode=1


    The selected folder for transcoding is on the Client.
    I also moved that folder on the WHS, but then transcoding does not even start. No error, no transcoding. Nothing at all.

    I canīt solve that problem, because I donīt know what it is
    Any ideas...?

    Thanks,
    Robert
    Panasonic TX-50CXW804, Panasonic BMP-BDT700, Yamaha RX-V663, WHS2011

  2. #2
    Join Date
    Mar 2011
    Posts
    336

    Default

    Quote Originally Posted by rowin View Post
    Almost every day a new challenge :-)

    I am still trying to find out, what is the best way to use Mezzmo.
    If Mezzmo is installed on the WHS2011, I have to access it from the Client via the Remote Desktop Connection or directly on the WHS. Streaming works then, but I dont like to use it like this. Because I have to be "on the Server" always.
    If Mezzmo ist installed on the Client (my first choice), transcoding does not work: I can see it starts, but in a second it fails (permission denied), see the text from the MezzmoFFmpegTranscodeFileLog.txt

    ffmpeg version N-66094-gbb8b752 Copyright (c) 2000-2014 the FFmpeg developers
    ...
    ...
    ...
    \\SERVER-NAME\Filme\Film-Name.avi: Permission denied

    <MEZZMO>: Child process ended with code: 109, ExitCode=1


    The selected folder for transcoding is on the Client.
    I also moved that folder on the WHS, but then transcoding does not even start. No error, no transcoding. Nothing at all.

    I canīt solve that problem, because I donīt know what it is
    Any ideas...?

    Thanks,
    Robert
    Mezzmo must be installed on whatever device is going to do the transcoding. You can always store the media files on a different machine and just add them to the Mezzmo library via network share.

    Are you saying that you don't like logging into WHS 2011 when you need to add files or do updates to the library? Oncee your library and playlists are set up, if you do it correctly, you shouldn't need to log in to Mezzmo for anything other than changing/adding/deleting playlists or a Mezzmo setting. Mezzmo can automatically run regular updates so adding and removing media should be pretty automatic.

  3. #3

    Default

    Perhaps my explanation was not clearly enough or confusing.

    ) I donīt want to add or delete files to the library.
    ) Mezzmo and the transcoding-folder are installed on the same device (Laptop). All the media is on the WHS. Transcoding fails with this error: "\\WHS-NAME\Folder\Movie.avi: Permission denied"
    ) I copied some files to the client, and here transcoding works as usual. So it seems to be an issue with transcoding data from the WHS. See attachment.

    Alternative option:
    I install and run Mezzmo on/from the WHS. Transcoding works then. And this is what I donīt want, because then I have to be logged in to the WHS (directly or via remote desktop).
    Mezzmo should run properly on the client.

    Robert
    Attached Images Attached Images
    Last edited by rowin; 03-26-2016 at 10:59 PM.
    Panasonic TX-50CXW804, Panasonic BMP-BDT700, Yamaha RX-V663, WHS2011

  4. #4
    Join Date
    Mar 2011
    Posts
    336

    Default

    My biggest question is what is forcing you to log in to the WHS machine if Mezzmo is installed on it?

    Secondly, it sounds like a network sharing issue and you likely have some permissions issues from your network. Have you been through this article to make sure Mezzmo has the proper permissions to stream remote files:

    http://forum.conceiva.com/showthread...er-permissions

  5. #5

    Default

    Quote Originally Posted by smitbret View Post
    My biggest question is what is forcing you to log in to the WHS machine if Mezzmo is installed on it?
    Sorry, i donīt understand this question; if Mezzmo is installed on the WHS, how could I run the program (not the media-server), without being logged in to the WHS? I donīt understand what you want to tell me. If I want to see the Mezzmo surface, I have to run the progam where it is installed?!? How could I work with Mezzmo and browse the media-files without beein on the device, where Mezzmo is installed?

    Quote Originally Posted by smitbret View Post
    Secondly, it sounds like a network sharing issue and you likely have some permissions issues from your network.
    Yes, it looks like, but only with FFmpegīs Transcoding :-)

    Quote Originally Posted by smitbret View Post
    Have you been through this article to make sure Mezzmo has the proper permissions to stream remote files:

    http://forum.conceiva.com/showthread...er-permissions
    I can see all my folders, and I do have access to all of them. Also Mezzmo has! In Mezzmo I can see all of my media-data and browse it. But transcoding does not work. FFmpeg failes.
    Everything works fine, as long as Mezzmo and the media-files are on the same device; both on the Laptop or both on the WHS.

    I am sure, it is a permission issue; but how can I tell FFmpeg about that?
    The linked article does not describe my problem, I think; or I canīt see it. The only difference was the checkbox 'Replace all child object permissions...", which is checked now.
    But still the same:

    "\\WHS-SERVER\Folder\name.avi: Permission denied

    <MEZZMO>: Child process ended with code: 109, ExitCode=1"


    in the FFmpeg logfile.

    Thanks for your patience.
    Robert
    Panasonic TX-50CXW804, Panasonic BMP-BDT700, Yamaha RX-V663, WHS2011

  6. #6
    Join Date
    Mar 2013
    Posts
    31

    Default

    If you haven't changed anything, I suspect the Mezzmo service is running under the "Local System" account on your laptop. I would guess that it is launching FFmpeg with the same account. I would also guess that the "Local System" account does not have access to the network share on the WHS server.

    You could confirm this in two ways. You can configure the Mezzmo service to run as the user account you are using to login, see Windows > Services). Alternatively you can provide read access to "Everybody" & "Guests" to the files on the WHS server.

  7. #7

    Default

    Quote Originally Posted by dafunk60 View Post
    ...I suspect the Mezzmo service is running under the "Local System" account on your laptop. I would guess that it is launching FFmpeg with the same account. I would also guess that the "Local System" account does not have access to the network share on the WHS server.
    Yes, you are right.
    You confirmed my guess and also gave me the solution at the same time.
    I configured Mezzmo to run on my user account - transcoding works and everything ist fine

    Happy easter and thanks a lot,
    Robert
    Panasonic TX-50CXW804, Panasonic BMP-BDT700, Yamaha RX-V663, WHS2011

Similar Threads

  1. Streaming fails from a Network Location - Permission Denied
    By smitbret in forum Mezzmo Questions and Support
    Replies: 2
    Last Post: 07-14-2013, 06:56 PM
  2. Updating FFmpeg for Transcoding
    By stevefoobar in forum Mezzmo Questions and Support
    Replies: 3
    Last Post: 10-21-2012, 01:05 AM
  3. FFMPEG 100% when transcoding DTS
    By Diesel in forum Mezzmo Questions and Support
    Replies: 21
    Last Post: 02-22-2012, 08:53 AM
  4. FFMPEG 100% CPU by transcoding
    By species81 in forum Mezzmo Questions and Support
    Replies: 8
    Last Post: 02-01-2012, 09:11 AM
  5. Transcoding/FFMPEG.exe Questions
    By FlyingVguitarist in forum Mezzmo Questions and Support
    Replies: 11
    Last Post: 05-02-2011, 11:06 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •