Results 1 to 10 of 10

Thread: Mezzmo Service User

  1. #1

    Default Mezzmo Service User

    Hello all,

    I installed Mezzmo current version (5.0.3) as a Windows Service. After changing the login of that Service to a dedicated user, I can't log into Web Console anymore. Does this "service user" need any specific permissions on Mezzmo folders to make it work properly?

    Thanks

    Keep it up guys!

    ITMAN

  2. #2
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    The dedicated Windows user account will need read/write access to your Mezzmo database folder (see Options dialog - General page), your transcoding folder (see Transcoding Settings dialog), your Mezzmo plugins folder (see Options dialog - Plugins page) and read access for the Mezzmo program folder. And, it will need read access to the folders where your media files are.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  3. #3

    Default

    Awesome thanks!

    ITMAN

  4. #4

    Default

    I have granted read/write access to all folders you said - still not working. I'm reaching the Homepage of Mezzmo Website but can't login. It says password is wrong.
    If I change the Service Account back to Local System Account it works fine.

    What am I missing?

    Thanks,

  5. #5
    Join Date
    Mar 2012
    Posts
    227

    Default

    Quote Originally Posted by itman View Post
    I have granted read/write access to all folders you said - still not working. I'm reaching the Homepage of Mezzmo Website but can't login. It says password is wrong.
    If I change the Service Account back to Local System Account it works fine.

    What am I missing?

    Thanks,
    Try restarting the service after you've changed it to the actual user that you want it to be. The web interface works for me when I have it running as a specific user account.

    Another thing that I may do different than you is that I don't have the login pre-populated. I go to http://{mezzmo_server}:53168/web/login page, instead of the one with an actual user account entered. I've encountered some password issues with the pre-populated logon. Try it that way.

  6. #6

    Default

    Quote Originally Posted by ftanner View Post
    Try restarting the service after you've changed it to the actual user that you want it to be. The web interface works for me when I have it running as a specific user account.

    Another thing that I may do different than you is that I don't have the login pre-populated. I go to http://{mezzmo_server}:53168/web/login page, instead of the one with an actual user account entered. I've encountered some password issues with the pre-populated logon. Try it that way.
    Hello ftanner,

    I appreciate your input on this!
    Every time I made security changes to folders or changed the login of the Mezzmo - Service, I bounced that service as well. (FYI even a reboot didn't change the result)

    I am only accessing the Website through 'http://IP:PORT/web/login', didn't even know you can save a username into the URL. I also do not have any credentials saved.
    I'm wondering if there's any kind of log file for the Website I can check where it's failing on...

    I might also reinstall tonight just to make sure I don't have anything messed up!

    Cheers

    ITMAN

  7. #7
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Hi ITMAN,

    If you can reproduce the problem, then we'd like to see a set of logs. Turn on logging in Mezzmo (see http://forum.conceiva.com/showthread...nostic-logging) and restart your Mezzmo server. Now use your web browser to reproduce the problem. Once reproduced, stop your Mezzmo server and exit Mezzmo (Windows) app. Zip up all the logs and email them to us at support [at] conceiva [dot] com.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  8. #8

    Default

    Quote Originally Posted by Paul View Post
    Hi ITMAN,

    If you can reproduce the problem, then we'd like to see a set of logs. Turn on logging in Mezzmo (see http://forum.conceiva.com/showthread...nostic-logging) and restart your Mezzmo server. Now use your web browser to reproduce the problem. Once reproduced, stop your Mezzmo server and exit Mezzmo (Windows) app. Zip up all the logs and email them to us at support [at] conceiva [dot] com.
    Well, we might be able to figure it out together. I have done the following so far:

    - Base installed
    - Activated Software
    - Changed Mode to run as Service + changed Login of that service to my dedicated service account (none admin privileges)
    - Granted the dedicated service account full access to:
    C:\ProgramData\Conceiva
    C:\Program Files (x86)\Conceiva
    C:\Users\ADMINUSER\AppData\Local\Conceiva

    On the last one it threw errors for the Temporary - Folders.

    Now, I can't access the Website with the Password I have set up (also changing the password doesn't help), but if I login with Admin and a blank password I'm getting in.

    Hope this helps, I also provided the Logs per mail.

    Thanks and regards,

    ITMAN

  9. #9
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    11,616

    Default

    Thanks for the testing notes. We'll analyze your logs and report back via email shortly.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  10. #10

    Default

    Greetings earthlings,

    I'm pretty sure I've got it finally running.

    OS: Server 2012 R2
    user A (Administrator)
    user B (Starting as Administrator, will be used as service account later with no admin priviliges)

    1. run mezzmo setup as user B (shift + right click -> run as different user) and base install
    this will only work if user B is an Administrator

    2. after mezzmo is base installed, start mezzmo windows application as user B

    3. configure mezzmo (here is what I did)
    - change database location to C:\Mezzmo\DB
    - change logs location to C:\Mezzmo\Logs
    - change transcodingfiles location to C:\Mezzmo\TranscodingFiles
    - install mezzmo service (media server settings - run mezzmo server as windows service)
    - change the logon for that service (windows key + r -> eventvwr, return, scroll down to Mezzmo - Service, right click properties, Logon)

    4. edit security of the folders you moved mezzmo stuff in step 3 to full access for user B
    additionally you need edit access to the following locations:
    C:\Program Files (x86)\Conceiva\Mezzmo
    C:\ProgramData\Conceiva\Mezzmo

    5. start mezzmo windows application as your normal user
    this will create all the mezzmo configuration from scratch

    6. stop mezzmo service and exit mezzmo windows application

    7. change db location to what you have configured in step 4
    C:\ProgramData\Conceiva\Mezzmo\MezzmoServices.txt

    8. copy all files from
    C:\Users\B\AppData\Local\Conceiva
    to
    C:\Users\A\AppData\Local\Conceiva (yes override all)

    9. remove Administrator privilege from user B as this service account shouldn't need it anymore if you set the permissions in s

    And here the explanation:

    Mezzmo seems to create configuration per user. So if we start mezzmo server as a dedicated user, it will create a mezzmo database and all settings within that service user's AppData.
    To be able to start Mezzmo normally without "run as" I had to point my user's A configuration to the mezzmo service user's configuration. (step 7)

    Thanks Paul for the great support on this.

    peace out

    ITMAN
    Last edited by itman; 06-24-2016 at 07:43 AM.

Similar Threads

  1. Mezzmo Service Hang
    By jarrydp in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 05-13-2013, 08:52 AM
  2. Changing Mezzmo user
    By hevijoni in forum Mezzmo Questions and Support
    Replies: 1
    Last Post: 01-21-2013, 09:50 AM
  3. Mezzmo Service Problem
    By sohail in forum Mezzmo Questions and Support
    Replies: 7
    Last Post: 10-18-2012, 10:26 AM
  4. New Mezzmo user problems
    By freshhouse1 in forum Mezzmo Questions and Support
    Replies: 4
    Last Post: 03-07-2012, 09:07 AM
  5. What Exactly Does The Mezzmo Service Do?
    By kitsunegari in forum Mezzmo Questions and Support
    Replies: 5
    Last Post: 11-29-2010, 08:49 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •