Results 1 to 3 of 3

Thread: Mezzmo downscaling 4k to FHD?

  1. #1
    Join Date
    Nov 2016

    Default Mezzmo downscaling 4k to FHD?


    I bought a 4k TV and now Im testing 4k movies in it but the image is not as good as I would expect when streaming via Mezzmo.
    Looking at the FFmpeg output file I noticed the following:

    Input #0, matroska,webm, from 'D:\4KMOVIE.2160p.UHD.BluRay.FLAC.7.1.x264.mkv':
    Stream #0:0(eng): Video: h264 (High), yuv420p, 3840x1606, SAR 1:1 DAR 1920:803, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
    Stream #0:1(eng): Audio: flac, 48000 Hz, 7.1, s32 (24 bit) (default)

    And the output is:

    Output #0, matroska, to 'D:\Mezzmo Temp\TranscodingFiles\87A119BF-D971-4746-B6D1-0EEE7EFD48A7\Video\5407-fake_mp4-libx264-aac-sn.mzt':
    Stream #0:0(eng): Video: h264 (libx264) (H264 / 0x34363248), yuv420p, 1920x804 [SAR 804:803 DAR 1920:803], q=-1--1, 23.98 fps, 1k tbn, 23.98 tbc (default)
    Metadata: encoder : Lavc57.25.101 libx264
    Side data:cpb: bitrate max/min/avg: 0/0/0 buffer size: 0 vbv_delay: -1
    Stream #0:1(eng): Audio: aac (LC) ([255][0][0][0] / 0x00FF), 48000 Hz, 5.1, fltp (24 bit), 640 kb/s (default)

    Looking at the output resolution (1920x804) I would think that my 4k file is being downscaled to 1080p. Am I correct? If so what can I do to make the output be the same resolution as the source file?


  2. #2
    Join Date
    Sep 2009


    it looks like you may be using the LG TV (2015 Models) profile, please try using the LG TV Ultra HD to see if this helps deliver 4K content to the TV. You can also go to 'Media Devices' and double-click the device in the list then on the Performance tab set the Maximum resolution to 4K.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at
    Wiki: User Guides & Reference Manual at

  3. #3
    Join Date
    Nov 2016


    Hi! Thanks for the tip, it worked!

    I've been fighting this problem the entire day. Tried Plex but it would also transcode, and when I finally managed to make Plax stream in Direct Play it didnt recognize my subtitles. I managed to stream 4k with subtitles with Twonky but its a way too simple server.

    I've already tried the 'LG TV Ultra HD' profile but to no avail. Now that you said that, I went back to Mezzmo and tried messing with the substittles option in the Profile, so it wouldnt transcod to burn in into the movie. Did nothing, but after I put the Maximum resolution to 4k, as you said, it worked! Now Mezzmo will stream directly to my TV instead of transconding in my pc then send to my TV.

    Thanks! I love Mezzmo and was already sad with the prospect of leaving it hahah

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts