Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39

Thread: Transcode issue

  1. #11
    Join Date
    Aug 2015
    Posts
    35

    Default

    Alright, feel dumb... but I may have solved some of this. Checked my IP address in iphone to make sure it did not change and it had. So when I was trying to make changes to the video file in Mezzmo under transcode tab for what I thought was the correct media device, it was not taking it because it was not the actual device's IP so figured that out. I'm not sure why that randomly changed since that was the LAN assigned from the WIFI router and does not ever seem to change.
    Now, I was able to get the videos in question playing wide aspect to work with "original file" as expected. So...


    I have numerous .MOV files and some play wide and some do not. Would you recommend I delete all transcoded files for this iphone device and start over? Also, If I leave my iphone setting under media devices - transcode - to not transcribe files, will it then start to have trouble playing other files I have (ie MTS and MP4). Would it be best to go into each individual .MOV file that is playing wide and tell it to play "original file" vs delete all transcode files?

  2. #12
    Join Date
    Sep 2009
    Posts
    1,735

    Default

    I would recommend deleting all transcoded files for the iPhone then edit the device profile to remove the maxbitrate setting from the mp4 container, it is currently set to 2000000 so this is forcing your files to be transcoded because they are over this limit.

    You will need to:
    1. Open Mezzmo and stop your Mezzmo media server, then exit Mezzmo
    2. Go to your device profiles folder (see this thread for its location: http://forum.conceiva.com/showthread...ofiles-located) and edit the MariiaSmeshkova8player.prf file in a text editor and look for <maxbitrate>2000000</maxbitrate> in the mp4 container then delete this text or set the limit to 20000000 and save the file
    3. Open Mezzmo and start your Mezzmo media server

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  3. #13
    Join Date
    Aug 2015
    Posts
    35

    Default

    Quote Originally Posted by Peter View Post
    I would recommend deleting all transcoded files for the iPhone then edit the device profile to remove the maxbitrate setting from the mp4 container, it is currently set to 2000000 so this is forcing your files to be transcoded because they are over this limit.

    You will need to:
    1. Open Mezzmo and stop your Mezzmo media server, then exit Mezzmo
    2. Go to your device profiles folder (see this thread for its location: http://forum.conceiva.com/showthread...ofiles-located) and edit the MariiaSmeshkova8player.prf file in a text editor and look for <maxbitrate>2000000</maxbitrate> in the mp4 container then delete this text or set the limit to 20000000 and save the file
    3. Open Mezzmo and start your Mezzmo media server
    I am sorry to revive this problem but still gives me trouble. Bear in mind I have done the above and did not see a difference. I have noticed two things:

    1. When I use the original file, it is Rotated 90 degrees counterclockwise, has audio, and is delayed/ choppy playback.
    2. If I let Mezzmo transcode this, it leaves a wide aspect, no audio but plays much faster.

    All of these are .mov files created on an iPhone and utilizing 8player as app to play back on Apple devices (ie Iphones, Ipads, and Apple TV).

  4. #14
    Join Date
    Sep 2009
    Posts
    1,735

    Default

    Please go to 'Media Devices' and double-click the device in the list and on the Performance tab set the maximum bitrate to a very high value so that it will not get hit and trigger transcoding. The iPhone will record the video with a very high bitrate so streaming this file from the Mezzmo server to the device over wifi may be too slow and this is why transcoding to a lower bitrate improves playback, the problem is that transcoding is changing the container to mpegts which results in 8Player displaying the aspect ratio differently and uses mp2 audio which does not appear to be supported by 8Player anymore. As a test you could try editing the profile to turn off encoding for mpegts:

    <avcontainer id="mpegts" name="mpegts" mimetype="video/mpeg" encode="0" supportschunked="0" >

    and set matroska as the default format:

    <avcontainer id="matroska" name="matroska,webm" mimetype="video/x-matroska" encode="1" format="matroska" supportschunked="0" level="30" preferredtranscoded="1">

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  5. #15
    Join Date
    Aug 2015
    Posts
    35

    Default

    Quote Originally Posted by Peter View Post
    Please go to 'Media Devices' and double-click the device in the list and on the Performance tab set the maximum bitrate to a very high value so that it will not get hit and trigger transcoding. The iPhone will record the video with a very high bitrate so streaming this file from the Mezzmo server to the device over wifi may be too slow and this is why transcoding to a lower bitrate improves playback, the problem is that transcoding is changing the container to mpegts which results in 8Player displaying the aspect ratio differently and uses mp2 audio which does not appear to be supported by 8Player anymore. As a test you could try editing the profile to turn off encoding for mpegts:

    <avcontainer id="mpegts" name="mpegts" mimetype="video/mpeg" encode="0" supportschunked="0" >

    and set matroska as the default format:

    <avcontainer id="matroska" name="matroska,webm" mimetype="video/x-matroska" encode="1" format="matroska" supportschunked="0" level="30" preferredtranscoded="1">
    Tried changing under performance tab setting to from 100 Mbps to 10 Gbps and did not see a change. Did not try to transcode but then again I had the tab for that device unclicked for transcoding. So in a sense I forced the original but then got the 90 deg counterclockwise picture with normal aspect and sound. Was also still quite choppy and not viewable.


    When I went in and changed profile settings as you have listed, did same thing.

    As a separate but related issue, went back into devices by double clicking - transcode tab- then checked "transcode incompatible..." but changing the performance speed did not cause it to utilize the original file.
    Last edited by Christian; 06-27-2017 at 01:12 AM.

  6. #16
    Join Date
    Sep 2009
    Posts
    1,735

    Default

    The device profile has a 2Mbit limit on mp4 files <maxbitrate>2000000</maxbitrate> so if this is still set then changing the performance settings will not have an effect. You can try pre-transcoding the file to mp4 in Mezzmo then play it on the device to see if the aspect ratio is correct, this will reduce the bitrate also to help with the choppy playback.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  7. #17
    Join Date
    Aug 2015
    Posts
    35

    Default

    Quote Originally Posted by Peter View Post
    The device profile has a 2Mbit limit on mp4 files <maxbitrate>2000000</maxbitrate> so if this is still set then changing the performance settings will not have an effect. You can try pre-transcoding the file to mp4 in Mezzmo then play it on the device to see if the aspect ratio is correct, this will reduce the bitrate also to help with the choppy playback.
    When you mentioned in a previous post about changing performance settings, did I not enter that in right location?

    I will try later the MP4 transcode. Why do you suppose this is an issue where once before it never was ?
    Is it an update to Apple's code doing this? It seems such a waist of data to transcode a video created on an apple device to play on an Apple device. With all the Apple devices on the market, I can not be the only guy with these issues.

  8. #18
    Join Date
    Sep 2009
    Posts
    1,735

    Default

    The device profile contains limits that can override the performance settings so if you did not modify the device profile prior to changing the performance settings then this value will override them. You can modify the profile using the instructions in the previous post http://forum.conceiva.com/showthread...5592#post35592

    It is a problem with network bandwidth rather than a problem with the compatibility of the file with the apple device, the network cannot deliver the file fast enough to the player to allow smooth playback. You could try adding packetsize to the device profile <packetsize live="8192">1024000</packetsize> to see if this helps, see the ConceivaMezzmoAndroid.prf profile for an example of this.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

  9. #19
    Join Date
    Aug 2015
    Posts
    35

    Default

    Quote Originally Posted by Peter View Post
    The device profile contains limits that can override the performance settings so if you did not modify the device profile prior to changing the performance settings then this value will override them. You can modify the profile using the instructions in the previous post http://forum.conceiva.com/showthread...5592#post35592

    It is a problem with network bandwidth rather than a problem with the compatibility of the file with the apple device, the network cannot deliver the file fast enough to the player to allow smooth playback. You could try adding packetsize to the device profile <packetsize live="8192">1024000</packetsize> to see if this helps, see the ConceivaMezzmoAndroid.prf profile for an example of this.
    I went back and checked...I have the device profile set at a maxbitrate of 20000000. Device setting under performance tab has maxbitrate 10 Gbps.

    Tried adding packetsize suggestion and more less copied the way it was written in ConceivaMezzmoAndroid.prf. Still no improvement.

    The video is choppy and turned 90 degrees counterclockwise so viewing it side ways. Audio is there. Double checked on the video in Mezzmo under transcode tab for that video and it is playing original file.

    My home network has not changed; essentially running on a 5G /ASUS router. Video I'm trying to play might be 2 minutes long in this case.

    As a test, I went back to view an older and even longer video that was created similar, .mov file on iPhone. I chose one that has never given me trouble with playback. Plays audio fine, normal aspect, no 90 deg turn and not choppy. Looking at the file, it did transcode and transcoded as preferred -mov,mp4,mpa,3gp, 3g2, mj2 (-h264-aac). I thought I would run a little test. I took the same video (this latest video created on iPhone) I have been working on with you not playing correctly and forced a transcode identical to the one that plays fine. It did not work. I then for completion went back to the "old .mov movie" that plays fine and tried to use "original file" with it and it came through choppy, turned 90 deg counterclockwise, same as the problem I'm currently having with the new movie.
    So I then unchecked "original file" and had it play the transcoded file when I originally loaded it that it has above and it worked like a charm. So now my dilemma is this.
    The only difference between those two videos is the time in which they were recorded. It was the same iPhone that recorded the older and the newer video, however an older ios I'm sure. But even if I try to currently use the same transcode for the newest video that worked on the older video, it does not work. That does not make sense.

  10. #20
    Join Date
    Sep 2009
    Posts
    1,735

    Default

    The transcoding of the newer file might be different because the maxbitrate value has changed in the profile, this can have an impact upon transcoding. Try setting the value back to 2000000 then save the file and after restarting Mezzmo try pre-transcoding it to mp4 again to see if it plays.

    Mezzmo Android: Install it on your tablet, smartphone, Android TV or Amazon Fire to browse and stream files from your Mezzmo library to all your devices. Full details at http://www.conceiva.com/products/mez...mo_android.asp
    Mezzmo for Kodi Add-on: Install it into Kodi to stream files from your Mezzmo library directly in Kodi. Full details at http://www.mezzmo.com/wiki/doku.php?...odi_user_guide
    Mezzmo for Roku App: Install it onto your Roku to stream files from your Mezzmo library. Full details at http://www.mezzmo.com/wiki/doku.php?...oku_user_guide
    Wiki: User Guides & Reference Manual at http://www.mezzmo.com/wiki
    Facebook: http://www.facebook.com/Mezzmo.DLNA.Server
    Twitter: https://twitter.com/conceiva_mezzmo
    Web: http://www.mezzmo.com

Similar Threads

  1. Panasonic GT30E "to transcode or not to transcode"
    By freeman in forum Mezzmo Questions and Support
    Replies: 6
    Last Post: 01-23-2015, 08:57 AM
  2. How to Setup Transcoding to NOT Transcode On-The-Fly but ONLY Transcode Manuallly?
    By stevefoobar in forum Mezzmo Questions and Support
    Replies: 6
    Last Post: 10-22-2012, 04:03 PM
  3. Transcoding: list devices and transcode state - option to pre-transcode
    By Dillster in forum Mezzmo Wish List and Feedback
    Replies: 13
    Last Post: 01-06-2012, 04:30 PM
  4. VLC used to transcode?
    By a980652 in forum Mezzmo Wish List and Feedback
    Replies: 1
    Last Post: 04-20-2011, 08:37 AM
  5. first start transcode, second start no transcode of MKV file?
    By djvdgalien in forum Mezzmo Questions and Support
    Replies: 5
    Last Post: 01-20-2011, 08:35 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •