Samsung Smart TV connected to Hub via WIFI, & LG HB909PA Bluray Home Cinema System downstairs, wired to Hub, Desktop PC upstairs, WIFI, streaming usually fine.

My grandson is off school on the 48 hoursí sickness rule so we were due to look after him, tried to stream from PC so he had some cartoons to watch, Bluray said there was no LAN and Internet, re-booted it and PC still nothing, tried Console and PC mode in Mezzmo, nothing, Iíve just fitted a couple of Powerline plugs to connect my two Virgin boxes so unplugged them, nothing.

Swapped all the cables into different router inputs, nothing, last thought, duff cable though it had been working perfectly yesterday, used a spare, success, Bluray connected to LAN and Internet but no Mezzmo shown on server page.

After various re-boots without success I looked in the devices page on Mezzmo, there were 4 Unknown devices with the US TV standard, no idea where they came from so deleted them as well as the Bluray.

Turned on Bluray and Mezzmo appeared on the server page and worked, checked under the Mezzmo devices and noticed that I had no LG Bluray but did have a Pico Pro device, the TV was also now listed twice, Iím assuming Pico Pro is my LG player.

No great issue as itís now sorted but as an inquisitive sort does anyone know what on earth is happening, why Pico Pro and an extra TV.

Many thanks in advance.