So I finally splashed out and bought an Nvidia Shield TV (without the game controller it falls within my budget). I'm very happy with my purchase, apart from the minor disappointment of it not yet having all the Australian Catchup TV apps, and another issue I'll explain further.

I installed Mezzmo For Android on the Shield. I love the interface and this was a big factor as to why I wanted an Android box. I also installed VLC and disabled the internal player in Mezzmo so I could use VLC. In the Mezzmo server I set the device profile for the Shield to Android To VLC.

Everything worked really fine, but after a couple of days I noticed that almost everything I played was being transcoded when it didn't need to be. For example, an MP4 with H264 and AAC was being transcoded to, would you believe it, H264 & AAC!

I then noticed in the Media Devices list a second entry for the Shield with a device profile of Mezzmo (Android) and an IP of See attached image. Strangely, in the network settings of the Shield there are two MAC addresses - one just called MAC Address (EE:32) and the other Ethernet MAC Address (EE:34). I tried changing the profile in the entry but Mezzmo would not allow it to be saved with a zero IP address and would not let me edit the IP.

If I set the entry to Deny connection, nothing works. If I delete it it comes back with the next use.

I have disabled all unnecessary network options on the Shield including IPv6. All IPs on my network are static - I even allocated an address to the EE:32 MAC, but it doesn't pick it up.

Any advice appreciated.